Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Restoring- Strange results (

leslie 09-01-2007 11:55 PM

Hey guys, just found the perfect solution to all these problems with SD and it was right in front of me all the time... The answer is OS X Disk Utility - nothing to install, nothing to buy and best of all it is very fast and produces bullet proof results.
The only inconvenience is that to obtain perfect bootable clone you have to start the computer from installation CD and run it from there, but it is the price I am more than happy to pay :D

brich 09-02-2007 08:17 AM

Good luck with your solution. I've got 3 Macs running 10.4.10 with frequent smart update clones to external FW via SD. I have not experienced any bugs so far...ymmv. I had previously used CCC before discovering SD a few years back. Both are good cloning apps, but lots of us prefer the ease and reliability of SD.

This may not make a difference for you, but I'm quite anal about running DiskWarrior from external FW to optimize the internal drive's directory items. For me, the combination of DW and SD has been a recipe for seamless Mac performance.

leslie 09-06-2007 04:55 AM


Originally Posted by brich (Post 13856)
Good luck with your solution.

"Good luck"..?! You've got be joking... - This is THE only bullet proof solution (Disk Utility) to get a PERFECT CLONE on Mac OS X 10.4.10 at the moment :D
CCC Beta is crap, so SD is not alone here ;)
Well,.. I guess (as I mentioned before), Leopard will either fix all these issues or it will just make both CCC and SD redundant. My bet is for the latter...
As it is, I have removed SD from my HD and I'm more than happy to use Disk Utility to create PERFECT CLONES of my iMac :)

edoates 09-21-2007 12:52 PM


Originally Posted by dnanian (Post 13805)
SD! absolutely can be used with 10.4.10 without hassles. I'm doing it myself, as are the vast majority of users out there in the field...

Why you are having difficulty I don't know, and that's what I'm trying to help with in this thread.

Here is exactly what caused the problem for me (problem is disk images don't mount, HELP doesn't work, and SD can't schedule copies, and probably more):

Computers: both iMac G5 1.8 1GB memory, 250GB internal drive, backup drive OWC Mercury 250GB FW 400; OS: 10.4.10

Do a full backup on computer one from a drive called Ellies iMac G5

Restore on computer number two which has a running 10.4.10 on its system drive (named Jens Photo iMac G5): boot from the system drive, use preferences to change the startup drive to the FW backup, then restart.

Once restarted, start SD on the boot drive (the FW drive), and do a full backup to the internal system drive (erase and copy); I didn't rename the drive, and I didn't really check anything on the FW drive other than starting SD.

Once done, start up from the internal drive, and all sorts of problem will occur. I "renamed" the internal drive to that of the backed up (computer 1) drive, no change: HELP fail, disk images fail to mount, SD can't schedule (script error of some sort).

When I rebooted from the FW backup to check things out, it had the exact same problems even before the restore!

It would appear that there is something in 10.4.10 which gets tied to the specific hardware and/or serial numbers which was not the case in prior versions.

When I did the suggested rebuild of the launch database on the internal drive of computer 2, it seems to fix things. I still don't trust it completely, but the few things I tried appear to be OK: HELP works, images can be mounted, and SD can schedule a backup.

I hope this helps isolate the issue for SD. I prefer SD to trying to use DU because Smart backup is fast and I can schedule daily backups to unmounted (but spun up) drives, and integration with Growl can send me email on success or failure.

Eddie O

dnanian 09-21-2007 02:06 PM

Right: rebuilding LaunchServices is the solution to this. Hopefully, it'll be fixed in 10.4.11...

mykmelez 10-18-2007 02:25 AM

I'm using 10.4.10 with SuperDuper 2.1.4, and I'm experiencing this problem after restoring from backup. Unfortunately, rebuilding LaunchServices doesn't fix it for me. I tried the command-line version as well as using Onyx (both the rebuild and the reset options), but the items on my dock are still all wrong (missing or incorrect icons, clicking opens random files/applications). Anything else I can do?

dnanian 10-18-2007 09:54 AM

Are all the dock icon entries wrong? Is your destination (the drive you're now running from) named the same as the original drive?

mykmelez 10-18-2007 12:22 PM


Originally Posted by dnanian (Post 14701)
Are all the dock icon entries wrong? Is your destination (the drive you're now running from) named the same as the original drive?

The finder one is right, and there's a WMV Player icon that works. I can't remember if it worked before I rebuilt LaunchServices. All the rest are wrong, though.

However, the link to Software Update in the About This Mac dialog started working again after I rebuilt LaunchServices, so it looks like the rebuild did something, it just didn't fix the dock.

dnanian 10-18-2007 12:39 PM

Very weird. I can't get this to happen in-house, but there are a number of you it's happened to. I'm certain we've copied the relevant plist properly, but changes have been made in the OS to the way it dereferences aliases (which the Dock must be storing).

Is your drive named the same?

mykmelez 10-18-2007 02:49 PM


Originally Posted by dnanian (Post 14707)
Is your drive named the same?

Yes, my drive is named "Macintosh HD", and that's what it has always been called. In case it helps, here are the details:

My computer (32bit 2.16GHz MacBook Pro) started shutting off spontaneously a few weeks ago, so my company sent it to Apple for repair. Before they sent it off, I made a complete backup to an external Firewire drive, then I used Mac OS X's migration feature to migrate my account to a loaner laptop (32bit 2.00GHz MacBook Pro).

(Fortunately, the machine didn't shut down during either the backup or the migration.)

Apple's migration utility worked ok. Afterwards, a couple items on my dock were question marks, and I had to do a bit of configuration (don't remember what now) and reinstall a few applications (including XCode, if I remember correctly), but overall things worked out.

When I got my computer back from Apple, however, I decided to restore using SD!, so I backed up the loaner to the external drive, booted my repaired machine off the external drive, and used SD! to "back up" from the external drive to my repaired machine.

When I booted off the external drive (called "Backup"), the dock was already messed up. In fact, I think it was messed up in the same way that it's messed up now. But I didn't worry about it, assuming the problem was just that the name of the drive was different and that things would be ok after rebooting from my machine.

After I restored the backup and rebooted my machine, however, things were not ok. That's when I visited these forums, found the two threads on the problem, and tried the recommendations of rebuilding LaunchServices. I've since tried rebuilding using all three recommended tools (Onyx, Cocktail, and from the command-line), but my dock items are still all screwed up.

But like I said, it looks like they are screwed up in the same way they were screwed up when I booted off the backup drive, so it seems that the problem occurred during the backup, not during the restore.

dnanian 10-18-2007 03:02 PM

Well, except Migration would have migrated those same settings.

At this point, I'd suggest just dragging off and replacing those icons. As I've said, I assure you that we copied the file on the disk faithfully. But the Dock -- or the alias manager -- is doing things a bit differently in 10.4.10 that's causing some of these aliases to not resolve properly, even though they're bit-for-bit the same as the original...

mykmelez 10-23-2007 09:26 PM

I took your advice, emptied my dock of icons, and replaced them one by one. Afterwards, things worked fine again.

I now have to send my MacBook Pro back for repair again (they broke some things while fixing others), so I've backed up to my external drive and then restored from the external drive to a loaner laptop.

After rebooting from the external drive, all my dock icons were fine, and they stayed fine after restoring to the loaner and rebooting from the loaner's drive.

So whatever the problem was, it appears to be resolved. Perhaps rebuilding LaunchServices fixed the problem, except for icons that were already on the dock.

dnanian 10-23-2007 09:55 PM

Glad to hear it! :D

All times are GMT -4. The time now is 07:13 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.