Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Restoring- Strange results (

Jonathan Strait 08-03-2007 04:37 PM

Restoring- Strange results

I managed to successfully restore a rental macbookpro with my disc image while mine is repaired. I think....

I started up (option key) on the backup drive and then erased and copied my backup to the laptops "Macintosh HD". I used the repair permissions on backup option too..

When I restarted on the newly copied drive many of my dock icons were not recognized ("?" icons) once I clicked to launch many of those they restored fine (seemingly) Many others however were replaced with pictures (jpegs, tiffs) and other strange files from random places on my HD. Weird!

I went to try and copy the backup to the HD again and it didn't recognize it as a place to copy to. (Is that cause I'm running from there?)

Also several of the programs I started asked for serial numbers again. Is this going to happen everytime I restore??

Any other ideas of things I might want to check to be sure it's all good?

Thanks, J

dnanian 08-03-2007 06:07 PM

Try rebuilding your Launch Services database with Onyx or Cocktail. The programs asking for their SNs are likely noticing that the computer is different...

leslie 08-05-2007 05:18 PM

Same thing here... I have tried to restore multiple times and always with the same results. Since it has never happened under OS X 10.4.9 I have came to conclusion that it is due to some kind of incompatibility issues between SD and OS X 10.4.10. Just to be sure I have just restored my old 10.4.9 image without any problems. Proceeded with restoration of 10.4.10 and all those problems returned..?! I find it very surprising that no one else on this board noticed this odd SD behavior before, unless everyone here is still using OS X 10.4.9...

dnanian 08-05-2007 05:22 PM

There are strange things with LaunchServices in 10.4.10. It's not really SD! specific -- they've definitely added some, um, "features".

leslie 08-05-2007 05:32 PM

Wow, that was a quick reply :) I do have Cocktail, but I don't seem to find rebuild LaunchServices... Is there another way to do it?

dnanian 08-05-2007 05:37 PM

You can run the following in Terminal:


Frameworks/LaunchServices.framework/Support/lsregister \
-kill -r -domain local -domain system -domain user

leslie 08-05-2007 05:48 PM

Thanks again dnanian, saved the command for future use :)
P.S. Quick edit - silly me I have just found it in Cocktail 3.7.5 System Misc. Rebuild LaunchServices Database

Ramin 08-24-2007 08:00 AM

I am having the same exact problem using the latest version of SuperDuper! and 10.4.10.

Using other clone/backup tools, there is no issue. Please note that I have about 31 icons on my Dock.... IF that would make any difference.


Why do you need people's birthday?!!!!

Why do we have to go through reading those silly characters when doing a simple search here?!!!! It's really a waste of time when someone needs a quick solution to an urgent issue!

Ramin 08-24-2007 09:59 AM

A quick update: Just to re-confirm, I used NetRestore 3.3.6 which came out long before 10.4.10, to restore the same image created by SuperDuper and no problem with the icons on DOCK. Every single one of them looked and worked as supposed to.

Therefore, I am certain there is an issue with this version of your software.

P.S. Some of us need to learn to give a chance to free software applications as well!

dnanian 08-24-2007 02:03 PM

I'm not sure what you're complaining about with "silly characters", Ramin. The birthday is simply so we can send you best wishes.

If you rebuild your LaunchServices database, your icons should work properly...

day 08-29-2007 12:06 PM

Hi there,
I'm having similar problems here with a 10.4.10 clone. first thing I noticed was the "More Info..." button in the "About This Mac" window led to an obscure resource file within the address book application, instead of system profiler. after some googling, I rebuilt Launch Services database w/ Onyx, and that was fixed. but then, a day or so later, a couple of dock shortcuts also led to seemingly random files, often within application packages. I ran AppleJack, and then rebuilt my database with Diskwarrior. When I rebooted, instead of application shortcuts in my dock for Illustrator and InDesign, there were zero-K files in my trash, named "" and "PathForApplication.indd", with the correct icons.

Anyhow, now, several days later, it just happened again -- a shortcut in my dock led to some ".nib" file - I think within Address Book.

Any thoughts? is my newly rebuilt sytem hosed? Things seem to be working otherwise, but these issues give me pause.

I should add, love SuperDuper! (never had a problem before this, and it's helped me out immensely!)


dnanian 08-29-2007 12:09 PM

I'm confused -- you can't rebuild your LaunchServices database with DiskWarrior, David. Did you rebuild LaunchServices a second time?

day 08-29-2007 12:29 PM

sorry to be vague -- yes, I rebuilt LanchServices database w/ Onyx.
I later rebuilt my directory DB with DiskWarrior.
I should add this is on a brand new, fresh system (+apps) install...

dnanian 08-29-2007 12:33 PM

OK. I'd try rebuilding LaunchServices again; LS has been rather weird under 10.4.10...

day 08-29-2007 12:38 PM

Hi Dave,
thanks - will give it a shot. will keep you posted...

All times are GMT -4. The time now is 05:01 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.