PDA

View Full Version : sparse bundle slowness


astrodog
04-10-2012, 11:00 PM
I have a clone of my main hard drive stored on a NAS as a sparse bundle.
I use a different volume (just a bootable FW drive with my utilities on board) to boot from when performing a smart update.
The sparse image has the same name as my main volume (hdd).

The problem - if I mount the sparse image while booted from my main drive (clones of each other), the mounting takes about 3 minutes, then navigation of the image is very slow, then unmounting takes about 3 minutes again.
Mounting/unmounting of the clone, when system booted from the external maintenance volume is near instantaneous.

Is this expected? Would this be due to the volume/clone having the same volume name?? I restored the sparse image to a spare drive last night, and it seems to be fully intact....

dnanian
04-11-2012, 09:22 AM
I don't have any idea why that would be - perhaps you're running some software that's interfering with networking, file access, etc?

Try starting up in, say, Safe Boot to see if that makes a difference.

astrodog
04-12-2012, 12:30 AM
I'll try that, last night I deleted the old sparsebundle, and made a new one, with a name different to its parent volume.... still had trouble (slow) opening when booted from the volume it was cloned from.....

astrodog
04-12-2012, 09:16 AM
Safe boot - can't connect to the NAS at all....
So a basic lion install on a FW drive can open/close these large sparsebundles without delay, and my main account on internal drive takes 2-3 minutes to do either....
An error I noted in console, which appeared at the end of the pause, as the image mounted:

Apr 12 21:51:56 xxx-MacBook-Pro fseventsd[40]: event logs in /Volumes/FW800-backup/.fseventsd out of sync with volume. destroying old logs. (560 1 850)
Apr 12 21:52:00 xxx-MacBook-Pro fseventsd[40]: log dir: /Volumes/FW800-backup/.fseventsd getting new uuid: 04C3AC65-EF65-4F4E-8EE9-62FED2737EEA

Any ideas?
I've also disabled time machine and spotlight with no change.....

dnanian
04-12-2012, 09:30 AM
The implication to the above is that the drive was incorrectly ejected, and that it needed a new fsevent database. That also likely means the delay in mounting is because it's doing an fsck on the volume.

astrodog
04-12-2012, 09:36 AM
Possibly - I think I restarted the sucker while waiting for it to eject before - but this behaviour is every time I try and mount from my main account. Every time I try and mount from a different user on my main drive its perfect, as it is from a different boot drive....
Are there any preference files you think I should delete? - seems like a problem with this user account....

(I realise this isn't a SD! fault, but really do appreciate your help!)

dnanian
04-12-2012, 09:41 AM
I don't know any. You can try to look at Activity Monitor (all processes) to see what's taking the time - that might give you a clue. Seems clear it's *something* you're running.

astrodog
04-12-2012, 09:48 AM
I've been watching Activity Monitor like a hawk, and console log, there is nothing taking up any appreciable amount of processor cycles at all.... Certainly no other apps running either....
Really irritating now..... accessing any other files through the NAS work great - DVD isos etc, just not these sparsebundles....

Its far from mission critical, I always use the separate drive to boot from when doing backups in any case, I just don't like that something is obviously not working....

astrodog
04-12-2012, 09:58 AM
Well bugger me - deleting Finder and Sidebar prefs fixed it.....
This had been irritating me for weeks....

dnanian
04-12-2012, 10:02 AM
Really? That's...bizarre. But I'm glad that you're all set.

astrodog
04-12-2012, 10:10 AM
:) I was ready to trash the whole prefs folder.....
Thanks for your help, as always....

astrodog
04-12-2012, 07:44 PM
Bugger.... this am we are back to how it was - this is strange....
All I did between it working fine last night, and not this am, was boot into my external volume and run a surface scan (Drive Genius) on the main laptop drive, then reboot into the main account.
I'm creating a similar bundle on my other NAS today, to see if this issue is specific to this NAS, but I suspect it will do the same, given the other accounts aren't affected.

astrodog
04-16-2012, 10:51 PM
Will post my solution in case others affected one day...
Deleting prefs above seemed to work for a short time... minutes usually, before error recurring.
I found a webpage from Apple suggested deleting cache files in cases of single user account problems, so I ran Cocktail to delete all cache files it could find, and everything has been perfect ever since....
No idea which file was corrupt, probably never know now! :)