Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-08-2009, 12:36 AM
Sophie Sophie is offline
Registered User
 
Join Date: Apr 2009
Posts: 22
Before-Copy script failure

I have this as my "quit_vmware.sh", set to "Run before copy":
#!/bin/sh
osascript -e 'tell application "VMWare Fusion" to quit'
------------

The scheduled backup worked fine with VMWare 2.x.

A couple of days I upgraded to VMWare 3.0. Now my backup stops at the Run-before-copy stage, although the quit_vmware script runs and successfully shuts down VMWare. The SD log shows:

| 10:04:41 PM | Info | ...ACTION: Running shell script quit_vmware.sh
| 10:04:41 PM | Info | ......COMMAND => Invoking Before Copy shell script: /Users/s/Library/Scripts/quit_vmware.sh
| 10:04:41 PM | Error | file:///System/Library/ScriptingDefinitions/CocoaStandard.sdef:2: I/O warning : failed to load external entity "file://localhost/System/Library/DTDs/sdef.dtd"
| 10:04:41 PM | Error | <!DOCTYPE dictionary SYSTEM "file://localhost/System/Library/DTDs/sdef.dtd">
| 10:04:41 PM | Error |
-------------
When I run the script from Terminal, I see this:
>> ./quit_vmware.sh
file:///System/Library/ScriptingDefinitions/CocoaStandard.sdef:2: I/O warning : failed to load external entity "file://localhost/System/Library/DTDs/sdef.dtd"
<!DOCTYPE dictionary SYSTEM "file://localhost/System/Library/DTDs/sdef.dtd">
^
>> echo $?
0
------------
So, VMWare seems to be printing out some message (no idea what it means), but, importantly, seems to exit with a "Success" code of 0.

Am I reading this correctly? Should SD be aborting the backup if the exit code of the script is "0"?

Thanks!

p.s. strange thing, running the script even with VMWare Fusion not running still gives exactly the same result, both in Terminal and in SD.
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting from backup guruuno General 27 10-17-2009 12:53 AM
Failed to copy error lmatheo General 1 03-20-2009 09:27 AM
fix-prebinding fails after successful (smart) copy rlfsoso General 2 01-06-2009 09:27 AM
Persistent failure to copy radicalkat General 1 08-10-2007 09:00 PM
Error: No space left on device tradervic General 11 06-29-2005 05:50 PM


All times are GMT -4. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.