Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-24-2006, 12:43 AM
jefman jefman is offline
Registered User
 
Join Date: Mar 2006
Posts: 6
feedback from a first-time backup

hi -

i just completed my first successful (i hope!) backup! thought you might like a bit of feedback, mainly about the stupid mistakes i made...

my plan was probably the most typical one - to make a full backup to my external drive, onto a sparse image so i don't need to repartition, but to exclude a few large folders that really don't need backup (eg. garageband loops). i know you "highly recommend" backing up the whole drive, but for many people that probably isn't practical. anyway, the fact that SD lets me do exclusions easily (and make a bootable copy) is a great improvement over my old method, which was to move these files to a temporary folder, drag the rest to a folder on the external drive, then move them back. i've tried some other backup programs, like retrospect, but they were too awkward. i really don't need incremental backup - i don't want to save a new copy of my 100MB inbox every time i download my mail!

the manual was very helpful, although i think it provided perhaps a little too much information right at the beginning. by the time i had read ten or twenty pages about various options like the "sandbox", automatic scheduling, network backups, and so on, i was starting to get a little weary. but no problem, i guess one should understand what's going on. i made it through (but i doubt my mom would have!). by page 25 i knew what i needed to, how to create a script to exclude the things i didn't want to back up.

my first real problem came when i finished making the script, and clicked the "close" button. i was asked to save it, and i did so, to a folder in my home directory where i normally would keep a document like this. but then i couldn't figure out how to select it for use! now, there's a short sentence at the top of page 25 that says to save it "with an appropriate name in the default location". well for me the "default location" is that folder in my home directory... ok, let's try again - this time i'll just put it where the file save dialog opens up. ok, "standard scripts" - so i clicked on that and saved it there. which ended up actually inside the application itself! fortunately i understand this concept and know how to control-click, show package contents, etc. - but for most people i think we are not in kansas anymore...

i think this is a bit of a rough spot in the user interface - SD shouldn't let me make this mistake. if copy scripts don't work unless they're saved in the correct folder in "applications support" then i shouldn't be presented with a file dialog that lets me save it somewhere else. the easiest thing would be for SD to silently save them in the right place. personally i would rather see it work in a more "mac-like" way - if i create a script related to my own files, i'd like to be able to save it as a document where i want, and to double-click on it to run it. that document should also include the other options for source and destination, what to do during copy, and so on, rather than those things magically being remembered from the last time i did something. in other words, any work i do setting up configuration, i would like to keep in a document separate from SD itself, in my own folder and not in Application Supprt. i know this is quite a departure from how SD works at the moment, but as i said it seems more "mac-like" to me.

after that, things went smoothly, and a while later i had my backup image. i mounted the image to have a look, hoping that it would look just like the original drive. i noticed a couple of things that were different. i think it would make people feel more secure if you explained any differences between their backup image and the original drive, in the manual.
- folders such as Applications etc. just have generic icons. i understand that's normal, and that they should come back on a restore, but again you might want a note about that in the manual.
- in the root directory, there's a file called "Desktop DB", and an empty folder called "dev". i understand that's probably normal, but i think they should perhaps be hidden.

on the other hand, there were things i somehow expected *would* be different:
- my Firefox webpage cache folder, and a bunch of other things in ~Library/Caches were copied, i kind of assumed they wouldn't be. you should either not copy them, or tell people to empty their caches before backing up.

well that's about it for now, all in all a good experience so far. hope these comments may be of some help to you - although not as much help as SD has already been for me!
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to verify a Scheduled Backup? tuqqer General 3 12-06-2005 07:50 PM
(Zero-length) File caused SuperDuper to abort backup alancfrancis General 7 08-31-2005 11:42 AM
Could not disable Ignore Permissions - each time I backup Tricia Henwood General 3 08-08-2005 08:57 AM
Smart Backup Error bill s General 20 02-04-2005 10:46 AM
1st backup clone to ext dr estimated time ?? esuebrown General 3 07-24-2004 05:31 PM


All times are GMT -4. The time now is 07:03 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.