Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-12-2010, 11:33 PM
michelh michelh is offline
Registered User
 
Join Date: Mar 2009
Location: Sydney Australia
Posts: 6
Unable to eject sparse image on NAS drive

I am using SuperDuper to backup to a sparse image on a NAS drive. When the backup process does not complete, so I redo the backup.

Sometimes I am unable to eject the sparse image and i get this message: "The volume could be be ejected because it is currently in use." Even when I close all apps and data files, I still can't eject the sparse image and nor the NAS drive. I only have this problem when I use SuperDuper.

I have no problems directly opening the sparse image from the desktop.

The SuperDuper log reads:
| 12:19:39 PM | Info | ......COMMAND => Setting ownership and access modes for '/Volumes/mbhbackup/Macintosh backup NAS.sparseimage'
| 12:19:39 PM | Info | ......COMMAND => Mounting Macintosh backup NAS
| 12:19:40 PM | Info | /dev/disk4 GUID_partition_scheme
| 12:19:40 PM | Info | /dev/disk4s1 EFI
| 12:19:40 PM | Info | /dev/disk4s2 Apple_HFS /Volumes/Macintosh backup NAS 2
| 12:19:40 PM | Info | ......COMMAND => Mounting Macintosh backup NAS
| 12:19:40 PM | Info | Waiting for Macintosh backup NAS to mount.
| 12:19:42 PM | Info | Waiting for Macintosh backup NAS to mount.
| 12:19:44 PM | Info | Waiting for Macintosh backup NAS to mount.
| 12:19:46 PM | Info | Waiting for Macintosh backup NAS to mount.
| 12:19:48 PM | Info | Waiting for Macintosh backup NAS to mount.
| 12:19:48 PM | Error | Failed to mount Macintosh backup NAS
__________________
regards
Michel

iMac 24" 2.4 Ghz Intel Core 2 Duo, Max OS 10.5.6
Drives: LaCie 125Gb, LaCie 250 Gb, Lacie 500Gb, LaCie 1Tb, Synology NAS 1Tb
Reply With Quote
  #2  
Old 08-13-2010, 08:29 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
From what I can tell, you may have a bunch of bad mount points in /Volumes. Use Finder's "Go To Folder" command to open /Volumes. In there, you'll find one or more folders (not aliases/symlink) with the name of the image. Delete those and empty your trash, then restart your Mac.

The backup "not completing" seems like it's because your network connection is failing, or your NAS is dropping the connection/failing.

As far as "can't eject" goes - this may be because Spotlight is indexing the image, or because an AntiVirus program has active files up there. We certainly don't have active files when we're not running...
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 08-18-2010, 11:11 AM
michelh michelh is offline
Registered User
 
Join Date: Mar 2009
Location: Sydney Australia
Posts: 6
Thanks for your reply. I did as you suggested. Subsequently I used SD to backup the computer to an external HD and to a sparse image on a Synology NAS drive. The backup worked for both, but the sparse image did not unmount with the message that the disk is in use and cannot be ejected. The only way to unmount the sparse image and NAS drive was to restart the Mac.

This unmounting problem only happens when using SD. There are no problems in normal use of files on the NAS drive or in opening the sparse images on the NAS drive. I am not sure if this is only a problem occurring in backing up the computer. I use SD with other volumes without issue but then these are less than 5GB.

The Synology wiki community could not give any suggestions if the NAS drive is at fault. There are threads in the Apple discussion forums highlighting problems with Mac disconnecting external servers but no solutions seemed to have been found and Apple is being blamed.

Could you advise further please? Would using sparse bundles be better?
__________________
regards
Michel

iMac 24" 2.4 Ghz Intel Core 2 Duo, Max OS 10.5.6
Drives: LaCie 125Gb, LaCie 250 Gb, Lacie 500Gb, LaCie 1Tb, Synology NAS 1Tb
Reply With Quote
  #4  
Old 08-18-2010, 12:52 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
I can only suggest that it's because of what I mentioned above. You might find using lsof (list open files), filtered by the volume name, will help you determine what files are actually active and preventing eject...
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows equivalent to SuperDuper!? jreffner General 21 08-13-2009 06:36 PM
SD not unmounting sparse image volumes acronce General 1 09-14-2008 12:22 PM
Hangs while backing up to network mounted sparse image acronce General 9 09-11-2008 02:25 PM
Unable to mount sparse image on network attached drive mj71 General 2 09-22-2007 09:42 AM
Sparse image from aborted DMG backup? Winston General 9 10-22-2005 01:28 PM


All times are GMT -4. The time now is 01:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.