Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-09-2008, 03:21 AM
Harry Cover Harry Cover is offline
Registered User
 
Join Date: Dec 2005
Posts: 64
Weird

I make mirror BUps of my H Disks.

I have noticed that when one of my copied HD is not mounted, alias files/folders pointing to this unmounted disk points to its mirror disk.
This modification persists even after the copied disk has been monted back.

This issue may be dangerous, the next SD BU is going to erase the modified/created files/folders on the mirror HD without the user knowing it.

Is this known ?

MacOS X 10.4.11
Reply With Quote
  #2  
Old 02-09-2008, 03:53 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
Are you sure you're making a "Backup - all files" as opposed to a "Sandbox..."?
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 02-09-2008, 08:37 PM
RickO RickO is offline
Registered User
 
Join Date: Feb 2008
Posts: 3
I'm thrilled to finally have a Leopard-compatible SuperDuper, but I thought I'd note that I'm seeing similar behavior.

I have Leopard (10.5.1) running on a MacBook. I have Time Machine backing up to a partition on an external USB2 drive (call that volume TMbackup) and SuperDuper 2.5 cloning my MacBook's internal drive to a second partition on the same external drive (call that volume SDdupe).

When the drive is attached, both volumes show up in the Finder side bar. The Time Machine volume has a Time Machine drive icon and the SuperDuper volume has a generic external drive icon. Both volumes can be ejected using the eject button that appears next to the volume name.

When I do eject the two volumes and disconnect the external drive, a new item appears in the Devices list of the side bar -- an alias with an internal drive icon and the same name as my MacBook's internal drive. If I select that item in the side bar, I see the list of the root contents of my internal drive. If I select one of the items in the finder window, then the selection jumps over to the actual internal drive object that appears in the side bar.

When I reconnect the external drive, the alias object disappears and the two backup volumes appear, but they now both have generic external drive icons and there is no eject button next to the SuperDuper volume.

If I drag the alias object from the sidebar before reconnecting the external drive, the SuperDuper volume does not appear in the side bar when I do connect the external drive. If, when the external drive is connected, I use finder preferences to specify that all external drives should be shown in the side bar, then the SuperDuper volume reappears and looks as expected (i.e., icon, eject button).

As the OP said, it's weird.
Reply With Quote
  #4  
Old 02-09-2008, 08:58 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
I don't think that's at all the same, Rick -- he's seeing aliases of files on his backup drive itself, whereas you're seeing some aliases in Devices, which I've seen on many systems -- I think that's a more general Leopard bug.
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 02-09-2008, 11:13 PM
James James is offline
Registered User
 
Join Date: Jul 2007
Posts: 37
To Rick, I have that bug and I have had it since before using the latest version of SuperDuper. My internal drive is called "MacBook" and has no custom icon. I connect a Firewire drive that has three volumes, all three have no custom icons and show up as the orange Firewire icon. When I eject every volume on the Firewire drive at the same time, either by holding the "Option" key while ejecting a volume or by choosing "Eject All" from the pop-up box, I am left with a duplicate of "MacBook" in the Finder sidebar that has the same internal icon. This disappears when I reconnect the drive, but it also disappears if I open Finder's Preferences and go to the Sidebar tab and under Devices, uncheck External Disks. I have put it down to a (annoying) Finder bug that I hope will be fixed in 10.5.2.


Harry, here is something I have observed with alias's on Leopard and if I remember right (probably not) it wasn't like this on Tiger, which is what I see you're using, though you're using 10.4.11 and the version I last used was 10.4.9, I'm not sure if anything has changed from 10.4.9 but, anyway.

If I attach my backup (a full clone called "MacBook Clone"), navigate to somewhere like CoreServices (on "MacBook Clone") and make an alias of this folder on my desktop, doing a "Get Info" on the CoreServices alias shows that it points to "/Volumes/MacBook Clone/System/Library/CoreServices/". After I eject the "MacBook Clone" volume, doing a "Get Info" on the CoreServices alias shows that it now points to "/System/Library/CoreServices/" and this path does not change after the "MacBook Clone" volume is re-attached.

I don't think this is the correct behavior for an alias, is it? Dave, can you tell us how they should function so we can determine if what we're seeing is a bug, modified behavior or correct behavior and for me a dodgy memory.

Last edited by James; 02-09-2008 at 11:16 PM.
Reply With Quote
  #6  
Old 02-09-2008, 11:52 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
I think that since the two files are going to have the same "signature" and information, the alias re-maps itself to the one that's available...
__________________
--Dave Nanian
Reply With Quote
  #7  
Old 02-10-2008, 01:17 PM
RickO RickO is offline
Registered User
 
Join Date: Feb 2008
Posts: 3
Thank you Dave and James for the clarification. It's very helpful. Sorry to sidetrack the thread.
Reply With Quote
  #8  
Old 02-10-2008, 05:01 PM
BlackPearl BlackPearl is offline
Registered User
 
Join Date: Feb 2008
Posts: 1
just a quick question to RickO and James

what kinda partition do you have?

GUID Partition
Apple Partition

i had the same problem and my hdd had a Master Boot Record Partion ( don`t ask me why)

i got rid off it with a GUID Partition (Intel iMac)
Reply With Quote
  #9  
Old 02-10-2008, 10:46 PM
RickO RickO is offline
Registered User
 
Join Date: Feb 2008
Posts: 3
The partition map scheme for my external USB2 drive is GUID Partition Table. As I recall, that's the configuration that was recommended when I first prepped the drive for Time Machine.
Reply With Quote
  #10  
Old 02-11-2008, 03:22 PM
James James is offline
Registered User
 
Join Date: Jul 2007
Posts: 37
All of my partition maps are GUID.
Reply With Quote
  #11  
Old 02-14-2008, 01:23 AM
Harry Cover Harry Cover is offline
Registered User
 
Join Date: Dec 2005
Posts: 64
Quote:
Originally Posted by dnanian View Post
Are you sure you're making a "Backup - all files" as opposed to a "Sandbox..."?
Yes, Dave, I am making a "Backup - all files".

Thanks for your help.
Reply With Quote
  #12  
Old 02-14-2008, 11:01 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
I'm not sure what to suggest here. Aliases kind of do that, and will resolve to the different drive if the files are the same...
__________________
--Dave Nanian
Reply With Quote
  #13  
Old 02-14-2008, 11:27 AM
Harry Cover Harry Cover is offline
Registered User
 
Join Date: Dec 2005
Posts: 64
Quote:
Originally Posted by dnanian View Post
I'm not sure what to suggest here. Aliases kind of do that, and will resolve to the different drive if the files are the same...
Bug or feauture... ?

Unsecurity anyway.
Reply With Quote
  #14  
Old 02-14-2008, 11:55 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,761
Send a message via AIM to dnanian
It's really something in OS X, though... perhaps report it to Apple?
__________________
--Dave Nanian
Reply With Quote
  #15  
Old 02-14-2008, 02:05 PM
Harry Cover Harry Cover is offline
Registered User
 
Join Date: Dec 2005
Posts: 64
OK, Dave.
Thanks a lot.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
weird dock jayartibee General 4 09-12-2007 10:00 AM
Weird problem badlydrawnboy General 8 07-16-2006 04:17 PM
Weird folder "dev" on target volume mypointofview General 1 07-03-2006 01:27 AM
Weird stuff resolved Lee Carroll General 1 02-22-2006 12:54 AM
Weird Question fdwlaw General 3 06-06-2005 10:50 AM


All times are GMT -4. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.