Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > netTunes > General

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #2  
Old 02-23-2003, 10:05 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,780
Send a message via AIM to dnanian
First, let me apologise for any difficulty you've been experiencing. As you can see from the other messages in the forum, this is the first time this "looping problem" has been reported, and I'd certainly like to get to the bottom of it.

There are a few other issues here, so let me try to address each one:

- iTunes does, indeed, have to be "on top" for a seamless experience. I'd love for it to be "smarter" than that, but unfortunately there's no way to get at the "back buffer" -- the drawing area the compositor uses to create the screen image. So, I have to resort to screen scraping (which is what VNC, Apple Remote Desktop and everything else has to use as well).

- netTunes does tell iTunes to move "on top" when you initially connect -- if it's possible, it'll move to the top at that time.

- Having another window on top won't -- or rather, shouldn't -- impact your session: if you close that window (in the case of a dialog) or click on the iTunes window (if you can see it), it should move right to the top. If it's something that's forced "on top", it has to be dismissed manually. Note that sizing your iTunes window to close-to-fullscreen will allow these situations to be covered handily.

OK, so on to the "looping". That's really something I've never heard of before, at least in a specific-to-netTunes kind of way. Were you previously using iTunes with VNC without any difficulty? I do have quite a few users who operate netTunes "headless" without this kind of problem (my server is an iMac, so I can't remote the display to check, unfortunately).

netTunes isn't -- or rather, shouldn't be -- doing anything that would cause sound looping, since it doesn't really interact with the sound in any way. But there must be *something* going on that might explain things: when you say things "went downhill", did that happen as you were using the iTunes controls, the direct controls, or while playing with the System Preferenecs app? Had you disconnected and reconnected? Anything at all that might help point me in a direction that would allow reproduction of the problem?

Thanks for spending the time to contact me -- I'll do my best to get this taken care of.
__________________
--Dave Nanian
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My server doesn't show up! dnanian General 0 01-04-2003 01:41 PM
AirPort base station as server: can't connect! dnanian General 0 01-03-2003 12:48 PM
running a headless netTunes server tgibbs General 1 08-20-2002 10:50 PM


All times are GMT -4. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.