Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-05-2008, 09:40 AM
raf raf is offline
Registered User
 
Join Date: Jan 2007
Posts: 14
Can SD! be safely used under Leopard if one is NOT using Time Machine?

I have upgraded to Leopard and need to perform backups. I would rather continue to use SD! and not switch to CCC, but I can't seem to find an answer to the above question and I am concerned about the lack of reliable backups. I need to travel late next week and would really like to get a backup of my laptop before I go.

Can anyone with relevant knowledge provide an answer?

Thanks,
Martin
Reply With Quote
  #2  
Old 01-05-2008, 10:12 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,745
Send a message via AIM to dnanian
Not until our Leopard version is out.
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 01-06-2008, 08:21 AM
justG justG is offline
Registered User
 
Join Date: Oct 2007
Posts: 42
Quote:
Originally Posted by raf View Post
I need to travel late next week and would really like to get a backup of my laptop before I go.
Use Disk Utility.
http://shirt-pocket.com/forums/showthread.php?t=3371
Reply With Quote
  #4  
Old 01-06-2008, 08:59 AM
raf raf is offline
Registered User
 
Join Date: Jan 2007
Posts: 14
Thanks for the suggestion. Looks like that's the route I'll take. Too bad its so slow.

Martin
Reply With Quote
  #5  
Old 01-06-2008, 12:27 PM
villaman villaman is offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Thumbs down Unhappy Camper

I'm really disappointed with the situation here.

I have been backing up my 10.5.x install for a month or so using SuperDuper with out any knowledge of it's inability to properly perform it's job. There really should have been some information passed along to the user via the application interface regarding this. This is not a minor thing! Not everyone follows all the blogs & forums for each piece of software they buy.

As for the decision to add Time Machine support, I wish there was a "dot" release before the "new features" release to get things working on Leopard. I am sure there are a heck of a lot of people out there who are upgrading to Leopard who can do without Time Machine. I'm also quite sure there aren't that many people out there who are willing to upgrade to Leopard and forgo backing up for the couple of months it takes you guys to catch up.

I feel you dropped the ball on this one guys. If I hadn't tried rebooting from my backup this past week out of habit I wouldn't even know the danger I was in! Now I have to check out CCC or Disk Utility to hold me over until the next SuperDuper release comes out.
Reply With Quote
  #6  
Old 01-06-2008, 12:32 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,745
Send a message via AIM to dnanian
I'm sorry you're unhappy, villaman.
__________________
--Dave Nanian
Reply With Quote
  #7  
Old 01-06-2008, 08:11 PM
villaman villaman is offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Addressing Concerns

Hi Dave,

I wasn't posting here looking for an apology. I was more thinking along the lines that you might address the concerns raised in my previous post. Specifically:

1. Users need to be informed when their software is no longer functioning properly. As I stated above, if I hadn't tested my clone the other night I would still be blissfully unaware that I was no longer properly backed up. Will any effort be made to remedy this situation? Not everyone is checking the website and/or reading the blog/forums. Especially in these times of built in application updates. I asked SuperDuper to check for updates and it said I was up-to-date. I assumed this meant I was good to go. I mistake on my part but I don't think it an uncommon one.

2. I would hope that an emphasis would be placed on keeping the software functional vs adding new functionality. Any comment on this? I see updating for Time Machine as adding new functionality where as releasing an update prior to that to restore basic cloning would be keeping things functional. It's obviously your call as to which road to take but I would like to know your opinion on this so I can be better prepared for future system updates.

Thanks.
Reply With Quote
  #8  
Old 01-06-2008, 08:44 PM
justG justG is offline
Registered User
 
Join Date: Oct 2007
Posts: 42
Quote:
Originally Posted by villaman View Post
1. Users need to be informed when their software is no longer functioning properly.
Sure, if you were still using Tiger and a bug was introduced in a new build that got pushed out, a fix needs to be pushed out, the blog needs to be updated, e-mails to customers need to be sent.

That's not what happened here. You upgraded your operating system, the thing on which all other things run. It's *your* responsibility to make sure that the software on which you rely is compatible with your OS, you can't just assume that you can upgrade your OS and everything will work!

SuperDuper! functions properly if it's run on the version of the OS for which it was created and is guaranteed compatible. Simple.

Quote:
2. I would hope that an emphasis would be placed on keeping the software functional vs adding new functionality. Any comment on this?
Please read the posts regarding this on the forums as well as Shirt Pocket's blog. This has been addressed by Dave at length. The gist of it is that this isn't about new features, this is about making the software compatible with the operating system, which happens to encompass Time Machine issues among other things. From what I understand, SuperDuper! could *not* simply be updated to support Leopard without addressing what you're calling a new feature.
Reply With Quote
  #9  
Old 01-06-2008, 09:35 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,745
Send a message via AIM to dnanian
JustG has pretty much covered it, villaman. Before Leopard was released, I provided information here, on the SuperDuper! page and on the blog about Leopard compatibility. All of the various web sites that list these things were informed that SD! wasn't fully Leopard compatible. I didn't do a "direct mailing" to SD! users because we never direct mail users... but apart from that I certainly endeavored to inform everyone...
__________________
--Dave Nanian
Reply With Quote
  #10  
Old 01-06-2008, 09:50 PM
dancingbrook dancingbrook is offline
Registered User
 
Join Date: Jan 2008
Location: Earth
Posts: 7
Villaman,

On the forum for the "other" app, you would be berated by the hosts quite thoroughly for even suggesting what you did here. That's not right, and it hopefully won't happen here (surely not by the hosts, but perhaps other users).

I think it is fair to ask when was the last time Apple sent you a notice about a problem? Not to dismiss your suggestions, just to point out it is pretty standard practice to not send out notices (probably to avoid the sue happy lawyers and their class action law suits). Besides, can you imagine the onslaught of inquiries they'd have to deal with; talk about whacking yourself up beside the head.

That said, I think it is indeed a good idea, when upgrading your OS, even with a minor upgrade, to wait and to check with all the developers of all your mission critical apps before upgrading. I did tech support in a Mac office and we always did extensive testing before upgrading anything. If you simply wait a week or so, and then check with the developer's website, you should be in good shape. There are always some (of us) fools willing to be on the bleeding edge. Either way, it is safe to assume there might be problems, so checking first is always a good idea. The developers don't always get the upgrades before we do so in some cases they couldn't send out advance notices.

Consider yourself lucky you didn't make the your comments on the CCC forums (besides, just because they say they are Leopard ready, doesn't mean they really are). In the mean time, while we all wait, either Disk Utility, and/or time machine should keep your data safe, even if it is a bit of a slower solution for now.

db
Reply With Quote
  #11  
Old 01-07-2008, 03:36 AM
villaman villaman is offline
Registered User
 
Join Date: Jan 2008
Posts: 5
I definitely wasn't asking for or advocating a "mass mailing" but rather thought some kind of notification might be presented through the software itself. That sounds reasonable to me. If an application can check for updates I don't see why it can't check for incompatibilities as well. It might be an unusual practice but SuperDuper! is in a unique class of software and we place a lot of trust in it. At there very least, consider it a feature request then.

Quote:
Originally Posted by justG View Post
That's not what happened here. You upgraded your operating system, the thing on which all other things run. It's *your* responsibility to make sure that the software on which you rely is compatible with your OS, you can't just assume that you can upgrade your OS and everything will work!

SuperDuper! functions properly if it's run on the version of the OS for which it was created and is guaranteed compatible. Simple.
OK, I agree with this. I apologize Dave if my concerns and criticisms were worded too harshly. I guess I've always been very satisfied with SuperDuper! and this experience was a bit of a let down. Lesson learned, I'll be more vigilant with regards to my upgrading practices in the future.

Again, thanks to everyone who took the time to respond. I appreciate it, even if I did sound like a whiny so and so.
Reply With Quote
  #12  
Old 01-07-2008, 07:24 PM
thf thf is offline
Registered User
 
Join Date: Jan 2008
Location: Santa Fe, Nuevo México
Posts: 7
ridiculous

Hi Folks,

I'm a registered and basically happy SuperDuper user. Waiting not too impatiently.

BUT for Villaman to apologize if ridiculous.

> I apologize Dave if my concerns and criticisms were worded too harshly.

How is it POSSIBLE that one can STILL goto the homepage, read it carefully (especially noting the "leopard support"), click on "Buy Now!" and then on "more info" (being careful, after all) and then make a purchase... and NEVER see one word about the fact that SD does NOT work with the current, shipping Mac operating system.

There should be a GIANT RED BANNER on the homepage saying "DANGER, this software does NOT WORK with Leopard".

How can this be justified? It's been MONTHS. I'm not talking about "it's been months so the update should be ready" (that's a whole nother discussion). The homepage STILL makes it sound like everything's just fine and that, say, a new Mac switcher can safely rely on SD to do what it's known for.

Knowing that SD is a great program, that Dave is a good guy, that Shirt-Pocket is a small outfit, etc, etc is totally beside the point. I should think any impartial visitor would think that the homepage is duplicitous.

Ridiculous.

Tom
Reply With Quote
  #13  
Old 01-07-2008, 07:49 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,745
Send a message via AIM to dnanian
Tom, the SuperDuper! page does absolutely have information at the top that specifically indicates that it's not compatible. It points to the blog, which has even more information.
__________________
--Dave Nanian
Reply With Quote
  #14  
Old 01-09-2008, 01:59 AM
sdsl sdsl is offline
Registered User
 
Join Date: Dec 2005
Posts: 64
Quote:
Originally Posted by villaman View Post
I definitely wasn't asking for or advocating a "mass mailing" but rather thought some kind of notification might be presented through the software itself. That sounds reasonable to me. If an application can check for updates I don't see why it can't check for incompatibilities as well. It might be an unusual practice but SuperDuper! is in a unique class of software and we place a lot of trust in it. At there very least, consider it a feature request then.
Well, I will put in a vote *against* this sort of "notification," which seems to be not unlike the ways some spyware works. Do we want software we have installed to audit our operating systems (and possibly other aspects of our computers) and then report back to the home company with such data, which will then have to be checked against some data base for what works and what doesn't and then a message or pop up sent back to the user to either warn against using or simply refuse to run due to not meeting the requirements for the current version? Which will lead to all kinds of users arguing that the "auditing" process was flawed (which is quite possible) and their systems really are ok and so forth.

I'm fine with SuperDuper noting that a new version is available and offering to download it, but doing an "audit" of the user OS to make sure it is "ok" is more than I want a program like this to do. I prefer for the software to stay on the simpler side here and hence fewer failure modes will be likely.

I think the person who upgrades his/her OS and then gets mad because some existing software doesn't work has things upside down. The user is the one who has the onus to make sure software works when changing the OS. This has always been the case in the computer world.

Also, it is very clear (to me) in looking at SuperDuper's web page that the latest OS to use it with is Tiger, and that for Leopard one has to wait until an updated version comes out. There are plenty of other software packages in a similar situation, by the way.

From the SuperDuper home page:
"Leopard Infomation
SuperDuper! 2.1.4 is not yet fully Leopard compatible. But we're working hard to get it done as soon as we can."

Sounds pretty clear to me.

Last edited by sdsl; 01-09-2008 at 02:02 AM.
Reply With Quote
  #15  
Old 01-11-2008, 05:54 AM
villaman villaman is offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Quote:
Do we want software we have installed to audit our operating systems (and possibly other aspects of our computers) and then report back to the home company...
sdsl, a notification system like the one I mentioned would not need to send anything to anyone. It could simply check the OS version and tell you if it's been tested against that version or not. That's hardly a system audit.

Panic does something similar (or did, I haven't tried the latest version) in their CandyBar software. It changes system icons so it's sensative to the OS you're running. I believe SuperDuper is a similar class of application. And the fact that people have made this mistake, even if it's only me, which I doubt, shows that something more could (should?) be done to prevent it.

Quote:
Also, it is very clear (to me) in looking at SuperDuper's web page that the latest OS to use it with is Tiger, and that for Leopard one has to wait until an updated version comes out. There are plenty of other software packages in a similar situation, by the way.
Yes it is, on the SuperDuper page. It's not worded so clearly on the homepage though. You can go to that page, read the promo blurb and download the software without ever clicking through to the 2nd page with the warning.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
backup file size—SD vs. Time Machine jotaro General 10 06-23-2009 10:00 AM
Will Time Machine make SuperDuper obsolete? JAC II General 9 11-07-2007 03:54 PM
A different angle on SD & Time Machine integration badlydrawnboy General 10 10-26-2007 08:37 PM
Future of SuperDuper? (in light of Leopard Time Machine) backerupper3160 General 10 10-20-2007 10:18 PM
Leopard Time Machine vs. SuperDuper MMM General 5 07-05-2007 05:20 PM


All times are GMT -4. The time now is 12:41 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.