Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-12-2008, 01:10 PM
rithban rithban is offline
Registered User
 
Join Date: Jul 2007
Posts: 16
Trouble with scheduled backups

I've been pulling my hair out over this for some time, so I'm going to bare my ignorance here. I think I may have been staring at the manual too long and must be missing something that is staring me in the face. Sorry!

I'm trying to get scheduled backups to work, but have been unable thus far.
1) In the "Energy Saver" preferences -> Schedule, I have the computer set to wake at 3:29 (AM).
2) I have four backups scheduled daily, one at 3:30 AM, 4:30 AM, 5:30 AM, and 6:30 AM to ensure they don't overlap. A manual backup takes ~20 minutes. The four backups do a rotation across four partitions.
3) At night I leave the computer on, turning off the external monitor and dimming the MacBook Pro's display all the way.
4) ... ? [insert obvious thing I'm missing]

In the morning the "Scheduled Copies" show nothing new under "last copy". I then do a manual backup. This wastes time in the morning.

What am I misunderstanding?
Reply With Quote
  #2  
Old 02-12-2008, 02:05 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Try setting a copy to run a few minutes from "now". Does that work?
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 02-13-2008, 04:04 AM
rithban rithban is offline
Registered User
 
Join Date: Jul 2007
Posts: 16
I should have thought about doing that for testing. *massive duh*

No, it doesn't seem to work. I set it for a few minutes in the future, and have waited for a few minutes after the set time. I tried shutting down SD, leaving it open, leaving it open with the scheduling window.
Reply With Quote
  #4  
Old 02-13-2008, 04:18 AM
rithban rithban is offline
Registered User
 
Join Date: Jul 2007
Posts: 16
I can use the "Copy Now" button on the "Scheduled Copies" window to trigger SD, but the timer portion doesn't work.

One non-standard thing I can think of is Preferences > International > Formats > Region is set to "Japan (Japanese)". I'm learning Japanese, but I don't know enough to set *everything* to Japanese. Only the date/times are in Japanese.

I also have the backup partitions partially labeled in Japanese. See attached window snapshot.

I have no idea whether this would affect things. I assume not, but I might be useful.
Attached Images
File Type: jpg sd-01.jpg (92.3 KB, 211 views)
Reply With Quote
  #5  
Old 02-13-2008, 09:32 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Rename the source and backup volumes to "standard" ASCII, then re-schedule. I think that'll fix it.
__________________
--Dave Nanian
Reply With Quote
  #6  
Old 02-17-2008, 12:17 AM
rithban rithban is offline
Registered User
 
Join Date: Jul 2007
Posts: 16
I've played with this some. If I use 7-bit ASCII, then the scheduling works. If I don't, the scheduling doesn't work. Is this a bug or OS X limitation?

If from the "Scheduled Copies" window, I press "Copy Now", it works with or without the 7-bit ASCII limitation. It only seems to be the scheduled run that has trouble.

Thank you for the tip. I'd rather be able to type something short rather than "Backup Day Before Yesterday 2". For the time being I'll put up with it just so the darned scheduled backups run.
Reply With Quote
  #7  
Old 02-17-2008, 10:40 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
It's a known problem in the scheduler having to do with AppleScript, shell script, crontabs and a bunch of complicated stuff that seems to be broken in some OSX builds and not others... hopefully the workaround isn't too painful for now.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Saving backups? Necessary for scheduled backps? gcoghill General 2 12-10-2007 12:43 AM
Scheduled Backups Don't Run Drdul General 3 08-07-2007 07:45 AM
Scheduled backups failing using WD MyBook USB HD timslim General 3 05-31-2007 09:22 AM
SD: How does SuperDuper handle skipped/pinched off scheduled backups? samson General 4 04-18-2007 11:13 AM
Feature request: "Run scheduled backups NOW" option ChicagoLarry General 1 09-11-2006 01:29 PM


All times are GMT -4. The time now is 04:31 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.