Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-26-2009, 08:31 PM
TheDesigner TheDesigner is offline
Registered User
 
Join Date: Jun 2009
Posts: 3
Script to run backup on mount

So I love SD, and it's actually made backups simple enough to where I ACTUALLY do them on a regular basis, but now that I have a new WD MyPassport drive (small, USB powered, perfect compliment to my MBP), I would like to automate the process even further to run right when I plug in the drive, and unmount the drive when its finished.

I don't plan on using this particular drive for anything else other than backups, so what I want to do is to find a script that starts SD and runs my regular backup when I plug in the drive, and at no other point. I don't tend to run my backups at the same time every day, and I don't keep this drive plugged in when it's not serving its purpose. Does anyone have an idea how I could script this, or is there a feature/script already out there that allows for this? Thanks in advance for all your help with this great product!
Reply With Quote
  #2  
Old 06-26-2009, 08:59 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
You can use the general steps in the One Touch Button FAQ entry, along with "Do Something When" (located on MacUpdate or VersionTracker), to accomplish most of this...
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 06-27-2009, 02:25 PM
TheDesigner TheDesigner is offline
Registered User
 
Join Date: Jun 2009
Posts: 3
So I got Do Something When installed and running, but when I tried to point it to the symlink file I created using the FAQ you mentioned, I wasn't able to use it because DSW didn't recognize it as an application...any thoughts? I also found when I just tried to open the alias, it said that the original file could not be found, and when I pointed it to the saved backup file that you make from the scheduler, I get an Unexpected Error Code (-43). Any more help you could offer is greatly appreciated!
Reply With Quote
  #4  
Old 06-27-2009, 03:21 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Sounds to me like the symlink wasn't created properly, actually. Try following the steps again...
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 06-27-2009, 06:01 PM
TheDesigner TheDesigner is offline
Registered User
 
Join Date: Jun 2009
Posts: 3
Turns out I made a mistake in naming the source for the link...got it working now though...thanks!
Reply With Quote
  #6  
Old 06-27-2009, 08:24 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Great to hear: congratulations.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shell script not executing before backup gfesmire General 13 01-08-2009 10:37 PM
Server drive won't mount after backup rhennosy General 1 11-09-2007 04:49 PM
Backup failure on a certain file bmat General 3 09-25-2007 10:06 AM
Error: No space left on device tradervic General 11 06-29-2005 05:50 PM
Smart Backup Error bill s General 20 02-04-2005 10:46 AM


All times are GMT -4. The time now is 05:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.