Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-14-2008, 12:17 PM
acronce acronce is offline
Registered User
 
Join Date: Aug 2006
Posts: 10
SD not unmounting sparse image volumes

Hi all,

I've got two scenarios where sparse image destinations are not being unmounted after their respective backups. Ideally I want this to work with scheduled backups. But manual backups fail to unmount in exactly the same way.

I've reviewed the user's manual, searched this forum, and done numerous experiments. But I just can't get this to work. I know that I can use scripts to unmount the volumes. But it seems that since SD is supposed to do this for me under certain scenarios, I'd prefer to work within SD's parameters rather than try to just fall back to scripts.

Scenario 1 - backup to local sparse image bundle:
In this case, I'm backing up a boot drive to a sparse image bundle on an external RAID array. The reason why I'm using a bundle as the target, is because the RAID array itself is backed up later over the network. Using a bundle minimizes the work needed for this backup because only the changed bands need to be copied.

When the volume associated with the sparse image bundle is not mounted, SD mounts it, does the backup, then doesn't unmount it. This is a problem for me because I want to periodically compact the sparse image bundle, driven by a post backup script.

Scenario 2 - backup to encrypted sparse image on an AFP share:
In this case, I'm backing up the external RAID array mentioned above to an encrypted sparse image file on an AFP volume. Again, if the AFP volume and the contained sparse image backed volume are not mounted, SD mounts them. But after the backup, neither are unmounted. This is a problem because we want to do periodic maintenance on the AFP server.

According to the documentation, a network mounted sparse image file will be unmounted after the backup. The subtlety, according to posts to this forum, is that this only works when the target backup known to SD is an image file.

However in both of my scenarios, the backup target is a sparse image that I had to create in Disk Utility. SD doesn't directly support the ability to create either an encrypted or bundle image. But it also doesn't let me target an existing bundle or image file. The UI will only let me create a target sparse image file. As a result, I've had to mount my bundle and encrypted image, then target the volume in SD.

I seem to be in a catch 22, where SD has its own internal rules for when to unmount the target image, but I can't configure it to do for my particular scenarios. It would be nice if a future version of SD just allowed me to specify to unmount the target, regardless of its internal logic.

Thanks in advance for any suggestions.

Best regards,
--
Allen Cronce

Last edited by acronce; 09-14-2008 at 12:21 PM.
Reply With Quote
  #2  
Old 09-14-2008, 12:22 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
There are various posts on the forum that explain how to write a little shell script to eject the drive post-copy, so you might want to search around a bit.

In scenario 2, though, you should be able to select the (already created) image file in the "Disk Image..." pop-up and we'll unmount it (though not the intermediate network volume) when we're done. Just select it even though it's grayed out, and ignore the 'overwrite' warning.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hangs while backing up to network mounted sparse image acronce General 9 09-11-2008 02:25 PM
network sparse image question subrama6 General 2 02-21-2008 12:35 PM
sparse image creep revisited jotaro General 3 09-20-2007 09:20 PM
Testing a sparse image... macmidiguy General 5 05-14-2006 02:51 PM
Sparse image from aborted DMG backup? Winston General 9 10-22-2005 01:28 PM


All times are GMT -4. The time now is 06:22 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.