Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-14-2008, 11:04 PM
adriansmith adriansmith is offline
Registered User
 
Join Date: Nov 2005
Posts: 7
Time Machine stopped working - SuperDuper involved?

Hi,

Yesterday I moved my Time Machine backups to a new 750GB drive using SuperDuper! Time Machine worked fine after pointing it to the new location and I'm able to go back through the entire history etc.

Last night I set SuperDuper! to do a clone of my boot drive onto the 750GB drive now being used for Time Machine, ie the using the Smart Update feature that leaves the backup directory intact.

This morning I tested booting from the clone and it was fine. However, after switching back to my normal boot drive, Time Machine has stopped working and just gives the error message "Unable to complete backup. An error occurred while copying files to the backup volume."

I don't know if SuperDuper is involved or not but it has obviously had quite a bit to do with this particularly hard drive

Any suggestions? I can't find anywhere where Time Machine might be logging things in more detail?

Regards,

Adrian

Hardware details:-
MacBook Pro, 160GB internal drive
Mac OS X 10.5.2
750GB external PATA drive in WiebeTech case connected via FireWire
External drive is formatted with Apple Partition Map (ie not GUID which is optimal for intel-macs) - could this be involved? The clone booted OK...
Reply With Quote
  #2  
Old 02-14-2008, 11:41 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
I can't think of what we might have done: we don't really touch Time Machine's stuff at all. If you open Console and view all messages, then filter for "backupd", you should see some diagnostics for Time Machine (but it really doesn't say much when things go wrong, as you've seen).
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 02-15-2008, 12:03 AM
adriansmith adriansmith is offline
Registered User
 
Join Date: Nov 2005
Posts: 7
Console errror messages...

Maybe the drive has become corrupted?

Here is what Console.log reports...

***************

15/02/08 1:35:10 PM /System/Library/CoreServices/backupd[445] Starting standard backup
15/02/08 1:35:10 PM /System/Library/CoreServices/backupd[445] Backing up to: /Volumes/MacBookPro_TimeMachine/Backups.backupdb
15/02/08 1:38:54 PM /System/Library/CoreServices/backupd[445] No pre-backup thinning needed: 46.48 GB requested (including padding), 362.55 GB available
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-50) copying /.com.apple.timemachine.supported (from old Mac) to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /.DS_Store to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-50) copying /.vol to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Applications to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /bin to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-50) copying /CentenaryServer to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-50) copying /cores to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/.bpesec to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/.DS_Store to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/.localized to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Address Book Plug-Ins to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/.btsjkvtv4e
to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/.htr.ijats-yjhmstqtlnjx.fljsy to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/.htr.ijats-yjhmstqtlnjx.ymnspuwt to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/.rsrcsl5 to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/.ShadowlandTempEleven to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/ACDSystems to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Adobe to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/Automator to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/Grapher to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/iChat Icons to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/Installer to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/Mail to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/ParentalControls to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Canceling backup.
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Error: (-36) copying /Library/Application Support/Apple/Remote Desktop/Client to /Volumes/MacBookPro_TimeMachine/Backups.backupdb/TheDefiant/2008-02-15-105524.inProgress/1C6861F4-A51C-4415-8408-12704980156C/TheDefiantHD/Library/Application Support/Apple/Remote Desktop
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Copied 11 files (11 bytes) from volume TheDefiantHD.
15/02/08 1:38:55 PM /System/Library/CoreServices/backupd[445] Copy stage failed with error:11
15/02/08 1:38:56 PM /System/Library/CoreServices/backupd[445] Backup failed with error: 11

*************

Any suggestions?

I'm currently running Disk First Aid but it seems to be taking a very long time (but I've not run it under Leopard or on a timemachine drive before).

Adrian
Reply With Quote
  #4  
Old 02-15-2008, 12:07 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
I saw this myself when going from 10.5.1 to 10.5.2: had nothing to do with SD, and had to restore a backup of an older TM archive to "fix" the problem.
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 02-15-2008, 01:17 AM
adriansmith adriansmith is offline
Registered User
 
Join Date: Nov 2005
Posts: 7
I think there are some threads on the Apple Discussions about TM problems with 10.5.2.

Interesting thing is that I did the 10.5.2 update on Monday and didn't have any problems until this morning...

Adrian

PS I've just given up on the Disk Utility First Aid - it was stuck on "checking multi-linked files" for well over an hour...
Reply With Quote
  #6  
Old 02-15-2008, 09:52 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Disk Utility can take many hours to check a TM volume.
__________________
--Dave Nanian
Reply With Quote
  #7  
Old 02-19-2008, 12:37 PM
rdzman rdzman is offline
Registered User
 
Join Date: Feb 2008
Posts: 7
I'm having a similar issue on my MacBook Pro under 10.5.1. I cloned my Time Machine disk (partition on a Iomega 500 GB FW800) to another drive (NewerTech 500 GB FW400). I also used SD 2.5 with Smart Update to put a clone of my internal drive on the same disk as the new Time Machine clone. I can still do TM backups to the old TM drive with no problems, but with the new TM drive I've been getting a number of -36 errors, like ...

Error: (-36) copying /Applications/-net/-web/Firefox.app to ...

Both the internal and the new TM drive check out OK with Disk Utility, and SD didn't seem to have any trouble cloning the same files/directories.

Some of my initial attempts to back up to the new drive appeared to work OK, but when looking at them in the Terminal I noticed that the ownership and permissions of the directories at the root level of the backups was incorrect. So I deleted these backups and am trying to start again. (Hmmm, I did use a different machine to do the initial SD clone of my TM backup. Does SD make sure ownership is turned on before doing a clone? And would it matter if the machine used to do the cloning had a different set of uid and gid?)

My current TM backup (in progress at the moment, after deleting all of the TM backups with incorrect ownerships) seems to be much larger than it should be and has already spit out a bunch of these -36 errors.

Does anybody know an easy way to force TM to do a full traversal?
Reply With Quote
  #8  
Old 02-19-2008, 12:44 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
We've seen this in 10.5.2 with Time Machine without any SD! actions involved at all...
__________________
--Dave Nanian
Reply With Quote
  #9  
Old 02-19-2008, 01:04 PM
rdzman rdzman is offline
Registered User
 
Join Date: Feb 2008
Posts: 7
Well ... I didn't initially suspect SuperDuper! but now it's looking more likely that it's the culprit.

If I look at the files that are causing trouble in e.g. the 2008-02-15-095136 directory on each of my TM drives they are not identical. So either SD! did not successfully clone it, or something (TM?) messed it up later.

For example, in the original TM backup I have ...

drwxr-xr-x@ 3 ray admin 102 Nov 27 23:26 Firefox.app

... in the new one, cloned by SD!, I have ...

-r--r--r--@ 57837 3895334 wheel 0 Oct 27 23:58 Firefox.app

I've run SuperDuper a few times since ... would the log for that TM clone it did still be around somewhere?

Last edited by rdzman; 02-19-2008 at 01:14 PM. Reason: forgot to proofread, left garbage at end of post
Reply With Quote
  #10  
Old 02-19-2008, 01:13 PM
rdzman rdzman is offline
Registered User
 
Join Date: Feb 2008
Posts: 7
Sorry for the multiple posts here ... but I just noticed that there are 3 files (actually .app directories) in this dir that failed and all end up with the same (random) date, and screwed up ownership. (Camino, Firefox.app, SeaMonkey.app).

== CLONE ==
-rw-r--r--@ 5 ray admin 6148 Dec 6 10:17 .DS_Store
drwxr-xr-x@ 3 ray admin 102 Jul 10 2007 Amaya.app
-r--r--r--@ 58851 3895328 wheel 0 Oct 27 23:58 Camino
-rw-r--r--@ 7 ray ray 17918936 Nov 28 20:15 Firefox 2.0.0.11.dmg
-rw-r--r--@ 7 ray ray 17546581 Nov 21 09:31 Firefox 3.0 Beta 1.dmg
-r--r--r--@ 57837 3895334 wheel 0 Oct 27 23:58 Firefox.app
drwxr-xr-x@ 3 ray admin 102 Dec 6 10:19 Navigator.app
drwxrwxr-x@ 3 ray admin 102 Dec 14 09:57 Opera.app
drwxr-xr-x@ 4 _unknown _unknown 136 Nov 2 2006 OmniWeb.app
-r--r--r--@ 58341 3895345 wheel 0 Oct 27 23:58 SeaMonkey.app
drwxr-xr-x@ 3 ray admin 102 Aug 20 2007 Validator S.A.C.app

== ORIGINAL ==
-rw-r--r--@ 5 ray admin 6148 Dec 6 10:17 .DS_Store
drwxr-xr-x@ 3 ray admin 102 Jul 10 2007 Amaya.app
drwxr-xr-x@ 5 ray admin 170 Feb 11 19:51 Camino
-rw-r--r--@ 6 ray ray 17918936 Nov 28 20:15 Firefox 2.0.0.11.dmg
-rw-r--r--@ 6 ray ray 17546581 Nov 21 09:31 Firefox 3.0 Beta 1.dmg
drwxr-xr-x@ 3 ray admin 102 Nov 27 23:26 Firefox.app
drwxr-xr-x@ 3 ray admin 102 Dec 6 10:19 Navigator.app
drwxr-xr-x@ 4 _unknown _unknown 136 Nov 2 2006 OmniWeb.app
drwxrwxr-x@ 3 ray admin 102 Dec 14 09:57 Opera.app
drwxr-xr-x@ 3 ray admin 102 Feb 2 08:37 SeaMonkey.app
drwxr-xr-x@ 3 ray admin 102 Aug 20 2007 Validator S.A.C.app
Reply With Quote
  #11  
Old 02-19-2008, 02:51 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,358
Send a message via AIM to dnanian
Are you looking at this right after the copy, or have other things been going on with the drive? It certainly looks to me like there are some problems with the attributes on the drive itself -- I can't see how we'd "change" those values unless they were returned incorrectly from some pretty important low-level file system calls...
__________________
--Dave Nanian
Reply With Quote
  #12  
Old 02-19-2008, 03:04 PM
rdzman rdzman is offline
Registered User
 
Join Date: Feb 2008
Posts: 7
I cloned my TM drive (call it A, and the clone B) last Friday using a PPC Mac mini running 10.5.2 and SD 2.5. Since then, I've moved B to my MBP (running 10.5.1) where I was intending use it for TM backups (instead of A). After noticing some TM errors today, I ran Disk Repair on B and my internal and did not find any errors on either.

Then I noticed ownership issues on B on the new TM backups (since cloning), so I deleted all of the TM backups that were done since the clone and began examining specific troublesome files from the last TM backup *before* the clone operation and found differences between A and B. So, it isn't immediately after the clone, but Disk Utility hasn't reported any errors and TM shouldn't be messing with existing backups (except when it removes them), right? So, it would seem that the problem most likely happened during the clone.

Btw, I do have the SD log from the clone operation ... would you like to see it? Should we take this to e-mail?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SuperDuper and Leopard if not using Time Machine edesignuk General 3 02-03-2008 07:41 AM
Will Time Machine make SuperDuper obsolete? JAC II General 9 11-07-2007 04:54 PM
A different angle on SD & Time Machine integration badlydrawnboy General 10 10-26-2007 09:37 PM
How will SuperDuper! integrate with Time Machine? Felix General 15 10-23-2007 04:55 PM
Leopard Time Machine vs. SuperDuper MMM General 5 07-05-2007 06:20 PM


All times are GMT -4. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.