Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-26-2007, 03:09 PM
Jos Jos is offline
Registered User
 
Join Date: Nov 2007
Posts: 5
Unhappy How to recover my FileVault-protected user files?

My HD crashed on 11-18. Such is life. I've got two complete backups, or at least so I thought: one from Time Machine dated 11-9, and one from SD dated somewhere in October, before migrating to Leopard. I just now discovered that neither backup system is good friends with FileVault: I did not know that with FV activated, the backup needs to be done from a different, non-FV user. I wish Apple would have been more explicit about this, when you activate FV. And I must say that TM looses much of its attractiveness with FV activated. Will SD's Leopard version tackle this one?

As my TM backup is more recent, I tried to recover from this one first. After starting up from the Leopard DVD, I selected recovery from TM in the menu. The recovery apparently went fine, with my user coming up nicely on the login menu after restarting the computer, although without my picture, a first indicator that something was wrong. After entering the password, my user wouldn't open, and after entering the Master password, I was unable to change my user password. Not nice. I rebooted again with the Leopard DVD and reset all the passwords (to blank) for Guest, my old user and Master, using the password modification tool in the menu. After restarting, I now had three users: Guest, my old user and Other... I still could not open my old user. I opened the Guest user and was able to create a new user with administration rights. From this new user, I accessed the files of my old user in the Finder, after changing the rights to Read & write for all users, folder by folder. My old user turned out to be practically empty. Actually, the TM recovered Users folder was only a few MB. I guess I won't recover much more from here even if I could eventually break into my old user.

At least I completely recovered all the applications-with-purchased-licence-codes and all other system settings outside the Users folder. I decided to go on from here, updated to 10.5.1, and then entered my .Mac account. The sync brought back iCal, Address Book, Dock, Keychain, etc. And with the recovery of my Mail accounts (all IMAP), I recovered all my e-mail of the last 10 years or so. It took almost 24 hours to get there via ADSL, but in some way I recovered many documents as e-mail attachments, because I've sent or received them at some point in time. But still, it's not the same as having them neatly organised in folders in the Finder. And of course I didn't recover them all, e.g. pictures and music files.

So, I still wanted to recover my old user from my SD backup of October. And here's what happens: when I open the SD sparse image, the Users folder is (or appears to be) empty. Still, the folder weighs some 50 GB! Tricky. So with TinkerTool, I activated view hidden files and folders, and there appeared a new sparse image: my old user. Now, when I try to open it, my password is accepted: with another password, it says wrong password. Still, the sparse image won't open with the correct password: it shows an error.

I feel like Frodo in front of the closed gate to the Mines of Moria: I'm worried about what I'll find inside, but for now the gate remains closed...

What now? Maybe I need a hacker? Where do you find these people? Or maybe it's more simple? We're talking about 10 years work or so...
Reply With Quote
  #2  
Old 11-26-2007, 03:12 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
Have you tried actually starting up from the October backup?
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 11-26-2007, 05:28 PM
Jos Jos is offline
Registered User
 
Join Date: Nov 2007
Posts: 5
The backup is a sparse image. It was made on a network drive at work. Now I have on a FireWire drive at home, among other files. I can only restart from the HD or the Leopard DVD: the FW drive or the backup file don't appear as a possible startup drive.

I actually tried the Restore function, described in the SD manual, but it gave an error. I wouldn't like to do it again to see what the error said exactly, because I'd wipe out my HD again.

I have not tried Disk Warrior, have actually never used it...
Reply With Quote
  #4  
Old 11-26-2007, 05:30 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
What error does the image give when you try to open the FileVault user?
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 11-26-2007, 06:55 PM
Jos Jos is offline
Registered User
 
Join Date: Nov 2007
Posts: 5
The disk image you are opening may be damaged and could damage your system. Are you sure you want to open this disk image? Open / Don't Open.

Open => The following disk images failed to mount. User.sparseimage: no mountable file systems.
Reply With Quote
  #6  
Old 11-26-2007, 07:00 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
Sounds like the image is damaged, but this could be a Leopard problem, too.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart update user files to pre-existing bootable volume = disaster! Sondergaard General 6 04-24-2007 06:09 PM
Backup All Files Skipping A User... nazzdeq General 1 10-18-2006 10:03 AM
stall on backup user files Lori General 7 04-11-2006 08:12 PM
'Backup - user files' stopped working dod488 General 1 04-03-2006 05:18 PM
User files aren't all backed up fabius General 3 03-24-2005 03:45 PM


All times are GMT -4. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.