Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-23-2007, 02:40 PM
phh phh is offline
Registered User
 
Join Date: Oct 2007
Location: France
Posts: 2
SD would not quit

I have scheduled an automatic back-up of one of my computers on a portable USB device, every two days. When the first scheduled back-up occurred yesterday, the external device had to be connected upon request. Although the back-up seemed to be successful, the only way I managed to quit SD was to "force quit".

How may I avoid this?
Reply With Quote
  #2  
Old 10-23-2007, 02:55 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
Try pressing Cmd+s to save the (changed) settings, then quit.
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 10-27-2007, 08:49 AM
phh phh is offline
Registered User
 
Join Date: Oct 2007
Location: France
Posts: 2
Thx for the advice, it works fine now. But why do we need to do this rather non-intuitive command?
Reply With Quote
  #4  
Old 10-27-2007, 10:18 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
The bug is that SD! is in a "no user interaction" condition (because of the schedule). So, it's set up to not prompt. But, rather than quitting, you changed something (the drive), which modified the settings. When you tried to quit, it wanted to put up a panel that said "hey, the settings have changed, do you want to save them?" But it can't, because it's set up to not interact...
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 02-13-2008, 01:09 AM
Cintra Cintra is offline
Registered User
 
Join Date: Dec 2006
Location: Norway
Posts: 8
First seen with 10.5.2

Quote:
Originally Posted by dnanian View Post
Try pressing Cmd+s to save the (changed) settings, then quit.
Hei

I hadn't had this problem until I updated to 10.5.2. The Cmd+s allows me to quit ok, but I thought you might like to know.. I don't use scheduling.

mvh
__________________
So much to learn...
Reply With Quote
  #6  
Old 02-13-2008, 09:30 AM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
That's strange. Try deleting the "Saved Settings" folder in Library/Application Support/SuperDuper!, Cintra.
__________________
--Dave Nanian
Reply With Quote
  #7  
Old 02-13-2008, 11:07 AM
Cintra Cintra is offline
Registered User
 
Join Date: Dec 2006
Location: Norway
Posts: 8
Quote:
Originally Posted by dnanian View Post
That's strange. Try deleting the "Saved Settings" folder in Library/Application Support/SuperDuper!, Cintra.
Thanks for replying dnanian

I did that, set things up again and its quitting ok now, but it did quit ok when I used the ctrl+s tip too.

mvh
__________________
So much to learn...
Reply With Quote
  #8  
Old 02-23-2008, 02:27 AM
Brad Brad is offline
Registered User
 
Join Date: Jun 2006
Location: Palo Alto, California
Posts: 13
SD! not quitting on me either in 10.5.1

Hi Dave,

I just emailed you a support ticket at Fogbugz (before searching here--sorry). I just had this happen on Susie's MacBook.

I thought I'd tried Save, but I guess I didn't, it worked just now and allowed me to quit normally. But wouldn't for several frustrating minutes. I even re-ran the SmartUpdate (another 9 min), after setting SD to quit automatically after finishing, but that didn't do it either...

Love to see a fix to this, but realize it's a workaroundable situation and that you've been busy just getting the new Leopard version out. Hope all is well.

~ Brad
Reply With Quote
  #9  
Old 11-09-2007, 01:32 PM
MacMarc MacMarc is offline
Registered User
 
Join Date: Nov 2007
Location: Chicago, IL
Posts: 5
Happened to Me Too

I just want to add that this happened to me too, and it motivated me to come to this site to find out how to fix it.

It would be great if there were a more elegant solution to this scenario -- like a warning box or letting SD quit.

-Marc
__________________
Apple iMac Core Duo with Mac OS X 10.5 Leopard
Reply With Quote
  #10  
Old 11-09-2007, 02:21 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
I agree, Marc: this isn't something I like. But it's something we haven't yet had time to focus on (it's lower priority than a number of other things).
__________________
--Dave Nanian
Reply With Quote
  #11  
Old 12-29-2007, 06:00 AM
Ronald Ronald is offline
Registered User
 
Join Date: Dec 2007
Posts: 1
I think the problem is a little bit different. The workaround with "save" doesn't work if the backup volume is unmounted.
Reply With Quote
  #12  
Old 01-24-2008, 02:28 AM
benschon benschon is offline
Registered User
 
Join Date: Oct 2005
Posts: 2
Yes, this is a problem

Very difficult to communicate to my wife or mother that my "completely behind the scenes" back up program is the reason the computer doesn't respond to the Shut Down command at the end of a day. I have tried to instruct them that they have to Save from SuperDuper first, ("Save what? I haven't changed anything." they quite reasonably ask.) but it's frustrating that there is not at least a dialog box that walks us through this.

Isn't there an elegant way to fix this? It's a big glitch in an otherwise terrific program.
Reply With Quote
  #13  
Old 02-08-2008, 01:27 PM
MacMarc MacMarc is offline
Registered User
 
Join Date: Nov 2007
Location: Chicago, IL
Posts: 5
Again

This happened again to me today -- enough time since the last time that I needed to come here to find the problem.

This is VERY annoying. My word processor prompts me to save before quitting. Why can't SD????
__________________
Apple iMac Core Duo with Mac OS X 10.5 Leopard
Reply With Quote
  #14  
Old 02-08-2008, 04:55 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,357
Send a message via AIM to dnanian
Because there's a bug.
__________________
--Dave Nanian
Reply With Quote
  #15  
Old 10-23-2009, 09:41 AM
sakurama sakurama is offline
Registered User
 
Join Date: Feb 2009
Posts: 4
A search brought me here - the fix worked. I think the irony is that it only happens after scheduled backups which is only possible if you bought the program. So the "solution" is to not buy the program to avoid the bug...

Hope you guys fix it soon as I've suggested to several people to buy the program but now I'll have to suggest that they only "try" the program...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't quit SuperDuper macgabe General 1 08-04-2007 09:31 AM
SD won't quit but not an Active Process SuperDuperUser General 7 01-10-2007 11:57 AM
didn't quit active processes hoodsmom General 1 12-31-2006 06:13 PM
Won't quit after backup Glo8al General 1 11-06-2006 09:42 PM
SD failed to quit & iTunes polarbear General 7 02-02-2006 03:45 PM


All times are GMT -4. The time now is 12:28 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.