View Single Post
  #1  
Old 09-09-2008, 11:52 AM
acronce acronce is offline
Registered User
 
Join Date: Aug 2006
Posts: 10
Hangs while backing up to network mounted sparse image

Hi all,

I'm trying to back up about 750 GB to a sparse image mounted from an AFP share on a ReadyNAS RAID5 array. The sparse image is encrypted with AES 128, and set with a maximum size of 900 GB. The machine I'm backing up from is running Leopard Server 10.5.4.

I've never successfully backed up the drive. After a couple of attempts, a failure pattern is emerging. Basically what happens is access to the mounted sparse image wedges somehow. When this first happened, Super Duper just hung. It couldn't make any progress, even after several hours.

I was able to quit Super Duper. But access to the sparse image was generally wedged. I couldn't eject the drive. And when I tried to run Disk Utility, it hung at start up. The diskimages-helper application was running and taking a fair amount of the processor (upwards of 20%).

Eventually whatever was holding its lock on the sparse image volume freed up and the volume was ejected. But this was hours later. Note that this happened on a server, so rebooting it during the work day was not an option.

After the above weirdness happened, we rebooted the server at a safe time and tried the backup again. Unfortunately we got another failure. Just after midnight, the Super Duper backup failed again, this time with an I/O error, according to the log.

But again the machine is in that weird state where the mounted disk image volume cannot be ejected, and Disk Utility wedges at launch. Also, when I tried to cd to /Volumes from the terminal, the terminal also wedged.

I've backed up other systems to other sparse image files before and I've never seen anything like this. Although I admit that previous backups of to sparse image files over the network have generally been smaller than 200 GB. And this is the first time that I've used this particular ReadyNAS hardware for this purpose.

I'm tempted to bail on using sparse images for this backup and just backup to a raw share point. Unfortunately I would lose encryption, which is not desirable given this situation.

Any thoughts on what could be going wrong here?

Best regards,
--
Allen Cronce
Reply With Quote