View Single Post
Old 08-05-2007, 02:31 AM
Drdul Drdul is offline
Registered User
Join Date: Jul 2007
Posts: 29
Unhappy Scheduled Backups Don't Run

For some weird reason, I can't get SD to run any scheduled backups. I can initiate the backups manually, but they won't run at the scheduled times. I've followed the suggestions here with no luck. Full details below...

I have one backup set to run daily at 7:30 p.m., and another one weekly on Sundays at 5:30 p.m. My computer is usually on and not asleep at these times. When I first installed SD, it ran the daily scheduled backup for at least a couple of days. I thought it was still running fine, but today when I checked the sparse image files, I saw that SD hasn't run since the last time I manually initiated both backups a couple of weeks ago. When I open the Scheduled Copies window, the log button is grayed out, so I'm assuming there's no log file.

I first rescheduled the daily backup to run in a couple of minutes, and then sat back and waited. When the time came, nothing happened.

Then I ran crontab -l in Terminal, and got this (this is everything from the crontab):

30 17 * * 0 open file:///Users/Richard/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20MacPro\%20Image\%20\%E2\%80\%94 \%20Weekly\%20from\%20MacPro1.sdsp/Copy\
30 19 * * * open file:///Users/Richard/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20MacPro\%20Image\%20\%E2\%80\%94 \%20Daily\%20from\%20MacPro1.sdsp/Copy\

I copied the daily command (from "open" to the end), pasted it into Terminal and pressed Return. Nothing happened.

FWIW, here's what I get when I run sudo launchctl list in Terminal:

In case it makes a difference, I set up and scheduled the SD backups from my day-to-day account (called "Richard"), which is not an admin account.

I haven't yet tried the modified version of "One Touch" button thing mentioned in the post referenced above. In any event, it seems like a kludge to work around the issue. I'd prefer to figure out why SD isn't running my scheduled backups and fix the problem within SD. Any suggestions?

Reply With Quote