View Single Post
Old 04-25-2010, 05:18 AM
Bob Kerr Bob Kerr is offline
Registered User
Join Date: Nov 2006
Posts: 5
Can't Boot from Back-up but SD can

I just bought a 1TB Western Digital USB2 HDD to back up a Macbook Pro (Leopard). I've partitioned the drive into four partitions, using Disk Utility, one 400GB for Time Machine, two 200GB for SuperDuper back-ups and fourth partition left as 'spare'. Named the two partitions for SuperDuper 'MBP BU1' and 'MBP BU2'. The drive name for the internal HDD is 'Macbook HD'. It's a 200GB drive with about 125GB in use.

Set SuperDuper off to repair permissions on 'Macbook HD', erase 'MBP BU1', copy 'Macbook HD' to 'MBP BU1' and then restart from 'MBP BU1'. All went perfectly, but when I went to 'Startup Disk' I noticed that only 'Macbook HD' appeared in the window, even though 'About this Mac' confirmed that the startup disk was 'MBP BU1'.

So restarted from 'Macbook HD' and had another look at 'Startup Disk' from there. As before only 'Macbook HD' on the list, no 'MBP BU1', even though SuperDuper had just used this volume to start up from.

So I ran SuperDuper again, told it to Smart Update 'MBP BU1' from 'Macbook HD' and then restart from 'MBP BU1'. Again this worked fine.

With the system now running from 'MBP BU1' I set SuperDuper off to repair permissions on 'Macbook HD', erase 'MBP BU2', copy 'Macbook HD' to 'MBP BU2' and then restart from 'MBP BU2'. All went perfectly, but again only 'Macbook HD' in the Startup Disk window, even though there are now three bootable volumes that the Mac should be able to see and even though SuperDuper was able to boot from both of the "unbootable" volumes.

Next I tried restarting the Mac and held down the option (alt) key. Only one option for startup appears i.e. 'Macbook HD'.

I could think of only one other thing to try i.e. put this post up on the forum . . . any help much appreciated.


Last edited by Bob Kerr; 04-25-2010 at 05:48 AM.
Reply With Quote