View Single Post
Old 04-18-2018, 11:56 PM
Mojo Mojo is offline
Registered User
Join Date: Feb 2006
Posts: 53
Geting SSD Back To Normal After Doing Something Stoopid. . .

A few days ago I did something I have never done, which is install a utility trusting that its compatibility claim is trustworthy and then using it on my Mac's boot drive. The utility is Disk Sensei and among other things it can be used to enable TRIM on Mac SSDs.

For the past year I have been using an external USB 3.0 SSD without any problems. I used SD! and Dave's emailed instructions to configure the SSD. The only thing missing was TRIM. Regretfully, I enabled "Automatic TRIM" on Disk Sensei.

I should probably note that prior to using Disk Sensei the SSD had insufficient free space, around 19GB. That may have caused some problems as well. . . I was about to order a new 500GB SSD. But then I used Disk Sensei to locate old iOS apps that had previously been managed by iTunes. Trashing those files has given me a respectable 82GB of free space on a 250GB SSD.

Prior to installing Disk Sensei the boot SSD ran normally. Since the installation I have experienced booting problems after NVRAM reset (the SSD does not appear as a startup disk). Booting into Single-User Mode is impossible. WRITE speeds are extremely slow, in the neighborhood of 40MB/s average. READ speed remains around 450MB/s. Disabling Automatic TRIM within Disk Sensei does not return the SSD to normal. I haven't noticed any other problems in the past few days.

My installation log (courtesy of BlockBlock) indicates that the following items were installed by Disk Sensei in various locations. The BOLD notations indicate my results trying to find the items. . .

2018-04-11 22:39:10 +0000: /usr/libexec/smd installed a launch daemon or agent (/Library/LaunchDaemons/org.cindori.TEHelper.plist -> /Library/PrivilegedHelperTools/org.cindori.TEHelper) LOCATED.

2018-04-11 22:49:59 +0000: /usr/libexec/smd installed a launch daemon or agent (/Library/LaunchDaemons/org.cindori.SenseiTool.plist -> /Library/PrivilegedHelperTools/org.cindori.SenseiTool) LOCATED.

2018-04-11 23:43:15 +0000: /Library/PrivilegedHelperTools/org.cindori.SenseiTool installed a launch daemon or agent (/Library/LaunchDaemons/org.cindori.noatime.plist -> mount) CANNOT LOCATE.

2018-04-12 04:11:21 +0000: /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/Resources/DesktopServicesHelper created an application helper login item (/Applications/Utilities/Disk -> /Applications/Utilities/Disk CANNOT LOCATE.

2018-04-11 23:24:00 +0000: /bin/cp installed a kernel extension (/Library/Extensions/TrimEnabler.kext -> /Library/Extensions/TrimEnabler.kext/Contents/MacOS/TrimEnabler) CANNOT LOCATE.

In order to regain control of the SSD and be able to boot using it I have twice reinstalled OS Sierra 10.12.6 while booting from an external clone. For some reason(s) that I am ignorant about, the installs did not overwrite the above files. Disk Sensei remained on the SSD during both installs.

I am looking for advice on returning the SSD to its original state without a trace Disk Sensei. Unfortunately my only external clone of the SSD has the utility and its myriad files installed on it. My Bad.

Is there a way to give the OS a clean slate while using SD! to move all my other files to the SSD? Or is there another fix? I admit that I may be missing something obvious. . . Either I never knew it or my aging brain (I turn 64 next month) has forgotten it. I've tried to include all the pertinent information for those who know more than I do about these things. I've tried getting help elsewhere and searched online for information but I haven't had any success.

I am using a Samsung T3 external USB 3.0 drive running OS Sierra 10.12.6 connected to a 2012 i7 Mac Mini. The SSD was reformatted so there is no longer any of the Samsung software that came installed on the drive.

Thanks in advance for taking the time to ponder my self-inflicted dilemma. . .
Reply With Quote