View Single Post
  #1  
Old 01-26-2010, 07:58 PM
robwilkerson robwilkerson is offline
Registered User
 
Join Date: Sep 2009
Location: Baltimore, MD
Posts: 14
Unable to unmount sparsebundle

I ran a new backup last night that created a sparsebundle on an external (USB) hard drive. Today, in the course of doing other things, I noticed that, although I couldn't see it on the desktop, the image was mounted. I can't see it anywhere except from the CLI when doing an `ls`.

I've tried to unmount it, to detach it, to force both operations and to throw sudo at them, but I can't get this volume to go away. The external drive that it actually resides on isn't even plugged in. If I _do_ plug it in and mount the content, it mounts as 'mbp17.mwf 1'. Clearly the system thinks something is mounted, but I can't find a way to unmount it.

I've rebooted several times and I've also removed some ACL bits that were set, but nothing seems to work. Is there anything else I can try?

Code:
rob@mbp17 [Volumes] $ ls
total 8
lrwxr-xr-x   1 root  admin     1B Jan 26 18:43 Macintosh HD -> /
drwxr-xr-x  11 root  admin   374B Jan 25 22:48 mbp17.mwf
rob@mbp17 [Volumes] $ sudo hdiutil unmount -force mbp17.mwf/
Password:
hdiutil: unmount: "mbp17.mwf/" failed to unmount due to error 49153.
hdiutil: unmount failed - Resource busy
rob@mbp17 [Volumes] $ sudo hdiutil detach -force mbp17.mwf/
hdiutil: detach failed - No such file or directory
Any thoughts, hints or suggestions would be much appreciated.
Reply With Quote