View Single Post
Old 03-20-2009, 07:12 PM
Jimwh Jimwh is offline
Registered User
Join Date: Mar 2009
Posts: 11
Apps crash when opening

Originally Posted by dnanian View Post
You'll do:

sudo update_prebinding -root "/Volumes/the-drive-name" -force

It'll prompt for your password.
I thought that this might do the trick, but...

For background, I have a MBP 1st Generation that I was having problems saying that I had run out of available space on my File-Vaulted home directory. I Ran a SD backup and booted in the backup to ensure that everything was there and functional. At that point files were visible and opened in their applications properly.

I did a clean install and run through the initial updates. I then mounted the sparse image and copied back files to their proper directories. Now when attempting to open, say, an iPhoto '09 file, it will open and then stall for about 10 seconds and then close. I then get a "...quit suddenly..." error dialog. Even resetting the app and relaunching does not work.

Permissions and file owner appear to be correct (checked both via GUI and Terminal). I ran the script above and am still experiencing the error.

The one thing that throws me is that iTunes seems to work fine, although instead of opening the backed up file, I re-imported to my library (ratings and such were not important).

I rebooted after my initial failure after applying the prebinding script without success. I can't re-import as i don't have the original files to import from and iPhoto does not appear to have a way to import from an iPhoto database.

Any thoughts?
Reply With Quote