Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Problem transferring to setup new laptop (http://www.shirt-pocket.com/forums/showthread.php?t=7087)

dnanian 11-04-2017 05:02 PM

Ah. So, as I indicated in my most recent blog post, if the major file system type (e.g. APFS, HFS+) isn't the same, we just reformat the drive and retain its format.

So, that just erased, it didn't reformat. You'll have to reformat it yourself to be case insensitive (or APFS case insensitive)...

conejo 11-04-2017 05:14 PM

So can I do that in Disk Utility or do I need another app to do this? Looks like the next step in DU would be 'erase', the 'partition' option is greyed out. I'm assuming that means DU only 'sees' something it can partition if it's blank. And, can one partition of several be reformatted while leaving the other partitions alone, or will it need to do the entire disk and all the partitions at the same time?

dnanian 11-04-2017 05:44 PM

You do it in Disk Utility. See the "Murtaugh's Lament" post at the blog.

conejo 11-04-2017 08:27 PM

ok, I tried to follow those instructions but things aren't cooperating. I erased the entire external drive but it didn't allow me the option to select GUID and then APFS. It only gave me 4 options: mac os ext journaled, then the same with case sensitive, ms-fat and exfat. That's it. I went ahead and erased everything, blowing away the existing partitions and using mac os ex journaled, thought maybe it would let me format to apfs while creating new partitions, but no joy. The partition button is still greyed out.

Am I doing something wrong? Now I'm nervous because I don't have a currently cloned backup of my laptop.

dnanian 11-04-2017 08:28 PM

You must be. If you turn on all devices, then select the physical drive hardware above the volumes, then click Erase, your should have the options to use GUID/GPT partitioning and APFS.

conejo 11-04-2017 08:36 PM

Ok, I think I figured it out. Needed to erase at the whole device level and it's under the boot record where I can select GUID. Did that, then was able to use the context menu to convert to APFS and now I'm creating partitions. Will report back but hopefully I'm good now. Thanks again.

dnanian 11-04-2017 08:41 PM

You shouldn't need to convert to APFS: you should have been able to erase as APFS...?

conejo 11-04-2017 08:59 PM

wouldn't let me erase as APFS, don't know why.

then creating the partitions was a pain in the ass. Now I remember why I used some other app years ago when I first created these partitions. Tried to create 3 partitions, each with unique names, 500 gig, then 2 with 250 gig. Failed the first time, some weird error message. Second time created 2 partitions, one 800 gig, one 200 gig. Erased again, started over, first try fails, second try I get what I want but it's weird. In Disk utility and in Super Duper, it sees one of the partitions as having 800 gig when it only has 250 gig. If I bring that partition up in Finder, it sees it as only having 250 gig.

Always hated Disk Utility, tonight is no exception. But I think I have workable partitions so I'm running a cloned backup of my laptop right now. Will sleep better once that's done, haha.

dnanian 11-04-2017 09:03 PM

Me too. :-)

conejo 11-04-2017 11:24 PM

ok, backup completed. Too tired to boot to it to test, will do that tomorrow. But when I view that partition in Finder/Get Info, format simply says "APFS", which I assume is intrinsically case insensitive. So now if I get a new laptop in a month, I can successfully migrate my data.

thanks again for all your help, Dave. You, and your product, are a godsend, sir.

dnanian 11-05-2017 01:22 AM

Yes, that’s what it would say. Good - glad it got done.


All times are GMT -4. The time now is 03:48 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.