Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   High Sierra (http://www.shirt-pocket.com/forums/showthread.php?t=7059)

dnanian 10-01-2017 09:22 AM

Glad to hear it worked!

ik8sqi 10-01-2017 01:38 PM

Quote:

Originally Posted by dnanian (Post 33917)
So, one drive worked and one drive didn't? (You said '2nd drive"....)

Did you format the backup drive as encrypted? Or did you encrypt by starting up from the backup, THEN turning on encryption and booting back?

Sorry - the title was misleading. here is the scenario.

My Macbook was running High Sierra with the boot drive having been converted to APFS during the upgrade process (drive is encrypted via FileVault).

I then formatted two external USB drives with APFS (encrypted). Run SuperDuper 3 to duplicate the boot drive onto the both USB drives. No problems during the copy. I did on two disks just to be safe - I had to bring the macbook for repair so wanted to have two additional backups in addition to TimeMachine.

I then discovered that neither of the two external USB drives were bootable. Connecting them to another macbook showed the USB disks just fine when the macbook booted up, it's just that they were not bootable.

Semi-good news though. I ran the Disk Utility on one of them and selected the repair option. The Disk Utility didn't report any issues... but when it was done the USB drive now appeared as an option in the Startup Disk in the System Preferences, and I was in the end actually able to boot from it.

But now I'm discovering other problems... when booting from the SuperDuper-made USB drive that got fixed, not everything was copied correctly. For example all the extensions in Chrome have disappeared, and some of the plugins in Safari are also gone. So far those are the only problems that I see after using the USB drive as a boot disk.

The 2nd USB drive that I had SuperDuper'd is still untouched (not fixed by Disk Utility yet) as I want to keep it intact just in case I find other issues with the 1st USB drive that was cloned.

dnanian 10-01-2017 02:17 PM

Interesting. The missing extensions seem quite unusual. Can you send me a support email? That's going to require more extensive investigation, since I'm not seeing that here.

ik8sqi 10-01-2017 02:52 PM

Quote:

Originally Posted by dnanian (Post 33921)
Interesting. The missing extensions seem quite unusual. Can you send me a support email? That's going to require more extensive investigation, since I'm not seeing that here.

Sure - I just sent you an email to your feedback email address. It said (also in case others have similar issues):

======================

Hi,

This is ik8sqi from the forum with the High Sierra / Safari/Chrome extensions issues.

For Safari so far I've compared the directory on the USB drive:
/Users/cmctrf1/Library/Safari/Extensions

with the same one in Time Machine, and except for the "Extensions.plist" the files where the same.

For Chrome instead, the USB drive's directory:
/Users/cmctrf1/Library/Application\ Support/Google/Chrome/Default/Extensions

contained only a couple of random folder names, while the one on Time Machine contained 13 such folder names.

In either case (Safari/Chrome), copying those folders from time machine onto the corresponding filders on the USB drive did not solve the issue - the extensions where still missing in both Safari and Chrome, so some other files are not being copied correctly.

Unfortunately I do not have my original computer as it's now being repaired by Apple. All I have is TimeMachine and the two backups made by SuperDuper...

Roberto


All times are GMT -4. The time now is 01:36 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.