Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Snow Leopard Killed SuperDuper (http://www.shirt-pocket.com/forums/showthread.php?t=5644)

jtphil 09-02-2009 09:37 PM

Snow Leopard Killed SuperDuper
 
I updated to Snow Leopard and got the latest SuperDuper (2.6.1) and it hasn't worked since then.

It no longer does backups. It just gives an unkillable window that says "The variable previousSettings is not defined."

No backups since Aug 27.

What should I do?

sjk 09-02-2009 11:19 PM

My guess is that's happening during a scheduled backup. Recreating any schedules should fix it.

dnanian 09-02-2009 11:47 PM

Right, as sjk indicated (and as is mentioned in the release notes/revision history and the update notice, you need to delete and recreate your schedules.

dkolenda 09-04-2009 12:30 PM

Fresh install issues
 
| 11:08:43 AM | Info | SuperDuper!, 2.6.1 (86), path: /Applications/SuperDuper!.app, Mac OS 10.6 build 10A432 (i386)
| 11:08:43 AM | Info | Started on Fri, Sep 4, 2009 at 11:08 AM
| 11:08:43 AM | Info | Source Volume: Macintosh HD, mount: /, device: /dev/disk0s2, media: Hitachi HDT721032SLA380, interconnect: Internal SATA, file system: "Journaled HFS+", OS: 10.6 (10A432), capacity: 297.77 GB, used: 78.86 GB, directories: 199249, files: 689533, ejectable: NO, ACLs: Enabled
| 11:08:43 AM | Info | Target Image: /Volumes/dkolenda/Backups/Backup.sparsebundle, name: Backup
| 11:08:43 AM | Info | Copy Mode : Smart Update
| 11:08:43 AM | Info | Copy Script : Backup - user files.dset
| 11:08:43 AM | Info | Transcript : BuildTranscript.plist
| 11:08:44 AM | Info | PHASE: 1. Prepare to Copy Files
| 11:08:44 AM | Info | ...ACTION: Preparing Macintosh HD
| 11:08:44 AM | Info | ......COMMAND => Verifying the integrity of volinfo.database
| 11:08:44 AM | Info | volinfo.database OK
| 11:08:44 AM | Info | ......COMMAND => Enabling permissions on Macintosh HD
| 11:08:44 AM | Info | Refreshing Disk Arbitration ...
| 11:08:44 AM | Info | ......COMMAND => Verifying that permissions are enabled for Macintosh HD
| 11:08:44 AM | Info | Permissions on '/' are enabled.
| 11:08:44 AM | Info | ...ACTION: Mounting Backup
| 11:08:44 AM | Info | ......COMMAND => Preparing Backup
| 11:09:28 AM | Info | hdiutil: create failed - image no longer available
| 11:09:28 AM | Error | ****FAILED****: result=256 errno=22 (Unknown error: 0)

I can see the sparseimage being created, but it fails to mount and then disappears.

The backup is being created on a network drive

dnanian 09-04-2009 12:33 PM

That would certainly imply the network drive is failing, disconnecting or -- for some reason -- not retaining the file that was created.

dkolenda 09-04-2009 12:35 PM

Any suggestions? Everything was running fine before upgrading to Snow Leopard and the latest SuperDuper

dnanian 09-04-2009 12:39 PM

Well, you've changed two things, one more serious than the other (Snow Leopard is a far greater change than SuperDuper! 2.6.1). Perhaps there's a problem between it and your NAS?

The error you're getting is coming from the system - we've asked it to create the image, and it fails with that error -- which certainly supports the "problems with Snow Leopard and your NAS" theory.

dkolenda 09-04-2009 01:03 PM

I think I've figured out the problem. The server is still running OSX 10.4, so I tried changing the backup file type from a .sparseimagebundle to a .sparseimage

Seems to be working fine now!

cyenobite 09-04-2009 01:19 PM

same error - regular Leopard
 
I found this forum and thread via google, after getting the same error this morning. But... I am not running Snow Leopard. I just updated to the 2.6.1 yesterday and the schedule ran last night for the first time.
I'll try the previous suggestion above that perhaps the schedules have to be recreated. Current system is 10.5.6.

Thanks for posting. Sounds like we found a bug.

dnanian 09-04-2009 02:25 PM

It's quite possible that sparse bundles require advanced features of AFP that Panther and some NAS devices don't support.

dnanian 09-04-2009 02:27 PM

To clarify as much as I can: this is a known issue, which is why its mentioned in both the update notice and the release notes/revision history.


All times are GMT -4. The time now is 01:17 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.