Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD Vs CCC (

Andrew 02-18-2009 12:21 PM

I have a power mac running tiger and want to back up to an external firewire HD. Thoughts on SD vs. CCC? Why one or the other? Thanks

dnanian 02-18-2009 12:22 PM

They're both good programs, Andrew, so it's hard for me to do much other than plug my own solution. Perhaps others will chip in with their thoughts.

Andrew 02-18-2009 11:05 PM

Dave, thanks for being so honest. I didn't mean to look for a plug for your competition. I guess I just want reassurance that SD is idiot proof and an easy solution for a low tech guy who wants to make sure his family pics/videos/documents and system don't disappear one day. I only had heard of CCC from friends and have no experience with either.

dnanian 02-19-2009 11:16 AM

Well, again -- obviously I'd think it was, otherwise I wouldn't be here. :)

You can download the product, install it, review the documentation, all without purchase. You can even use it (although not all features) without registering, forever, including getting support.

I try to put my money where my mouth is, Andrew. I encourage you to try it to see if it meets your needs.

Note that you do need a drive to copy to. In general, you don't want anything else on that drive. Please don't ignore the extensive warnings about erasing the destination drive!

rlfsoso 02-19-2009 03:47 PM

SD is easy!

in my personal experience SD has been very easy to use, and has saved my (digital) life several times. Smart copy (for which you would have to buy it) makes cloning for repeated backups, where only changed items/files need to be copied, very fast and convenient.

CCC basically can do what SD can, its usability has improved but in my personal opinion, setting it up is still a bit more complicated than SD.


Andrew 02-19-2009 11:19 PM

SD copying
IF I am copying my primary system HD to an external HD, can you make an exact copy of the entire contents (active programs and operating system included) from the drive you are running SD from? I had been told that copying programs like SD or CCC cannot copy the active programs and OS while they are used. I was told one has to boot up from a third drive to copy drive one (the primary system HD) to a second drive. So you really have to use a method of using 3 drives where A would have the operating system, and you would be copying drive B to drive C. I am confused.

rlfsoso 02-20-2009 07:18 AM


yes you can (in my personal experience). I have a nearly 99% track record of successful clones, while still working. That means, very very seldomly I've had a problem while downloading a larger file with a downloading-manager like "Speed Download" which led to a file which could not be copied by SD, which led to a clone failure. If – after prudently finishing downloading – I started the smart copy script again, this never was problem, only side-effect was that repairing permissions prior to cloning takes some time but ultimately solved the problem with that particular file (e.g. it was a permissions problem about who owns the file).

In addition, I suppose, if you check your mail in exact the same second/minute while that part of your HD is copied over, the clone might miss these very recent emails, because the email-folder (".emlx" if it's Apple Mail) was not yet saved to disk or sth. Otherwise I have had no problems wit cloning while still working. SD ignores certain cache files and things in memory (as far as I can say) so there should be no problem?

hope that helps. Please try it outand see for yourself.


dnanian 02-20-2009 08:39 AM

You've been misinformed. As Rolf said, this should work fine, assuming you're not running programs with big, active data files (e.g. Entourage, VMWare, Parallels... or, downloading big files).

fatespawn 02-20-2009 02:42 PM


Why would big active data files matter? I ask because although I've successfully used SD! for a long time on my Tiger/PPC machine, I've recently installed it on my wife's intel iMac. She runs parallels daily for certain apps. Is this going to cause a problem with scheduled backups?

I did notice the other day that the "scheduled" event in SD! was highlighted RED although it reported a "successful" copy. I didn't think anything about it until I read this thread.


dnanian 02-20-2009 03:57 PM

Because highly active data files, in a state of constant flux, cannot be copied properly. Sometimes they might produce errors. Sometimes the destination drive might fill.

fatespawn 02-20-2009 04:08 PM

Ok, that makes sense. But I'm using parallels from a boot camp partition. That data shouldn't be touched by SD! anyway, right? Would SD still have problems in this case?

dnanian 02-20-2009 04:09 PM

No: that's not an active data file on the volume you're copying.

Andrew 02-22-2009 11:10 PM


I noticed that you mentioned Entourage as a program with big, active data files that could lead to problems with cloning. I use Entourage. Am I doomed to failure in the cloning world with SD? If not what do I need to do to compensate for the Entourage being present?


rlfsoso 02-23-2009 05:31 AM

Hi Andrew,

the best solution would be to close Entourage for the period of cloning I suppose. Unfortunately Entourage keeps its data in one big file (with accompanying files for spotlight-indexing for individual messages/ToDos/Events).

I wonder if one could do this via a script, you run prior to cloning (as part of the cloning script in SD)…

You could run SD at a time when you don't need Entourage (at the end of the working day or during the night). SD can wake up your mac if you don't to re-login (via screensaver of else), mount your backup drive do the clone and unmount the drive again and send your mac back to sleep.



dnanian 02-23-2009 08:26 AM

Rolf is exactly right: quit Entourage and you should be fine (but recognize that Entourage uses a gigantic file to store all its data, and that file will be fully copied every time).

Andrew 02-23-2009 09:37 AM

Thank you very much. I will download SD and try tonight.

rlfsoso 02-23-2009 05:47 PM


sth. to add: as far as I remember: opening any of the MS Office apps would access entourage database. Toda I had to open PowerPoint and entourage's database showed up under recent files. This is probably due to contact data etc. being available to the other MS Office apps…



invictus26 02-25-2009 12:45 AM

I just wanted to say that I bought SD because it seemed to be more stable and feature rich. Unfortunately, I haven't been able to get SD to make reliable clones to my server despite days of trying. I gave CCC a shot, and it has worked perfectly every time, even cloning to sparseimages that SD was never able to mount. I would say that CCC is much better for networked backups, so if that's something you might do, you should look at CCC.

dnanian 02-25-2009 08:33 AM

Your experience is certainly not typical: many users back up on a daily basis to network devices without any trouble at all, including myself, three or four times a day, to many different devices.

invictus26 02-25-2009 11:00 AM

Well, I really wish I could reproduce that. I have tried everything I can think of and it doesn't work. The main reason I think it's a software problem is because CCC originally didn't mount images correctly either, but the developer said it was a bug and made a patched version which works great. I know you feel strongly that it's my hardware or something, but I would suggest you take another look into it. Because the fact of the matter is that one program works and the other doesn't.

dnanian 02-25-2009 11:09 AM

Well, actually, you indicated that the image was getting "zeroed out" on mount (literally set to zero length). I don't know if that's what you reported to CCC (which must not have worked perfectly originally, given what you've said), but I'd be curious about what you noted there.

Anyway, we're just mounting the image with diskutil, and there is no option that would zero it out like that... as I'm sure we must have discussed at the time.

Do you have the case number involved here?

invictus26 02-25-2009 03:53 PM

The image zeroing problem (case 88176) was related to SFTP. I've given up on that, so that's not the issue anymore.

My problem right now is that I can't mount my image. It seems to be giving up after a couple of minutes. It mounts just fine in either Finder or CCC. Maybe you could make it wait a little longer?

dnanian 02-25-2009 04:20 PM

We actually don't time out at all. Do you get an error?

invictus26 02-25-2009 04:45 PM

I just sent you the log. It says:

| Error | Failed to mount 'WeeklyBackup'

dnanian 02-25-2009 04:53 PM

Yes. As I indicated there, that's because the volume (or file) was renamed by you: the volume has a space in it, the filename doesn't...

All times are GMT -4. The time now is 06:14 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.