Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   spotlight fails to work on cloned drive (http://www.shirt-pocket.com/forums/showthread.php?t=4756)

davea 11-19-2008 03:33 PM

spotlight fails to work on cloned drive
 
Hi, I used SuperDuper on my MacBook 2GHz laptop to copy my 80GB drive to a Hitachi 320MB 2.5" drive, and then swapped it into the MacBook. It booted up ok, but when I try to type a search string into Spotlight, the string erases itself after a couple of seconds. If I use the folder search panel, the search string stays put, but nothing is "found."

I've tried removing the file, /Users/LOGNAME/Library/Preferences/com.apple.spotlight.plist but the behavior stays the same as described, even after reboot. I've also tried to run the utility program, OnyX.app which is said to have redeeming powers, with the "spotlight" option checked, to no avail.

Any suggestions?

dnanian 11-19-2008 03:39 PM

That seems strange. Try adding the startup drive into the spotlight preference pane's "privacy" tab, then remove it. Once done, restart your Mac and see if it's reindexing...

davea 11-19-2008 04:07 PM

Quote:

Originally Posted by dnanian (Post 22411)
That seems strange. Try adding the startup drive into the spotlight preference pane's "privacy" tab, then remove it. Once done, restart your Mac and see if it's reindexing...

I got the message in a stickup box:

Privacy List Error

The item couldn't be added or removed because of an unknown error.

I tried the disk, then various folders. Apparently I can't add anything at all to the Privacy panel.

dnanian 11-19-2008 04:48 PM

That seems weird. Try starting up in "safe boot" (which will disable Spotlight), then doing it.

davea 11-19-2008 06:17 PM

Hi, I came up in "Safe" mode after a full shutdown, but for some reason, the same error message came up.

I have the original disk and a SATA-to-USB adapter if it would help to retrieve something from the original. I'm mystified and I guess I'll have to try to reinstall the entire system and retrieve the user files from backup unless I can figure something out.

dnanian 11-19-2008 06:22 PM

I have no idea what might be wrong here: I'd contact Apple to see if they have any ideas.

davea 11-19-2008 06:48 PM

OK. I just typed "Apple" in the spotlight box and it "typed ahead," a moment later displaying the entire word, and then erasing the word about a half-second later. While waiting for the text to appear, the spinning "progress wheel" to the left in the blue spotlight box is, uh, spinning (what else?).

If I type slowly the individual characters are erased before the rest of the word is typed. So it's doing "something;" just not one would want.

Thanks very much for all. -- Dave

davea 11-21-2008 01:26 PM

Quote:

Originally Posted by dnanian (Post 22419)
I have no idea what might be wrong here: I'd contact Apple to see if they have any ideas.

I punted and reinstalled Leopard from the Apple DVD (actually this is the Apple-recommended way, so I figured I'd save the call to Apple by starting there).

I reversed the arrangement, attaching the original 80MB drive via a SATA-to-USB adapter, and to my amazement, the Apple installer asked if I wanted to copy my settings, user files, etc., from another volume. I checked all the boxes and they came in thataway. Spotlight is now operating correctly and lightening-fast. It's subjective, but folder windows and especially Mac Mail windows seem a lot quicker than from the clone.

I was dubious about the "clone" because obviously the system was not quiescent during the copy. Something happened to spotlight and all searches, including within Mail.

I also wonder if file system performance in general would tend to be more "optimized" after a DVD install vs. a "clone" copy. I don't know why that would necessarily be the case, although I can conceive that the placement of files during an install might be cleaner.

Having said that, your software is great stuff and I want to learn other ways of using it and related apps productively. Perhaps at some point some recommendations for "best practices" would be needed (although they may already be in your documentation--who reads THAT -- ha ha). Have a good one, --- Dave


All times are GMT -4. The time now is 11:46 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.