Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   App (CoD 2) won't launch on clone (http://www.shirt-pocket.com/forums/showthread.php?t=4009)

esbandido 04-27-2008 02:00 PM

App (CoD 2) won't launch on clone
 
It seems every app I own works fine on when I boot from my clone - with one exception: Call of Duty 2.

Anytime I try to launch the app, I get an error message that says "The application Call of Duty 2 quit unexpectedly" - did a search and found others with the same issue but it seems none of them were ever resolved, or they never posted a solution.

I cloned my drive again with the same result. The app will launch correctly from my internal drive but not from my external clone. Every other app I try works fine. After each backup, I boot form the clone and repair permissions. I also tried running Disk Warrior on the clone and that didn't change anything either.

What is also very strange is that I get the same result even with a fresh install of the game. That seems very perplexing to me.

In console it says there was a 'segmentation fault' if that's at all helpful. There's also a very lengthy entry in my CrashReporter log.

Have talked to support at Aspyr several times about this and they haven't been able to come up with any solution that will get it working. They also report never having heard about this. Don't think I mentioned I was trying to play the game when booted from my clone though.

Anybody have any thoughts? I am addicted to this game...:(

dnanian 04-27-2008 04:49 PM

The only thing I can suggest is that its copy protection is causing the crash.

esbandido 04-27-2008 05:20 PM

Quote:

Originally Posted by dnanian (Post 19112)
The only thing I can suggest is that its copy protection is causing the crash.

I guess that makes sense. Thanks for replying...

esbandido 04-29-2008 09:05 PM

Hi,

I tried an experiment and was a slightly bummed by the result. I took a different external drive and installed os x (10.5.2) and then copied my Call of Duty 2 folder onto it. To my surprise, it worked fine. Then I wiped that drive clean and cloned my internal drive to it with SuperDuper.

Darned if the same problem happened again. Nor can I re-copy the game folder or re-install the game to get it working. I always get the 'quit unexpectedly' message. Just to be sure, I erased the new drive again and then cloned one more time. Same result.

So I don't think it's an issue with the copy protection on the game.

It's not the biggest problem in the world, I know. But it does mean I can no longer just clone my cloned external back to my internal. In a way I have a backup of my data but not my drive which is a bit of a bummer.

Is there anything else anyone can think to suggest? It seems there's something about the clone that's preventing the game from working properly.

dnanian 04-30-2008 12:18 AM

We use very standard calls to copy the files. We've confirmed their operation a lot of different ways, so I don't think that the files aren't being copied properly. But I can't explain why it wouldn't work on the clone; perhaps you can send me the crash report to support and I can see what it's complaining about.

esbandido 04-30-2008 10:23 AM

I'll do that when I get home from work, tonight.

Thanks a ton for giving this your attention. I really appreciate it.

esbandido 04-30-2008 08:33 PM

I just e-mailed a crash report to support and hopefully that will help.

Thanks again for helping me out on this matter.

esbandido 05-02-2008 10:26 AM

Just wanted to add for anyone who is reading that per Dave Nanian's suggestion, I used the solution posted at the top of the forum and that seemed to do the trick.

I downloaded the .zip file and opened that file, then re-cloned to my external checking the 'run shell script after completion' option under the advanced tab selecting the new file. I'm not that versed in things in this matter so it was a learning experience for me.

Everything seems to work fine now.

Thanks a lot to Dave Nanian who really gave this more attention (on this board and through an e-mail exchange via support) than I ever expected.

Cheers and a good weekend to all.


All times are GMT -4. The time now is 01:10 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.