Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Smart Update or erase & full restore? (

badlydrawnboy 03-07-2008 04:20 PM

Smart Update or erase & full restore?

I'm having problems with my system. They seemed to start after I used Leopard Cache Cleaner to clean some caches. I tried booting from the full volume, and creating a new sandbox, but the problem remains - so I suspect it is within the full volume itself.

I have a clone from several days ago on an external FW drive. I was thinking of booting from that drive, and then using "Smart Update" to restore my internal full volume. Is this sufficient, or should I completely erase the internal volume and then copy the clone over?

Also... I have hourly TM backups on another internal disk. If I restore from the clone that is about five days old, will I be able to retrieve individual files & folders that have been created since the clone within the past five days? That's not an SD question, I know, but I'm still pretty unfamiliar with how TM works and I'm hoping you can answer it.


dnanian 03-07-2008 04:39 PM

Yes, that should be sufficient. As far as recovering files with TM -- the problem is going to be locating them, etc. But if you can do that, they should restore fine.

badlydrawnboy 03-07-2008 04:49 PM

Thanks for your quick reply, Dave.

I was seeing some strange behavior with my sandbox, and I created a new one which had the same issues. I then suspected the problem was with the full volume.

However, another possibility of course is that there's something in the creation process of the sandbox that's throwing it off.

I'm booted from my full volume right now and I'm not having any of the problems. I'm talking about application crashes and freezes, and also a strange phenomenon where the dock does not appear when I move my cursor to the bottom of the screen - even though I have it set up to appear and disappear automatically.

Also, when I choose a menu in an application or the finder, and click on it, as I'm scrolling through the items they do not highlight as they should. I move my cursor down the menu and nothing happens. I can click on the menu item to activate it, but no highlighting at all.

This has never happened when booted from the full volume, though it has happened intermittently with at least two sandboxes. Do you think this could be related to the "prebindings" issue? I did use the script you provided last time I made the sandbox, but it's still happening.

dnanian 03-07-2008 04:51 PM

I really think it was the main volume having the trouble... but are you using the "prebinding" fix that's listed at the top of the forum?

badlydrawnboy 03-07-2008 05:25 PM

You may be right. But I've been booted to the full volume for several hours now without a problem. I think I'll continue to test it over the next few days. If there aren't any issues, it would seem to suggest a problem with the sandbox.

Regarding the script: yes, I put the script you have posted at the top of the forum in the "Options > Advanced > Run Shell Script After Completes" area. Is that what I should be doing?

That reminds me of another question I had. When I repair permissions, I get a message that says "ACLs found but not expected". Is that significant?

dnanian 03-07-2008 05:25 PM

Yes, that's correct. And no, the repair errors are expected.

badlydrawnboy 03-07-2008 05:30 PM

Okay. I'll let you know what happens after a few days of being booted to the full volume. If everything goes smoothly, I will try one more time to create a sandbox using the prebindings script. If I experience problems with that, it would seem to indicate a possible problem with the sandbox creation, no?

badlydrawnboy 03-07-2008 11:47 PM

Well, I just started having the "dock problem" while booted to the full volume, so I think you're right Dave that I should probably restore from my clone, and use Time Machine to find the files that have been changed since that time.

Luckily, I've been primarily working out of one folder during that time, so most of the files I need should be fairly easy to locate. The other main place where files have been changed, though, is in Mail. I'm not sure how to find/retrieve email messages that have been stored locally in Mail since the clone. Seems like a real pain.

Of course, it's probably still easier than a complete erase and reinstall, and then restoring from TM - which seems to be my other option.

I'll tell you, I've had so many problems with Apple & OS X the past couple of years. It's not like I'm running any hacks or crazy applications... just Apple & Adobe and a few shareware programs. But I've run into stuff like this and had to reinstall SEVERAL times over the past few years.

I've had this new Mac Pro for just a few weeks, and I'm already at it again.

dnanian 03-08-2008 03:04 AM

It's weird, because I rarely get into this kind of situation, and I run all sorts of things, as you might imagine!

badlydrawnboy 03-08-2008 10:12 AM

Yeah, I must have bad karma with computers 'cause everyone's always saying how "solid" Macs are. I've been using them since the Apple IIe and they've been everything but solid for me.

I restored from the clone and recovered files created since then from Time Machine. So far, so good - but it's only been an hour. I'll keep you posted.

All times are GMT -4. The time now is 11:34 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.