Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Leopard backup boots, but apps crash? Try this. (

Jimwh 03-21-2009 12:14 AM

No difference when opening in Safe Boot...

dnanian 03-21-2009 07:21 AM

I think I'm going to have to suggest that you reinstall iPhoto, Jim. If that doesn't help, archive-and-install the OS.

Jimwh 03-21-2009 11:53 AM

will do...Thank you. Just curious, was there anything in the crash/console logs that point out an issue?

dnanian 03-21-2009 03:01 PM

Nothing terribly useful in there, no. It's crashing deep, deep inside iPhoto, in something like the 18th thread...

Jimwh 03-22-2009 12:21 AM

Researching further, I found that rebuilding the library by invoking Cmd & Option when opening the library and then selecting all options appears to have worked. For reference, you can refer to from Apple's Support site.

Many thanks for your assistance.

dnanian 03-22-2009 08:52 AM

Glad you've managed to find a fix, Jim: congratulations.

securityminded 04-16-2009 05:43 PM

Has this problem been resolved in a newer version of SD or is it still advisable to run the script?

dnanian 04-16-2009 06:06 PM

You don't have to run the script, since you can always boot in safe boot (one time) to force OSX to re-prebind. The new version isn't out yet, though.

securityminded 04-16-2009 09:39 PM

Why doesn't CCC in block or file copy mode suffer from this problem also? (or does it and they simply don't know it).

dnanian 04-17-2009 08:38 AM

Since the problem itself does not affect every copy, it's likely that it does but they don't know it... but it's hard to know, since we're still not entirely sure why the prebind doesn't happen automatically.

securityminded 05-23-2009 04:53 PM


Originally Posted by Bruno_08 (Post 23193)

I can get the problem to happen reliably, and i am willing to try an alternate method. :)

Dave, did any new information comes from this having someone who can reproduce the bug or is the script the only way to fix it?

dnanian 05-23-2009 05:27 PM

My experiments with some alternate techniques in that failed, but no - the script isn't the only way. If you start up in Safe Boot (Shift during startup), that fixes it too (the next regular startup works fine).

securityminded 05-23-2009 05:38 PM

That is so odd. It is frustrating that even though the problem can be worked around, the cause is unknown. So does booting in to safe mode always force a prebind which is why it fixes it?

dnanian 05-23-2009 09:30 PM

It seems to, yes.

DocZagreus 07-10-2009 09:02 AM

HI all!
I'm new on this forum, but I have a problem with a cloned superduper hdd.
The finder crashes in loop.
I have noticed that other users have encountered the same problem.
Could this script be good for my problem too?
Is there a solution?
thank you very much (and sorry for my awful english)

All times are GMT -4. The time now is 05:41 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.