Shirt Pocket Discussions

Shirt Pocket Discussions (http://www.shirt-pocket.com/forums/index.php)
-   General (http://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Scheduled operations do not start (http://www.shirt-pocket.com/forums/showthread.php?t=2254)

andersm 04-02-2007 08:32 AM

Scheduled operations do not start
 
Hello

I've been working on a client's somputer, trying to set up a proper backup schedule. However, the scheduled backups simply do not start, and the SuperDuper! log shows nothing. Please give me some indications as to where I should look for problems. I'm planning to look into it tomorrow night again.

Last time I was working on the computer it was running 10.4.8 with the latest version of SuperDuper! available at the time (probably a month or so ago). I think I remember typing in the admin password to enable scheduled backups, and I tried the suggestion mentioned in the forums regarding a bug - start backup and then minimize window. The backups are scheduled as weekly (two of them, for the same starting time) copying certain folders from two internal hard drives to two sparseimages on a Maxtor OneTouch connected by firewire. They run fine when started manually. No special scripting or anything, with smart backup activated.

Thanks,
Anders :confused:

dnanian 04-02-2007 08:46 AM

If you edit the scheduled copies in the Scheduled Copies window to run a few minutes from "now" and watch them, do they run?

andersm 04-02-2007 08:53 AM

I don't have access to the computer right now, and so I was hoping for a couple of things to look at when I do have access.. I've earlier had the client check on the backup when it's time for it to start, but nothing happens. This is of course with the fw drive turned on, the user logged in etc.

Anders

dnanian 04-02-2007 09:11 AM

You'll want to check to see if the crontab is properly formed by running

crontab -l

(that's a lower case L) in Terminal. There should be an entry for each schedule.

Of course, this assumes cron is running (which it certainly should be).

andersm 04-03-2007 05:44 PM

This is the output:

Code:

30      20      *      *      0,1    open file:///Users/[username]/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20BackupArkiv1\%20from\%20Macintosh\%20HD.sdsp/Copy\%20Job.app
30      20      *      *      0,1    open file:///Users/[username]/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20BackupArkiv2\%20from\%20Macintosh\%20HD.sdsp/Copy\%20Job.app


dnanian 04-03-2007 05:47 PM

These aren't set to run daily: are you sure, when you changed it to run a few minutes from "now", you actually set it to run today?

That's *everything* from the crontab?

andersm 04-03-2007 06:14 PM

1 Attachment(s)
I tried setting it to run April 3rd 1104 pm, but nothing happens. No entries show up in the log, nothing.. :confused:

(The entry changed to Apr 10th when the scheduled time passed.)

And yes, that's everything from crontab.

Anders

dnanian 04-03-2007 06:31 PM

Ok. Please take one of the lines from the crontab, from "open" to the end, paste it into Terminal and press Return after.

When you do that, does SD! start and run?

andersm 04-03-2007 06:35 PM

Yep, when I do it SuperDuper! starts the backup.

Would this indicate some problem with cron then? Do you have any further suggestions?

Anders

dnanian 04-03-2007 06:38 PM

It sounds like, for some reason, cron isn't running properly on your system. I don't know why that would be.

What do you get when you run

sudo launchctl list

in Terminal?

andersm 04-03-2007 06:43 PM

Going to bed now..

Will give it a try when I get the chance and post the results.

Thanks for the help so far.

Anders

andersm 04-10-2007 02:57 PM

Code:

com.apple.dashboard.advisory.fetch
com.apple.KernelEventAgent
com.apple.mDNSResponder
com.apple.nibindd
com.apple.periodic-daily
com.apple.periodic-monthly
com.apple.periodic-weekly
com.apple.portmap
com.apple.syslogd
com.vix.cron
org.postfix.master
org.xinetd.xinetd
com.apple.cups-lpd

Is what I get..

Anders

dnanian 04-10-2007 04:38 PM

That all seems reasonable. I don't know why cron isn't running for you.

What I'd suggest is using the "OneTouch" button FAQ entry in the FAQ forum here. Except, instead of setting the little application to run when a button is clicked, use an iCal alarm to set it to run when you've scheduled it. That should work around this system-specific issue...

andersm 04-17-2007 03:07 PM

Sure, I'll try that. Thanks for your help.

Anders


All times are GMT -4. The time now is 07:05 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.