Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   unable to do system restore :-( (

habi 11-16-2006 12:06 PM

unable to do system restore :-(
I have a mac mini intel and am a quite new mac user. I use mac mini with os x 10.4.7 with all new updates. I wanted to add a bigger 2,5" disk instead of the original and wanted to try using superduper! to test how this works.

Well it doesnt. It makes a sparse image to my usb2 lacie drive without whining. The problem is the restore. I boot from mini install cd and can mount the image from the usb drive and I see all the files and stuff inside.

I try to follow the user guide very thoroughly but it just says I should follow the instructions on the restore tab. The restore functions says that you can use an image from another url or drag'n drop the file in (yes it works in os x) but I dont seem to be able to drag and drop anything in diskutility when I boot from install CD. Not from the drivewindow(on the left in diskutil) nor from the file menu. In the filemenu the sparse image is grayed out (behind 'image' button (right from source image)).

Ive tried to make the image two times very successfully with same resore outcome.

Any advice is welcome here. In the meantime ill try: mode or url mode from my other mac system restore
3.carbon copy cloner

This was not very good experience in backin up :-(

dnanian 11-16-2006 12:13 PM

Agreed, it's quite frustrating. It'll work fine with FireWire Target Disk Mode with SD. The problem here is a bug in the Intel version of the Install DVD as discussed in this post.

There's a workaround in the comments as well...

habi 11-16-2006 01:44 PM

ok, thanks a lot
How come i didn't find that googling!!! Ive been very frustrated. Even called apple support with no help from them!!!!

It seems that asr is my only hope then. Ill start reading on this right away!!!Apple support guy said apple really doesnt support asr as its moore of a professional tool. What?????
thank, Christian

dnanian 11-16-2006 01:49 PM

They don't support it? That's funny: it's their tool!

If you do a "man asr" you'll see all the various options. A simple restore with asr isn't that hard to do... it's just unfortunate that it's necessary!

habi 11-16-2006 04:04 PM

Sounded funny to mee too... Maybe the guy who answered didnt understand what i was talking about.

Now i seem to have problems with asr.....

1. boot from CD and started terminal
2. type:

asr restore --target /Volumes/Varasto/macminihd.sparseimage --target /Volumes/macminihd --erase

The source is the image on Varasto which is the usb drive. Macminihd is the name of the system disk (only partition) on the disk

The system says:

validating target ... and source
couldnt open resource for image "/Volumes/Varasto/macminihd.sparseimage"
asr: Could not find any scan information - no such file or directory

Funny cause i tabed the filenames...

Then i tried the same command with --noverify

it goes through validating...

erase content of /dev/disk0s2 (/Volumes/macminihd)(ny):y
erasing content ..done
retrieving scan informatio ..done
validating sizes ..done
asr:image not an NDIF or UDIF
asr:coudnt restore - error -5351

Ah, my head will soon explode. I just cant understand why this is so hard.

dnanian 11-16-2006 04:42 PM

You have to mount the image and then go volume-to-volume...

All times are GMT -4. The time now is 04:31 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.