Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Folder Icon changes in backup (

Ronin 07-18-2006 10:26 AM

Folder Icon changes in backup
I made a complete backup overnight with SD 2.1.3. The backup appears to have proceeded to completion.

When I booted to the backup volume I was faced with a change in the icons for the (multiple) hard drives in the Finder as well as a different icon for the Network. there is also a different, unfamiliar icon for the Applications folder of the backup drive. Upon casual inspection of the Applications folder it appears that everything is there and the few apps that I launched appear to be OK.

My OS is 10.4.6 (the backup was in preparation for updating to 10.4.7) and I updated to SuperDuper! 2.1.3 (registered) immediately prior to making the backup. I ran Disk Warrior and all of the Cocktail items prior to the backup. Both drives are 500 GB SATA drives if that makes any difference (SIIG 4 channel PCI controller) with one drive mounted internally and the other in an external SATA enclosure. I performed a Smart Update even though the target drive had just been formatted and zeroed (with OS 9 drivers).

I do not recall anything like this happening when I made an earlier backup to a 300 GB hard drive with SD 2.1.1 in the demo mode.

Can anyone shed any light on this?

Thanks in advance!

(Edit) P.S. Several other things are simply wrong such as the icons displayed for my home folder and (users) Desktop (has a package icon!). When I clicked on a prior download of the Combo OS 10.4.7 disc image in finder it displayed the icon for Cocktail! There are probably other things that I have not had time to find as yet.

dnanian 07-18-2006 10:30 AM

That's weird, Ronin. It sounds to me like your icon cache was in a weird state when we copied it.

Try using Onyx or its equivalent to clear your various caches when started from the backup. Restart from it and see if that helps.

Ronin 07-18-2006 11:35 AM

That's Weird

Thanks for the response.

I went ahead and tried a few things. I trashed the Finder Preferences (plist) which did not appear to do anything, but I am not sure that it "took" right away. I had previously repaired permissions after completing the backup and went to update to OS 10.4.7. The disc image (which I had previously opened on the other drive) appeared to open, but failed. I trashed it and downloaded a new copy which I installed. On restart things were not quite what they should have been. I shut down and restarted with the option key, selecting the newly updated drive. When I finally got to it the Finder preference change appeared to have taken effect as the desktop icon sizes had reverted to the (default) large size as had the text size. I opened a Finder window and the icons appeared as they should. I reset the size of the desktop icons/text and things seem to be more or less normal. (I also repaired permissions after the OS update and after updating iTunes, iPhoto, iWeb and the iPod update.)

I had run Cocktail which is set to clear caches on the drive which I backed up immediately prior to the backup, but did not try doing so prior to trashing the Finder preferences and making the OS and software updates.

This is still troubling as I do not know what other "curves" SuperDuper! may have tossed in and I would prefer not to go through this every time I run a backup.

I guess I have a temporary solution, but not a longer term one. It will be a few days before I run another backup and I will have to see if the problem repeats itself.


dnanian 07-18-2006 12:05 PM

Please do let me know if you have continued problems. It's possible that, because you cleared caches immediately before the backup, the cache was being recreated as we copied it, which means it was incomplete...

This is always the danger of copying an active volume: it's possible that something will be changing at the exact moment we're copying it. Fortunately, the types of files that do this are nearly always logs and caches, and thus recovery in this rare event is easy to achieve.

If you do the copy when not booted from the volume, these problems won't occur. Of course, that's also far less convenient...

Ronin 07-18-2006 12:59 PM

When not booted from the volume
OK, I used to do that with CCC (I am a recent convert to SD) quite a bit because I could boot off of the third volume, run the backup and get on the net or play a game or whatever while it was going on. I can not remember why I was discouraged from doing was convenient.

Thanks again for your responses.

dnanian 07-18-2006 01:02 PM

It's not generally required, since the problems are infrequent, but if you want to get the closest-to-the-same result (since nothing is being changed "under you"), that's the way to go.

All times are GMT -4. The time now is 05:14 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.