Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   2.1.1 will not quit after backup (https://www.shirt-pocket.com/forums/showthread.php?t=1298)

mjames 05-19-2006 10:27 PM

2.1.1 will not quit after backup
 
I'm running 10.4.6, iMac Core Duo, and have it set to quit on successful completion. Since I upgraded from 2.1, the app doesn't close after backing up, and in fact won't even close unless I force-quit it. Here is the relevant portion of the log:
Quote:

| 10:16:45 PM | Info | PHASE: 4. And Finally...
| 10:16:45 PM | Info | ...ACTION: Quitting SuperDuper!
| 10:16:45 PM | Info | ......COMMAND => Quitting SuperDuper!
| 10:16:45 PM | Info | Copy complete.
Looks good ... except it won't quit or close. Very strange. I'm using Smart Update Backup to clone to an external firewire drive. Is this just me?

dnanian 05-19-2006 11:14 PM

Is this during a scheduled operation where the drive wasn't attached when the schedule failed?

mjames 05-19-2006 11:25 PM

Drive was attached and it was a scheduled operation.

dnanian 05-20-2006 06:51 AM

It's not something I've seen. Was SD running when the schedule fired? (If so, we don't quit.) Note, too, that it's not necessary to set the "quit" action in scheduled settings, because the scheduler takes care of that...

edoates 06-10-2006 05:23 PM

I've seen this behavior if you have multiple SDs scheduled (I use cron to run scripts), and the first one fails (see my new post regarding scripts detecting errors), for example with an I/O error. I think the SD status stays up even thought the script ends (my drives get dismounted, my custom log gets posted, etc.), along with the "schedule" window.

Then when the second script fires up, as dnanian mentioned, SD then does not quit, but leaves its final window up. This behavior is what clued me into the I/O error, since the "on error" condition did not activate in my script.

So, check for some error in the log which kept your SD active at the end of its or a prior scripts activation.

Ed

gryphonent 06-11-2006 05:14 AM

I second that behavior! I just was about to post to my old thread about SD not recognizing the backup drive and refusing to run the set schedule. I had to force quit SD thereafter!

dnanian 06-11-2006 07:40 AM

The problem in this situation is that the settings have been modified (because you changed the drive), but we're running in a "no user interaction" (scripting) mode, so prompts don't appear.

To get out, do a Cmd-s to save the settings. You'll then be able to quit.


All times are GMT -4. The time now is 07:07 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.