Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   How can I turn off Erase Destination Drive (https://www.shirt-pocket.com/forums/showthread.php?t=4679)

tmackinder 10-16-2008 07:10 PM

How can I turn off Erase Destination Drive
 
I am trying to restore a drive from an image on one USB drive to another blank USB drive. The Image was originally done in Disk Utility. I can set the source and destination fine but the option During copy is grayed out. The reason I am trying to change it is because when I go through the process Super Duper erases the disk I see it unmount on my desktop then remount on my desktop but then I get an error at that point. So I'm thinking that if I can get it to not erase the drive During copy but rather just start right away at restoring then it wont give me the error.

How can I get the During copy option to unlock itself?
Any help would be appreciated.
Troy

dnanian 10-16-2008 08:17 PM

You can't select a "During copy" option when you're using a DMG as a "Disk image..." source: it's always erase, then copy.

Instead, mount the image and then use its mounted volume as the source. You'll then be able to select the copy type.

tmackinder 10-16-2008 10:56 PM

THanks
 
I actually tried that. I have tried to mount it just by double clicking the DMG file and also using toast. But for some reason the result has no files in it. Even though the image is 120 Gig which is the size of the harddrive I backed up.

When I do the restore of the mount with no files only 73mb gets put on the destination disk.

Any ideas would be great. I'm desperate for a few of the files on the disk.
Thanks,
Troy

tmackinder 10-16-2008 11:01 PM

Extra info
 
By the way the following is the error I get when trying to restore using the erase first option:

| 11:59:20 AM | Info | Validating target...done
| 11:59:21 AM | Info | Validating source...done
| 11:59:28 AM | Info | Erasing target device /dev/disk2s3...done
| 11:59:28 AM | Info | Retrieving scan information...done
| 11:59:34 AM | Error | The selected journaling request does not appear to be valid

Also the disk disappears and I have to turn on and off the usb disk for it to show up again.
Troy

dnanian 10-16-2008 11:03 PM

The image sounds damaged to me, Troy, if it's empty. You're sure it's empty?

tmackinder 10-16-2008 11:11 PM

Well not sure. The DMG is the right size 120 GIG but when I mount it by double clicking the disk that shows up has no files in it.

dnanian 10-16-2008 11:34 PM

Definitely sounds damaged. Is there a file count in Get Info?

tmackinder 10-16-2008 11:56 PM

Neither has a file count:
The actual USB drive that has the image on it says
Capacity 111.79 GB
Availability 11.7 MB
Used 111.78 GB
Format MAc OS Exteneded (Journaled)


The Disk that shows when double clicking the DMG file:
Capacity 111.71 GIG
Available: 111.66 GIG
Used: 51.8 Mb

dnanian 10-17-2008 08:44 AM

Yeah, sorry -- the file count's in Disk Utility. Select the mounted image in the sidebar and you'll find the file count at the bottom.


All times are GMT -4. The time now is 09:42 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.