Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   backup failed: invalid argument (

kaolson 10-03-2010 09:55 PM

backup failed: invalid argument
Forgive me if I missed this searching the forum, but though I saw threads wrt i/o errors, this seems to be different.

It's been about 12 days since my last (of many) successful SmartUpdates and I decided to do an EraseCopy. This is an MBP, 10.6.4, and I've done several SmartUpdates and probably one or two EraseCopy's since the problem file was last updated.

IINM, it's a file in a VMWare Fusion package, and I'm pretty sure I have not run Fusion since way before my last few backups. Tried backup drive to both USB/FW (two different drives actually). I've retried the SD backup many times, after resetting the SMC, NVRAM, checked the source drive in Disk Utility, even booted as a target disk and tried it from another system.

A SmartUpdate targeting a drive that contains the last successful SmartUpdate does work, probably because that VMWare image hadnt been touched.

I have today run Fusion on that VM, then shut it down (from a Suspended guest to a Shut Down, so should have been sufficient to modify the file), but subsequent SD backup returned the same error.

Urusai! Happens about 3.5 hrs into the backup..

I'm not a software engineer but have done a bit of QA & I'm wondering 1) what could have changed wrt to this file that hasnt been touched in months, and 2) what's SD doing that returns an invalid argument in such a routine situation?

Here's the bottom of my SD log. Any insights greatly appreciated!

| 06:07:50 PM | Info | Error copying /Users/kao/Virtual Machines/VMWare/vfw2k3-a.vmwarevm/vfw2k3-a.vmdk to /Volumes/iom112HD_Misc/Users/kao/Virtual Machines/VMWare/vfw2k3-a.vmwarevm/vfw2k3-a.vmdk of type 8 due to error 1
| 06:07:50 PM | Error | SDCopy: Error copying /Users/kao/Virtual Machines/VMWare/vfw2k3-a.vmwarevm/vfw2k3-a.vmdk to /Volumes/iom112HD_Misc/Users/kao/Virtual Machines/VMWare/vfw2k3-a.vmwarevm/vfw2k3-a.vmdk of type 8 due to error 1\n: Invalid argument

dnanian 10-04-2010 12:44 PM

That usually means the destination drive failed during the copy... assuming you can duplicate the listed .vmdk in Finder (see the Troubleshooting section of the User's Guide)...

kaolson 10-04-2010 07:42 PM

backup failed -- ok, bad computer
Thanks, Dave. I'd looked at the Troubleshooting section of the UG but I think it had just been too long a day staring at screens and I didnt pick up on the duplicate and replace technique. At that time I was not seeing any I/O errors, but subsequently I've seen plenty of them. Appears my MBP has a logic board problem causing power levels to usb & fw bus-powered drives to dive (usb drives wont mount and fw gets tons of i/o errors).

But I am curious, can you give any insight to the Invalid Argument error? What's happening specifically that causes SD's copy statement to have one? I was a bit mislead (not to say flummoxed ;).


dnanian 10-05-2010 12:06 PM

That's just Apple's translation of the error code it returns... the 'argument' is basically the drive itself as a destination of a disk operation.

All times are GMT -4. The time now is 11:08 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.