Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Urgent help needed after restore (

nbarman 11-15-2007 07:29 PM

Urgent help needed after restore

I did not realize that SuperDuper is not yet Leopard-ready and I think I did something that needs some help to fix. Here's what I did and what happened:

1. Bought a new hard drive for my MacBook
2. Backed up my old internal hard drive to a disk image on an external, non-bootable drive
3. Installed the new internal drive and tried to restore using Super Duper's image

1. The actual restoration of files happened successfully.
2. The first thing I noticed is that icons on my desktop were out of order.
3. I tried to open Mail, but it told me that "Mail Cannot Open because its Index is read-only: This file is located in Neil MacBook:Users:Neil:Library:Mail:Envelope Index. If this file is on your computer, use the Get Info panel in the Finder to change your permissions for this file to "Read & Write." If this file is located on a network server, contact the server administrator. After your permissions are changed, open Mail again."
4. The clock on my menubar disappeared. All my user-specified settings were forgotten; my Safari-memorized forms were forgotten.
5. I tried to verify and repair disk permissions. On some occasions, this did not work and on other occasions it did work. On the times it did not work, it would give me a message in red immediately upon being invoked. (I don't recall what that message is). On the times that it did work, I rebooted hoping that everything would return to normal, but all my user settings are still not remembered.
6. Finally, if I change user settings or system preferences, they are again forgotten as soon as I reboot.
7. I also cannot open Addressbook.

It seems as though the computer doesn't recognize that I am writing user preferences to the same account that I am using...



dnanian 11-15-2007 08:00 PM

You did this under Leopard?

KLippert 11-25-2007 11:47 AM

I had the same problem following a simultaneous Leopard/hard disk upgrade, using Super Duper to backup and restore my original drive. I worked around the Mail problem by removing (actually renaming) the Envelope Index file, which forces Mail to rebuild a new one. Still having a host of other problems, though: Address Book won't open, Firefox refuses any secure connections, Terminal won't launch, and some slow typing (as if an overflowing keyboard buffer) issues. Not sure whether these are Leopard-related, or HD related (new drive is larger and faster), or, as so many seem to be, permissions-related from the restore? I've run Repair Disk Permissions from Disk Utility a dozen times to no avail. All very frustrating... If you find any workarounds to any of these problems (Address Book, Firefox, and especially Terminal), please post them here. --- Kevin L, NYC

ashworth102680 01-31-2008 02:55 PM

I'm having the exact same issue upon restore. Nobody's come across a solution to this? My recourse is to downgrade back to the original Macbook Pro hard drive and await the release of a Leopard-friendly version of SD. :(

dnanian 01-31-2008 02:56 PM

Try starting up from the Leopard CD, ashworth, and then use the "Repair Home Folder Permissions" option in the "Reset Password" utility.

ashworth102680 01-31-2008 03:02 PM

OK. I'll try that and see how that works.

Does it need to be Leopard disk, or will OS X Tiger disk work for repair only? I am not 100% certain I have the Leopard disk with me right now.


dnanian 01-31-2008 03:03 PM

If this is a leopard restore, it absolutely must be the Leopard disk. Never repair Leopard with Tiger tools.

All times are GMT -4. The time now is 05:30 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.