Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD! won't start copying when ignoring folders (

GMacSpark 08-02-2007 08:23 AM

SD! won't start copying when ignoring folders

I'm attempting to do my first backup with SD!, from my Boot drive to a Mac OS Extended (Journaled) partition on my second internal (SATA) hard drive.

All seems to go OK if I simply do a straight "Backup - All Files", but my problem is that there are some very large folders that I want to exclude from the backup (Movies, Music etc - I back these up to a different drive).

So I made a script that ignores these folders. But when I run it, SD! goes through the initial stages of its process (the upper section in the progress box) and then when it gets to the actual copying, it stops and says it can't copy any files - 0 files copied.

I suspect that after it erases the partition in the initial stage, it may be setting the partition's permissions to "read only", and hence the copy fails. Does this sound feasible?

Any words of advice?

Powermac G5 Dual 2.0GHz; 4.5GB RAM; OS 10.4.8

Thanks in advance!

dnanian 08-02-2007 08:53 AM

No, I don't think that's the case -- it's much more likely that your copy script is wrong. What does your script do?

GMacSpark 08-02-2007 12:22 PM

Basically it just "ignores" 7 folders on the Boot drive - at least that's what I meant it to do...

Can I send you some screenshots (268K)?


dnanian 08-02-2007 12:26 PM

No, don't do that -- just send me the script file. It's likely in Library/Application Support/SuperDuper!/Copy Scripts.

GMacSpark 08-06-2007 11:39 PM

For the benefit of other forum readers, I'm posting the text of a conversation Dave and I had via private email (which I really should have conducted in the forum, I guess...)

I sent Dave a copy of my script...

Dave said: "Are you trying to create a Sandbox with this stuff, Gary?"

I replied:


At one stage I started to try out a Sandbox, which didn't work, so I then tried a straight Backup, ignoring some folders.
I may have inadvertently mashed the scripts together and come up with a monster.
Let me try a straight Backup (ignoring some folders) from scratch and see what happens...

Thanks for your time.


And then:

I tried a straight Backup (ignoring some folders), setting up the script from scratch and it seems to have worked perfectly!

I must have got my previous script confused with an earlier attempt at a Sandbox script. Now I feel really stupid - I'm usually better than this at scripting stuff.

Anyway, many thanks, Dave, for your patience and help at pointing me in the right direction.

All the best,

All times are GMT -4. The time now is 10:16 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.