Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Clone Not Bootable (

slickmrick 06-27-2006 01:30 AM

Clone Not Bootable
Hello to everybody! I am bit of a mac newbie so forgive any basic stuff!
After using Carbon Copy Cloner with problems I decided to give SD a go!
Have registered version of SD (2.12 v79). Running OSX Tiger v10.4.5 (Intel)
Trying to clone internal 80GD HD to IDENTICAL (Model) external USB2 80GB.
Using Backup All Files option, FAILS to erase ext HD (left it running overnight!). Used Tiger Disk Utility to erase/format drive ok (same file system format as internal boot drive).
Tried again to clone but chose Smart option. Clone completed up to point of making ext hd bootable. error is;
Failed to make HD bootable.
Tried again using Smart option (NO format), completed much quicker second time round (no changed files I guess).
Both times same error. Log File ends with;

| 05:21:57 AM | Info | Evaluated 780825 items occupying 61.78 GB (129672 directories, 621996 files, 29157 symlinks)
| 05:21:57 AM | Info | Copied 29215 items totaling 0.12 GB (16 directories, 29 files, 29170 symlinks)
| 05:21:57 AM | Info | Cloned 61.56 GB of data in 781 seconds at an effective transfer rate of 80.71 MB/s
| 05:21:57 AM | Info | PHASE: 3. After Successful Copy
| 05:21:57 AM | Info | ...ACTION: Making OSX86_BOOT bootable
| 05:21:57 AM | Info | ......COMMAND => Blessing OS X System Folder
| 05:21:58 AM | Error | sh: line 1: bless: command not found

Seeing how the actual backup seems to have completed ok, how can I Manually make (bless!) the ext hdd so I can then use the ext hd as the internal hd. You may wonder why I can't just use the ext drive as a restore drive to internal hd, but this is just an experiment before I go ahead and buy a much larger HD as I'm running out of space!
Many Thanks.

dnanian 06-27-2006 08:01 AM

It seems that your bless command is missing, 'slickmrick'. Let's check.

Please open Terminal and type "which bless". It should say something like this:


[G5:/Volumes/SuperDuper!] dnanian% which bless
[G5:/Volumes/SuperDuper!] dnanian%

What do you get?

slickmrick 06-27-2006 03:21 PM

bless missing?
Thanks for your quick response my friend!
I typed what you instructed in terminal and I get;

no bless in /bin /sbin/ usr/bin /usr/sbin

How do I get this missing component back?
Regards. etc...

dnanian 06-27-2006 03:33 PM

The easiest way is to use the DVD that came with the system to archive-and-install Tiger. Then, update to the current release with Software Update, and that should bring it back.

slickmrick 06-27-2006 05:58 PM

Alternative to reinstall OS?
Dear Dave,
Is it possible to copy the relevant files off from my intel mac notebook as when I checked for Bless it seems to have it!?

dnanian 06-27-2006 06:05 PM

It is, but who knows what else is missing, you know?

slickmrick 06-28-2006 03:44 AM

He who asks questions may get some answers!
Very true Dave, but I'd like to give it a try anyway! Which files do I need to copy over? Also, if I do need to reinstall Tiger, is there any way I can do an 'upgrade' type of install that retains all my installed apps & prefs etc (like you can do with Windoze XP? :)
Thanks again.

dnanian 06-28-2006 09:10 AM

Actually, archive-and-install does a much better job than an "upgrade" on XP, and preserves everything you need. Works really well.

I really think you're taking a risk by copying the file and not doing an archive-and-install. But if you must, copy /usr/sbin/bless from the other computer to this one (as long as they're both Intel). Note that it has special permissions, so you must be careful to preserve them -- I suggest using the command line tool "ditto" authenticated, e.g.:

sudo ditto /Volumes/the-other-computer/usr/sbin/bless /usr/sbin/bless

Good luck.

samuelbray 08-12-2006 10:04 AM


Originally Posted by dnanian
It seems that your bless command is missing, 'slickmrick'. Let's check.

Please open Terminal and type "which bless". It should say something like this:


[G5:/Volumes/SuperDuper!] dnanian% which bless
[G5:/Volumes/SuperDuper!] dnanian%

What do you get?

I have the same problem---I'm trying to do a "Backup--all files," and all goes well until the error message "Failed to make Copyright [my clone] bootable."

I tried "which bless" in Terminal, and I seem to have it:

Auden:~ samuelbray$ which bless
Auden:~ samuelbray$

Any suggestions?

samuelbray 08-12-2006 10:07 AM

Here is the last part of my log:

| 02:54:17 AM | Info | PHASE: 3. After Successful Copy
| 02:54:17 AM | Info | ...ACTION: Making Copyright bootable
| 02:54:17 AM | Info | ......COMMAND => Blessing OS X System Folder
| 02:54:18 AM | Error | Can't access /Volumes/Copyright 1/System/Library/CoreServices/Volume Name Icon: Input/output error

I should also mention that my clone target disk is called Copyright, but SuperDuper calls it sometimes Copyright and sometimes Copyright 1 (and I have no idea why).

dnanian 08-12-2006 11:49 AM

It's because the drive is failing, Samuel, and when Bless tries to manipulate the drive it's getting errors. I'd try using Disk Utility to erase *and* zero the drive.

samuelbray 08-12-2006 12:08 PM

Thank you!

All times are GMT -4. The time now is 10:07 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.