Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   (Zero-length) File caused SuperDuper to abort backup (

alancfrancis 08-31-2005 11:11 AM

(Zero-length) File caused SuperDuper to abort backup

I just bought myself a big fat external firewire drive to backup the family laptops. I've been tearing my hair out with both SuperDuper and CCC. To cut to the chase, problem seems resolved and I'll be registering SD for future incremental backups.

I'm running 10.4.2 and the backup would fail (on SD, CCC just crashed) when it tried to *write* /usr/lib/gcc/powerpc-apple-darwin8/4.0.0/specs. The error was SVUclone: Error: Couldn't Create.

On investigation, this file turned out to be zero-length...could this be the problem?

When I trashed it, the backup failed again when it encountered the file in the trash, so I emptied. This time the backup has now worked twice without a hitch.

I've attached the full log, hope it helps.

[***] Tuesday, August 30, 2005 04:53:24 PM Europe/London
|04:53:24 PM|Info| SuperDuper!, version 74, path: /Users/acf/Applications/SuperDuper!.app, OS: 10.4.2 (8C46)
|04:53:24 PM|Info| Source Drive: /, name: Groucho, device: /dev/disk0s2 type: hfs, OS: 10.4.2 (8C46), capacity: 74.53 GB, used: 55.14 GB, directories: 82798, files: 391295
|04:53:24 PM|Info| Target Drive: /Volumes/PowerBook Backup 1, name: PowerBook Backup 1, device: /dev/disk2s3 type: hfs, OS: N/A, capacity: 83.88 GB, used: 0.04 GB, directories: 4, files: 8
|04:53:24 PM|Info| Copy Mode : Erase, then copy files
|04:53:24 PM|Info| Copy Script : Backup - all files.dset
|04:53:24 PM|Info| Transcript : BuildTranscript.plist
|04:53:24 PM|Info| PHASE: Volume Preparation
|04:53:24 PM|Info| ...ACTION: Erase PowerBook Backup 1
|04:53:24 PM|Info| ......COMMAND => Erasing PowerBook Backup 1
|04:53:31 PM|Info| Journaling has been enabled on /dev/disk2s3
|04:53:31 PM|Info| ......COMMAND => Restoring PowerBook Backup 1 UUID (63D41D9795A28AF9)
|04:53:31 PM|Info| ...ACTION: Enable Permissions
|04:53:31 PM|Info| ......COMMAND => Enabling permissions on Groucho
|04:53:31 PM|Info| Refreshing Disk Arbitration ...
|04:53:31 PM|Info| ......COMMAND => Verifying that permissions are enabled for Groucho
|04:53:31 PM|Info| Permissions on '/' are enabled.
|04:53:31 PM|Info| ......COMMAND => Enabling permissions on PowerBook Backup 1
|04:53:31 PM|Info| Refreshing Disk Arbitration ...
|04:53:31 PM|Info| ......COMMAND => Verifying that permissions are enabled for PowerBook Backup 1
|04:53:32 PM|Info| Permissions on '/Volumes/PowerBook Backup 1' are enabled.
|04:53:32 PM|Info| PHASE: Clone from Source to Target
|04:53:32 PM|Info| ...ACTION: Copy Files from Groucho to PowerBook Backup 1
|04:53:32 PM|Info| ......COMMAND => Cloning Groucho to PowerBook Backup 1
|04:53:32 PM|Info| Copying all files using script: /Users/acf/Applications/SuperDuper!.app/Contents/Resources/Copy Scripts/Backup - all files.dset
|04:53:32 PM|Info| Loading 19 commands from copy script /Users/acf/Applications/SuperDuper!.app/Contents/Resources/Copy Scripts/Exclude system temporary files.dset
|04:53:32 PM|Info| Loading 1 commands from copy script /Users/acf/Applications/SuperDuper!.app/Contents/Resources/Copy Scripts/Exclude Norton FileSaver files.dset
|04:53:32 PM|Info| Loading 2 commands from copy script /Users/acf/Applications/SuperDuper!.app/Contents/Resources/Copy Scripts/Backup - all files.dset
|04:53:32 PM|Info| Copy script command hash contains 22 commands
|04:54:01 PM|Info| WARNING: Caught I/O exception(22): Invalid argument
|04:54:01 PM|Info| WARNING: Source: /usr/lib/gcc/powerpc-apple-darwin8/4.0.0/specs, lstat(): 0
|04:54:01 PM|Info| WARNING: Target: /Volumes/PowerBook Backup 1/usr/lib/gcc/powerpc-apple-darwin8/4.0.0/specs, lstat(): 0
|04:54:01 PM|Info| Logging attributes for item: /usr/lib/gcc/powerpc-apple-darwin8/4.0.0/specs of type: 8
|04:54:01 PM|Info| Type:
|04:54:01 PM|Info| Creator:
|04:54:01 PM|Info| kIsOnDesk: NO
|04:54:01 PM|Info| kColor: NO
|04:54:01 PM|Info| kIsShared: NO
|04:54:01 PM|Info| kHasNoINITs: NO
|04:54:01 PM|Info| kHasBeenInited: NO
|04:54:01 PM|Info| kHasCustomIcon: NO
|04:54:01 PM|Info| kIsStationery: NO
|04:54:01 PM|Info| kNameLocked: NO
|04:54:01 PM|Info| kHasBundle: NO
|04:54:01 PM|Info| kIsInvisible: NO
|04:54:01 PM|Info| kIsAlias: NO
|04:54:01 PM|Error| SVUclone: Error: Couldn't create

dnanian 08-31-2005 11:17 AM

Hi, Alan.

Interestingly, I don't have the "specs" file in that directory (also under 10.4.2 with Xcode installed). My guess is that it was a broken symlink, with no destination set, or a bad one. When we tried to recreate it, it failed with error 22 (above) -- "invalid argument".

You might want to consider an uninstall of Xcode (with the uninstall script in /Developer/Tools), followed by a reinstall... but, if it's backing up now, that's probably not strictly necessary!

alancfrancis 08-31-2005 11:21 AM

Hi Dave,

Thanks for the quick response.

I assume, therefore, that you don't expect SuperDuper to have a problem with perfectly ordinary zero-length files such as might be created by `touch <filename>`, that this is just a weird case ?


dnanian 08-31-2005 11:23 AM

Absolutely. There are a jillion -- ok, maybe fewer than that, but a lot -- of zero-length files on a typical system. This file was damaged in some other, fundamental way...

alancfrancis 08-31-2005 11:24 AM

Sweet. Cheque's in the post (as they say) as soon as my PowerBook is online :-)

alancfrancis 08-31-2005 11:27 AM

Oops, just clicked the 'Buy Now' button to see what kind of reg system was in place and it crashed SD. No internet connection at present, but I didn't expect a crash :-)

The thing I was looking to find out was whether I can use PayPal. I have a bunch of US dollars sitting in a PayPal account, but if I use my credit card, I get hit for currency conversion charges into UKP.

alancfrancis 08-31-2005 11:33 AM

Heh, just paid on the website instead of through the app. I see there was an option to bill in UKP, so no paypal worries.

Thanks again for a great tool and the quick response :-)


dnanian 08-31-2005 11:42 AM

I wouldn't have expected that either, Alan. Unfortunately, the purchase assistant is code provided by eSellerate, and I don't have control over what it does other than by asking it to run! :)

PayPal isn't supported by the assistant or cart, though. But, drop some email to "sales" and we'll see if we can work something out. (Or, not, since you're all set! :))

All times are GMT -4. The time now is 01:30 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.