Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Missing Fonts error after recovering from backup (

rcs 01-27-2006 11:06 AM

Missing Fonts error after recovering from backup
Dave I need a help...I will try to explain my problem as clear as possible...

Everytime I create a new file using Keynote/Pages/iWeb template(all templates) I always got a missing fonts error...all templates gave me a missing fonts error. I check the fonts...just a few as reference(because there are a lots...I can't check them all one by one)...the missing fonts are the one with ".dfont" extension(for example: Copperlate.dfont)

try restarting, repair permissions, etc doesn't help...trying all my superduper backup doesnt help either. I have 5 superduper backup on my external firewire. I used to backup my mac everytime I want to install a new program..

First I thought It was MS Office or iWork screwing with my fonts.... Then I try to erase & install os x....(I still have the latest SuperDuper verion before 2.0.1 at this time)

then installing my apps again one by one because of this problem.

My backup is as follow:
Backup1: OSX 10.4.4 + updated OS X & superduper 2.0.1
Backup2: installed apps on Backup1 + MS Offcie 2004 + updated office
Backup3: installed apps on Backup2 + Macromedia studio + Maya + iWork 06 + iLife 06

===then before I backup to "Backup 4" I tried to create a new iWork template file and it work without a problem.

Backup4: installed apps on Backup3 + apss(like adium, cyberduck etc...)
Backup5: installed apps on Backup4 + Change my preferences like firewall, security, acount, mouse settings, etc...

===then I make sure that I don't get any missing font error again and it went wel...pheww...I am very happy with the result

"remember I did the backup straight from 1-5 without recovering from any backup that I made before".

Yesterday I tried some butler, iphoto buddy...messing around a bit with the mac. And after that I decided to recover my mac from "Backup5"...

And guess what...I got the missing fonts error again. I thought hmmm...this is strange, well maybe there is something wrong and I need to recover still gave me the same error. I decided to try my "Backup4"...same problem..."Backup3" same problem. I dont try "Backup1" and "Backup2" because I not yet install ilife/iwork on it.

I looked for the missing fonts at ~/Library/Fonts and its not there. Then I looked at Machintosh HD/Library/Fonts and its there...the are all there...

Dave I just want you to know that you made a very good backup apps...I try to look for the cause of this problem but I am pretty sure this have something to do with superduper recovering files.

So I really have no idea right now...

My specifications is as follows:
Powerbook 12" 1.5 GHz(latest rev), 1.25 GB memory, OS X 10.4.4 fully updated, SuperDuper! 2.0.1

Please advice.

Thank you in advance.

dnanian 01-27-2006 11:16 AM

I don't know of any cases where SuperDuper! would cause fonts to go missing, rcs... and since there are a ton of dfonts on a typical system we'd certainly have seen it!

So -- if the fonts are in /Library Fonts, and not in ~/Library/Fonts, that sounds right... that's where they'd be. There's no reason for them to move to ~/Library/Fonts.

Are they on the backup? In other words, if you look at /Library/Fonts on the backup, are the fonts there -- where they're supposed to be?

rcs 01-27-2006 11:17 AM

Yes they are there...

dnanian 01-27-2006 11:19 AM

So, they're in the correct location on the backup and when restored. Can you see them in FontBook? Are you using any Font Managers?

rcs 01-27-2006 11:27 AM

Yes I do use font book and I can't see them from font book. But if I searc for the font from finder(in Macontosh HD/Library/Fonts)->double click it-> "Install Font" then everything works well again and I can see the font from font book.

But why is that? why is after recovering the backup I have to add the fonts one by one. I just dont understand how it works.

dnanian 01-27-2006 11:32 AM

I don't know. FontBook just looks at the folder where the fonts are to generate its list, as far as I know. We're copying the files, clearly, as you can see from the drive. And the files are in the right location, and have the right content.

Perhaps your font cache is messed up? Try using one of the various maintenance utilities to clear your Font Cache -- maybe that'll help in this case. (I believe it'll recreate the cache if you boot into "Safe Boot", too.)

rcs 01-27-2006 11:43 AM

dave I'll try to boot into safe mode...I'll update you if it fix it...

rcs 01-27-2006 12:04 PM

Dave thank you very much. The safe boot is indeed resolve the issue with missing fonts.

So the problem is that my font cache is corrupt. Is this a common problem?

I am sorry to hit you with a question and saying that the problem might be because of superduper! ;)

Thank for your support and for this great application :)


dnanian 01-27-2006 12:06 PM

No, it's not that common, actually. But I'm glad that was, indeed, the issue -- and that it's fixed up! :)

All times are GMT -4. The time now is 06:04 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.