Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Western Digital My Book drives and SuperDuper (https://www.shirt-pocket.com/forums/showthread.php?t=2791)

chris_johnsen 09-10-2007 01:57 AM

Yes, I see that there is a new version. To be fair, the documentation/screenshots to which I linked are effectively only a few days out of date. That new 1.1 release is only a couple of days old, and until then the UI looked the same as it did in 0.7.4.

The new notification UI sure makes it difficult to get an overview of the settings and ensure consistency. I liked the old table view better. Maybe it was confusing, but I find the new UI to be a bit too verbose and click-intensive.

hdtvluvr 09-10-2007 08:12 AM

I didn't realize 1.1 was just a few days old. I believe I like the layout in your documentation better too.

In my Growl list there are 4 notifications for SD. I've set them all to "Stay on Screen" - Always. The 4 are Copy Failed, Copy Succeeded, Scheduled Copy Failed and Scheduled Copy Succeeded.

I have chosen "Sticky" and yet I don't see the notifiations the next morning. Choosing Sticky, checks a box on the General tab - "leave notifications on screen after ____ seconds of inactivity". The default is 30.

The backup did run the past 2 days but I don't see the notifiation the next morning after I wake the monitor. Do I have something set wrong?

chris_johnsen 09-10-2007 02:38 PM

Er, the documentation to which I linked is just from the Growl web site. I do not do anything for the Growl development team, so it cannot really be called mine.

Anyway, scheduled backups seem to reliably produce Growl notifications for me. In the Growl preferences for SuperDuper! I changed them all to "Always" "Stay on Screen" and they did just fine. I suppose it could be a problem with new installations of Growl 1.1 (I upgraded from 0.7.4 when you mentioned that there was a new version). Double check that the notifications have the Enabled checkbox checked, and that "Hide all notifcations" is unchecked in the General "tab" of Growl's preferences.

Edit: Also, if your schedule was originally created over a year ago, you may need to reschedule your backup: http://www.shirt-pocket.com/forums/s...5&postcount=27

You also might try something else that uses Growl, to see if that works. Since you might not have any Growl-enabled applications installed, you could just try running this little bit of AppleScript in Script Editor:
Code:

tell application "GrowlHelperApp"
        notify title "Test from AppleScript" description "This is a test message for Growl from AppleScript. Growl should display it as a sticky notification." with name "Scheduled Copy Succeeded" application name "SuperDuper!" with sticky
end tell

That should pop up a Growl notification that has SuperDuper!'s icon and uses the specified title and description text. If you play around with this script, the application name and "with name" must be from an application that has already registered with Growl.

hdtvluvr 09-10-2007 07:47 PM

<<I do not do anything for the Growl development team, so it cannot really be called mine.>>

I didn't mean to imply it was "your" documentation. I meant your doumentation as to the doumentation you linked to.

I set up the schedule this past weekend so it being over a year isn't a problem.

All notifications are Enabled.
All set to Always Stay on Screen
Hide is unchecked
Leave notifiations on screen after 30s of inactivity is checked. It seems that this checks itself when "Always Stay on Screen" is selected on the Appliations tab.

Display Options tab has a duration slider. It is currently set at 10s (the maximum listed). However, one would think that the Always stay on screen would override this setting.

Thanks for the Applescript code. It only displays the Growl for 10s. I'm going to restart my Mac and see if the Growl is displayed tomorrow.

chris_johnsen 09-11-2007 02:04 AM

Check your display style: Bezel, Music Video, and Nano do not work with "Stay On Scre
 
Well, at least we know that Growl is working since the AppleScript is able to trigger a notification.

Based on that, I found a post in the Growl forum that says some display styles do not support the sticky/"stay on screen" option.

I tested the display styles in my installation and found that Bezel, Music Video, and Nano do not seem to support sticky notifications. MailMe and Speech do not do screen-based displays so they do not support sticky notifications either. On my system that left AboveTheNight, Brushed, Bubbles, Candybars (my usual setting), Crystal, iCal, NotifyOS9, NotifyOSX, Plain, Pseudo-Code, and Smoke that seem to work OK with sticky notifications (at least the one that my AppleScript code generated).

If you are using one of those three styles that do not support stickies, try one of the others. If this is the problem and you want to keep the does-not-work-with-sticky style for other notifications, you could configure one of the works-with-sticky styles just for SuperDuper! via the per-application settings.

hdtvluvr 09-11-2007 08:08 AM

Well, wouldn't you know it - I had selected Bezel. I'll give one of the others a try. Thanks for assisting me with this. I'll let you know if it works tomorrrow.

hdtvluvr 09-12-2007 07:58 AM

I chose Brushed yesterday and it works! Thanks.


All times are GMT -4. The time now is 05:31 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.