Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Leopard Server : Not performing scheduled backups after restart (

bcometa 03-30-2008 10:50 PM

Leopard Server : Not performing scheduled backups after restart
I'm managing a small 10.5 server with about 5 clients.

The 5 client computers all have superduper and are cloning fine to their local external drives. The server however, is having issues, so I'm hoping to find out what's wrong.

I opened superduper on the server and none of the schudeled backups had been performed since the last time I was there (15 days ago). All the schedules are setup and the "next backup" shows the correct time (tomorrow early am).

I tried running all 3 scheduled backups using "copy now" from the scheduled copies window. worked fine.

I tried scheduling for 5 minutes in the future, quit superduper, worked fine.

But then I tried scheduling for 10 minutes in the future, restarted the computer, and it didn't automatically start the schedule.

The Console shows nothing different for the last attempt than it did on the first successful ones. No error messages as far as I can see.

Please tell me you know what's going on.



dnanian 03-30-2008 11:30 PM

Were you logged in after the restart?

bcometa 03-31-2008 01:32 AM

yes, i was logged in, everything was loaded up, two minutes before the scheduled time.

on a side note, i thought with leopard i didn't need to be logged in? i thought the need to schedule with "root" was only for pre-10.5 (?).

dnanian 03-31-2008 08:41 AM

No: you need to be logged in.

bcometa 04-01-2008 01:17 AM

ok, i was logged in.

i checked the server today and the backup worked as scheduled (the computer hadn't been restarted since I left yesterday).

but again, when I restart, the scheduled backups still exists in superduper, they just don't run.

dnanian 04-01-2008 11:19 AM

I really don't know why that would be; the system scheduler should run regardless of a restart...

RickCogley 05-12-2008 09:40 AM

The same thing is happening to me. On Server 10.5.2, running the latest SD!, after a reboot I have to recreate the schedule item. Then, SD! works fine until the next reboot.

Dave, you gave me the hint in email about recreating the schedule item, and it does work to fix it, but, it should not be necessary, no?

Rick Cogley

dnanian 05-12-2008 11:52 AM

Thanks, Rick. As I said: I don't know why this would be, since the 'crontab' is written to disk and should run regardless of restart.

RickCogley 05-12-2008 07:11 PM

Oh! Crontab!

Originally Posted by dnanian (Post 19372)
Thanks, Rick. As I said: I don't know why this would be, since the 'crontab' is written to disk and should run regardless of restart.

Ah, ok, thanks for the tip. My crontab looks like:


bash-3.2# crontab -u admin -l

30        16        *        *        0        open file:///Users/admin/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20Mercury\%20HUB\%20from\%20Macintosh\%20HD\%20-\%20Mercury.sdsp/Copy\

I'll see if I can find anything in the logs.

RickCogley 05-12-2008 08:37 PM

Good 'ol macosxhints
Interesting comment on this URL:

Perhaps this is needed at the end?:

>& /dev/null

dnanian 05-12-2008 10:53 PM

I don't *think* that'll make a difference, but you can give it a try and see...

All times are GMT -4. The time now is 03:40 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.