Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD hangs on "Restoring Spotlight state on OSXBackup" (

ncmphoto 04-03-2010 09:22 AM

SD hangs on "Restoring Spotlight state on OSXBackup"
I've been having some problems with my boot drive recently (G4 MDD/OSX 10.5.8) involving slowdowns - beachballs, apps very slow to launch, etc.) after the Mac has been running for a while. I've run Disk Utility - says boot drive is OK - permissions repair, applejack, Disk Warrior (only one icon flag to fix), Hardware Test (came up clean). Another symptom is that the external FireWire backup drive sometimes shows up as a boot option and sometimes does not, when booting with the Option key held down. When it's there, it does boot normally and seems to run fine. Also, twice when rebooting from my main boot drive the desktop appeared but the menubar and other stuff didn't. After a reboot it seemed to be working normally.

I have a 2nd internal hd where I had a backup of my older OSX 10.4.11 system (before ugrading to Leopard about a month ago). Since the external was behaving a bit weirdly I used SD to erase and do a complete backup of the boot drive, but it hung about 3/4 of the way through. Numbers and progress bar didn't change. So I quit that process and used DU to reformat the drive, ran DU on the boot drive (no problems) then ran SD again. It finished copying but now is hanging on the last step - restoring Spotlight state on the clone. Is it ok to quit SD and will the backup drive be bootable (that part and the prebinding did finish)?

BTW I'm running SD when booted with my login items disabled and not doing anything else on that Mac while backing up.

I suspect that I've gotta reinstall 10.5.8 on the boot drive and restore my stuff using Migration Assistant, but though I have two backups, I am not sure they will work when needed.

dnanian 04-03-2010 03:26 PM

This almost sounds like the backup drive is freezing up, actually. You can certainly stop SD!, but I'm *guessing* it may pinwheel. Give it a try.

ncmphoto 04-04-2010 04:46 AM

But which backup drive is freezing up? I've had issues with both (internal and external) as explained in my post and it seems unlikely - though not impossible - that both have problems at the same time.

Eventually I did get tired of the hours adding up (SD wasn't frozen, the gear shift kept going around and the clock moved) so I stopped the backup, and quit SD normally. I ran DU on the internal backup drive and it said it was OK. Next I'll try booting from it to see if that works.

I've been using SD for several years on several Macs and never had a problem before except getting caught briefly by that Virus Barrier bug some time ago.

dnanian 04-04-2010 07:25 AM

If SD! isn't frozen (before you said the clock wasn't advancing), perhaps you're backing up with active applications/files?

It's also possible you have port/FireWire problems on one Mac.

ncmphoto 04-04-2010 09:03 AM


Originally Posted by dnanian (Post 29069)
If SD! isn't frozen (before you said the clock wasn't advancing), perhaps you're backing up with active applications/files?

It's also possible you have port/FireWire problems on one Mac.

I suppose I could try a backup in Safe Mode. I usually do them by booting normally but holding down the Shift key when launching my account, so my personal login items are disabled (things like DragThing, Default Folder, etc. that usually launch automatically). I don't run any apps besides SD during backups, so unless some system process is active that shouldn't be a problem. Also, this is the way I've always done backups and they never failed before.

The FireWire port suggestion is valid. I'll try hooking that external drive to another FireWire port. Right now it's attached to a pci FireWire card in the G4MDD. But that wouldn't explain the failure to finish of the 2nd internal hd which is on the same bus as my main boot drive.

ncmphoto 04-04-2010 09:08 AM

Also you are right, I didn't explain SD's symptoms properly. It hadn't frozen, the gear was spinning and the clock working. But it never advanced - in one case (the external hd) it was stuck about 3/4 of the way through the backup. On the internal backup drive it had completed the backup, restored boot capability and prebinding but was stuck on the restore of Spotlight (with spinning gear and clock ticking), so it never finished and that section didn't turn green, if you know what I mean.

dnanian 04-04-2010 12:50 PM

I do. Next time this happens, send in your log and we'll work from that.

ncmphoto 04-04-2010 04:50 PM

Fine. I'll do that. For now, after running the Combo update on my boot drive it seems to be working again. I did another complete backup to my external drive (switching the FireWire cable to another port on the pci card) and this time it completed. But the drive doesn't show up when I boot using the Option key. On the other hand, it does show up both in DU and System preferences/Startup Disk. I also redid a complete backup on the internal second hd which also completed this time and does show up as a boot drive when I reboot with the option key held down. So it seems the backups using SD worked this time around.

Thanks for your help. I'll be back (with logs) if I continue to have issues.

All times are GMT -4. The time now is 08:58 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.