Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Cloning not working (

NMBob 06-12-2008 05:13 PM

Cloning not working
Leopard, v2.5(v84). I'm "cloning" my 250GB MacBook drive to a new 320GB drive. Both Hitachi's. After erasing the new drive SD! copies most of the 404,000 files to the new drive (normal) and finishes normally. When I swap the drives and boot up on the new drive my network settings for the built-in Ethernet have changed from a manually set address to DHCP. It seems to remember the Airport passwords and stuff OK. But then the strange one: the first time I tried this the file oniguruma.h ended up in my Login Items. ????!!!! Xcode starts up and makes itself ready for me to edit this file. I have no clue what this file is (it must just be one from the Xcode tools installation).

I've did the cloning again and the same thing happened to my Ethernet settings, but now multicell.h is Xcode's file of choice. I also have no idea what that file is. The usual other items are in Login Items (iTunesHelper, LazyMouseBG, Transport Monitor (PalmOS), and iStat menus Helper). On the original drive everything seems fine before and after the cloning.

I guess I'll do my usual periodic backup to my usual hard drive and see if it wants me to edit something when I try booting from that drive. ???

There may be other problems, but these are the two that I've noticed.

dnanian 06-12-2008 05:14 PM

I don't know why your ethernet address setting has changed, although it's possible it's somehow tied to, say, the drive name. Same goes for the login item - try checking to see which one is unusual, deleting and re-adding that entry before copying if (after updating the names to be the same) it doesn't work next time...

NMBob 06-12-2008 06:17 PM

The original drive name is Uniblab, and the drive I'm copying to is Macintosh HD. I'll try everything tonight and let you know. Thanks!

NMBob 06-13-2008 01:37 PM

OK. Tried every combination of everything that I could think of last night and this morning and when I boot off of a cloned copy (erase and copy everything) to this new hard drive I get a .h file set in my Login Items (today it's richtextbuffer.h) and Xcode starting up so I can edit it. There is some funny business with the Airport too (like the system being copied with the Airport off, but the copy booting up with the Airport turned on), but I couldn't check things like the Ethernet addresses/DHCP settings changing at home.

I tried booting up on a backup that was about 2 weeks old and it went file. Then I SmartUpdated it and booted up on it and everything was still fine, and many other things.

It seems like it is only when this new disk drive is involved that things get funny.

I'm ready to do a clean install of everything unless there is something you'd like me to try. It's probably time to do a clean install anyway with the way Apple is acting more like Microsoft every day :)

dnanian 06-13-2008 02:06 PM

This extra file gets set in your login items, and no other item is missing?

NMBob 06-13-2008 02:28 PM

As far as I can tell everything seems to be OK. There's 404,700 files so I'm not sure if 1 or 2 are missing. :) Mail is OK. The manual Network setting seemed to have survived this time (this last try this morning). Mail OK. VMWare/WinXP seems happy. All of the right icons are still in the dock. Dreamweaver remembered the serial number and reactivated OK, but is having trouble finding the site on the local disk -- oh, it a disk name problem. iTunes seems happy. It's just the .h files ending up in Login Items that is obvious. Two of them (multycell.h and richtextbuffer.h) are in


and oniguruma.h is in


Everything looks OK, I just don't trust it.

dnanian 06-13-2008 03:02 PM

There must be something in the login items plist (which is copied as a unit -- we have no idea what's in it) that is being resolved differently on the copy. Perhaps files that were deleted before without removing them from the list are now 'resolving' to different files, because the alias that's stored is finding something that matches. I think your copy is OK.

NMBob 06-13-2008 04:02 PM

Bizarre. There IS and entry in for the program on the original disk that I *thought* I deleted a couple of weeks ago (the program is gone, but not this entry). The plist entry is not in the new copy, but then I've deleted the .h file from the list already. Maybe that has something to do with it, but to turn that into a random .h! Now that's programming. :) I'll keep this copy and see how it does. Thanks!

dnanian 06-13-2008 05:29 PM

Yep! Glad I could help.

All times are GMT -4. The time now is 04:26 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.