Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Sparse backup unbootable (

Limpinghshrew 08-24-2005 11:43 PM

Sparse backup unbootable
I just got SuperDuper and was able to create a backup on an external firewire drive after following the instrunctions in FAQ thread: "How do I update an image?" (<>)

The backup was created all right and I could mount the image and copy files to/from the backup using finder. However, I could not boot from the image (does not show up as an option). Furthermore, after restoring the image to the original source (my PB hardrive) I could no longer boot from the PB and had to use the installer CD. (which was ok this time cause I wanted start over anyway). Is it possible to create a bootable backup in 10.3.9?

dnanian 08-25-2005 12:01 AM

Not being able to boot directly from the image is definitely expected, as it isn't a real drive. But it certainly should have been bootable once restored: what exactly happened when you tried?

Limpinghshrew 10-04-2005 09:59 PM

restore from image
sorry to just let this thread die, had to send the PB to applecare and finally got it back after 6 weeks... and, well it gets worse from there but thats beyond the scope of this forum... lets just leave it at it will have to go back to service to get the display replaced.

So - details: I booted off the OSX CD and ran disk utility. I go to the restore menu. First off, I can't drag any disks to the 'source' or 'destination' fields, disks in the left hand column are hilighted instead. So I click on 'image' next to source, click on my firewire drive, but can't select my backup (a sparse image) because it is grayed out. So i boot from to the harddrive which is a fresh install of OSX. Now I can mount my backup image. From there I run disk utility, and here I am able to drag and drop into the 'source' and 'destination' fields. I restore, restart, but something must have gone wrong cause now during startup the system hangs while trying to load the login screen. I can still boot off the OSX disk but its the same situation... what am i doing wrong?

dnanian 10-04-2005 10:03 PM

OK: you should be able to pull down the File menu in disk utility and mount the sparse image from the CD, as long as it's reasonably recent (10.3.7 or later). But, that won't get your further than you've already gone.

So, if it's hanging loading the login screen, we need to figure out what's failing. Try doing a "Safe Boot" (shift down during power on). Does that work?

If not, try a verbose boot (Cmd-Opt-v during power on). What error do you see when it's hanging, or what's the last thing that loads?

Limpinghshrew 10-04-2005 11:24 PM

The CD is 10.3.9, from last March or so. Under file, the only options are:

New Window
Unmount volume
eject volume
disable journaling
fix os 9 permissions (os 9?)
page setup

So I'm still not sure why/how you boot from the installer CD, mount the sparse image, and restore.

Then I tried safe boot. Same result: the blue bar is almost to the end and it just freezes at 'Login Window Starting'.

Then verbose boot. At least 2 screens worth of text comes up before I'm left with a plain blue screen with just my mouse pointer. It took about 10 restarts till I caught the last line:

Starting Virtual Memory
Welcome to Macintosh
checking disks
/etc/rc line 286: 147 Hangup system starter -gr ${VerboseFlag}{safeboot}

what do you think?

dnanian 10-04-2005 11:30 PM

Hm, strange. OK...

Let's see if we can get the drive to boot. It's possible that your Netinfo database has been damaged.

You can see if that's the case by performing a small experiment: print out this message so you can refer to it, and type carefully!

Reboot into single-user mode (hold down Cmd-s during boot). When prompted, type:

fsck -y

If it says the file system was modified, do it again until it no longer says that. Then, do:

mount -uw /
cd /var/db/
rm .AppleSetupDone
cd netinfo
mv local.nidb local.nidb.bak

The system will then boot. You should receive the Apple Setup Assistant. When it prompts, enter your name, password and the rest of the information. (It's very important that you use the same short name as before.)

Once that's done, it should boot normally... let me know!

Limpinghshrew 10-05-2005 12:44 AM

holy cow.. that did it! Everything seems as it should be. Thanks for walking me through all this. But still I'm confused- what happened and how do I use the next backup I make without all this trouble? Why couldn't I restore with the OSX CD?

dnanian 10-05-2005 01:22 AM

It seems that older Panther CDs don't have the Disk Utility that has the sparse-image-mount command. From what I could tell, that was introduced in 10.3.7. But, creating a BootCD (with BootCD) should bring your native command in, which will work.

Why the trouble? It's very hard for me to say. Netinfo can sometimes do this, and while we copy it properly, it must sometimes be in a 'bad state'. (In fact, we've even seen the netinfo command-line utilities fail on a volume that's working with netinfo.)

These steps are, sometimes, necessary. Painful, I know...

Limpinghshrew 10-13-2005 06:09 PM

ok - I made a bootCD with bootCD, booted from it, mounted the image, ran disk utility, set source and destination appropriately and... got the following error:

An error (-34) occured while copying

what does this mean? Is there a directory of error codes somewhere?

dnanian 10-13-2005 06:58 PM

I don't know, Limpingshrew -- not a terribly friendly error. Try mounting the image first, then copying from volume-to-volume, rather than DMG to volume...

All times are GMT -4. The time now is 07:17 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.