Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   odd messages about making changes (

Dan Lester 10-06-2021 08:17 AM

odd messages about making changes
I do a SuperDuper! scheduled backup every night. In the last week or so, some odd things have been happening. I get up in the morning, and am confronted by a "diskutil wants to make changes" message, asking for Administrator validation. I do that, and only then does the backup start. Then after the backup is declared to be successful, I get a "SuperDuper! 3.5beta3 wants to make changes" message, also asking for Administrator validation. Now, I moved to Big Sur a month or so ago, but this just started in the last week.

What's going on?

I erased the scheduled backups and recreated them, but that doesn't seem to help.

dnanian 10-06-2021 11:24 AM

It's a new Big Sur message. Basically, mounting volumes with Disk Utility won't work without authorization, even when running as 'root', unless the screen is unlocked. It's kind of ridiculous, frankly...but I don't have a way around it right now.

Dan Lester 10-06-2021 04:56 PM

"Unless screen is unlocked"? Does that mean the screen has to be active? If so, does that mean that a scheduled SuperDuper run has to be done with a scheduled "wake", in that the machine has to be woken before a backup is started? Ridiculous indeed.

Is that how one can do a scheduled backup?

Also, the disk that I'm trying to back up to IS already mounted. At least the icon for it is sitting on the desktop.

dnanian 10-06-2021 08:10 PM

It should work if the drive is mounted. Are you logged in as an admin?

Dan Lester 10-06-2021 09:49 PM

No, I am not logged in as Admin, but in principle, I could just give myself Admin privileges.

The bottom line question here is whether unsupervised scheduled backups can even be done anymore in Big Sur.

dnanian 10-07-2021 12:38 PM

Give yourself admin privileges and see if that helps. I think it will.

Dan Lester 10-08-2021 08:21 AM

need to have Admin privileges
Yep, tried that last night and it worked. In order to do unsupervised scheduled backups with Big Sur, you need to give yourself Administrator privileges. Quite bizarre. Thanks for figuring that out.

dnanian 10-08-2021 09:02 AM

A pleasure. Glad that worked.

BSquared 11-19-2021 09:21 AM

Thanks for figuring this our, folks. However, I purposely run in non-admin mode because I think it increases security, so I'd rather not change that; any thoughts on whether it really does improve my security?

dnanian 11-19-2021 09:26 AM

I don't think it significantly improves security on macOS. You get prompted for authorization regardless for anything that needs escalation...if Apple was really worried about this, they wouldn't default accounts on new systems 'admin'...

All times are GMT -4. The time now is 02:39 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.