Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Clone boots, clone of clone on SSD won't (

Bagpuss 08-20-2021 04:41 AM

Clone boots, clone of clone on SSD won't
Can anyone shed any light on this problem, please?

Earlier this year, I had to replace my 2020 MacBook Pro (Intel). Before letting it go, I made a clone with SuperDuper onto an external Samsung M3 Portable 1TB hard disk.

I set up my new M1 MacBook Pro as a new setup, as a "good practice" start afresh. Most things I have got set up fine, but there are a handful of reasons that I want to be able to boot up my "old" laptop.

I have an old MacBook Pro, 2013 I think, which was my previous computer that I never got round to selling. It still works, boots fine, and will boot up the Samsung clone of my more recent setup, but very slowly, being a slow external HDD.

I've bought a SanDisk Extreme Portable SSD 1TB. I have used SuperDuper on my new M1 Mac to make a clone of the Samsung HDD clone. The final step was failing, until I downloaded the beta, v121.3. Now an erase and copy goes smoothly, everything is green at the end.

But it is not seen by the old Mac when I try to boot from alternative disks. When I boot the very old setup, I can see the external SanDisk SSD, and it's there in the Startup Disk options, but one can't make it boot, just getting the "Running bless to place boot files failed" error.

I've tried and tried. Done a whole new clone, but to no avail. Anyone got any suggestions?

One thing that's just occurred to me is this: I could boot the old Intel laptop from the Samsung HDD and then use SuperDuper to make a clone of the running MacOS to the SanDisk SSD. It would take ages, but would it be worth a go?


dnanian 08-20-2021 07:23 AM

Well, the OS is not universal, and as such M1 copies definitely won't and can't boot on Intel, and vice versa. As I explain in the blog, you can migrate from an Intel Copy on M1 (and M1 on Intel), but you can't boot.

Bagpuss 08-20-2021 11:19 AM

Hi Dave, thank you for responding.
I'm aware the OS is not universal. I'm trying to copy an old Intel clone from one external drive to another (faster) external drive, which I will then run on an Intel Mac. The only involvement of the M1 is... cloning one external drive to another. Perhaps even this is not possible?
I think maybe I'll go the slow route of using the old Intel computer to boot from the external clone, and use it to make a clone of itself to the new SSD. Cut the M1 out of the loop totally. Worth a go?

dnanian 08-20-2021 01:00 PM

You can't copy Big Sur successfully unless you're booted from it.

Bagpuss 08-22-2021 06:35 AM

Hi Dave,
thanks, but I'm not copying Big Sur, I'm trying to copy an external clone of Catalina to another disk, using Big Sur.

Anyway, I've now tried booting into the old clone (Catalina) and using it to create a clone to the SSD. This "works", but I still get the "Can't change the startup disk to the selected disk, Running bless to place boot files failed". (There's no Big Sur/M1 involvement at all.)

Something simple, or should I just give up and move on?

Thank you!

dnanian 08-22-2021 07:51 AM

So, if you're getting a bless error, that sometimes means the EFI volume that's on the drive is too small.

Did you erase this drive from the hardware - that is, the actual hardware entry in Disk Utility, above the volumes, outdented all the way?

All times are GMT -4. The time now is 07:25 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.