Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Upgrade from iMac to Quad G5 (

Piggy 01-05-2006 01:46 AM

Upgrade from iMac to Quad G5
I have SD2 and was going to use it to switch from an iMac to a Quad G5 but instead just moved the iMac drive to bay 2 of my Quad and set it as the boot drive. The iMac is 1.8 GHz 20" iMac (Rev. A) with 2 GB RAM and the Quad 2.7 GHz with 5 GB RAM. I'm running OS X 10.4.3. The problem I’m having is I'm not seeing the performance jump I expected for simple stuff like logging in after system restart (and the start up applications), launching applications, etc. The system profiler reports 4 CPUs, 5 GB RAM, etc. Memory intensive operations seem quicker but I haven't performed any real tests. The system just doesn't "feel" faster for basic stuff. I realize these may not be CPU intensive tasks but still expected to see a little more livelier system.

The Quad's drive specs are virtually identical: The new boot drive (my iMac's old drive) is a 300 GB Seagate ST3300831AS. (The original iMac drive developed a problem and was replaced with this drive a couple of months ago. I noticed an improvement as this drive is a little faster than the stock Maxtor.) The original Quad drive is a 500 GB Hitachi HDS725050KLA360. The Seagate drive is actually .5 ms faster in seek time if I recall.

I'm thinking the issue is that the lack of performance gain I'm seeing is disk I/O and that the iMac wasn't lacking in power for basic stuff so I will only see the performance gain with applications that can take advantage of the additional CPUs and/or GPU. In other words, the iMac had plenty of horsepower to load applications as fast the disk I/O system could provide the data. Hence, the same basic stuff on the Quad isn't going to be faster because it wasn't a problem on the iMac in the first place and the Quad is relatively the same (even though the bus is faster). Still, I expected the system to "feel" a little faster.

I have, however, tried Virtual PC and it didn't seem to start up much faster - and I definitely expected to see a big improvement with this application. I don't have any timing numbers - again this is just a "feeling" thing.

Could there be an operating system issue? Could there be folders or caches that I need to clear? Could there be drivers that I need? Of course I've run Software Update (it didn't find anything new to install).

I posted a message in the Apple discussion forum and the answer was to put the Seagate drive back into the iMac and perform a migration because drivers might be missing. The system seems to run fine otherwise - every application works, no crashes, hangs, etc. Are missing drivers even a possibility in this case? The answer seems a bit lame to be honest, because if the person that told me this is an expert then why didn't he just tell me to perform an Archive & Install on the Seagate disk (from the Power Mac OS X DVD of course) or install OS X to the Hitachi disk and use the Migration Assistant and access the data on the Seagate disk instead of putting the drive back in the iMac and performing the migration?

I'm posting this issue here because I think someone that truely knows the operating system will be able to tell me "yes, you really could be missing drivers" or "no, that's hogwash, Software Update would have installed any missing drivers assuming the Power Mac didn't run in the first place."

If I really am missing drivers or something there's an issue with cache files, since I have both drives in the Quad should I use SuperDuper to clone the iMac drive to the Hitachi drive and set the Hitachi drive to the boot drive, or should I load OS X on the Hitachi drive, set it as the boot drive and then use the OS X migration assistant to “migrate” from the iMac drive in bay 2 to the Hitachi drive? Other than my *perceived* performance issue, things have been running fine.



dnanian 01-05-2006 09:27 AM

You're not going to see a significant performance improvement in things that are single-threaded, Adam. So, VPC -- which is basically single-threaded -- isn't going to run faster. Yes, the additional CPU will help... but GHz isn't everything, as you can see.

While I don't think the issue is missing drivers, when moving to a brand new machine I'd suggest using Migration Assistant. Often, those machines come with special builds of the OS that contain new system enablers. Subsequent OS releases "roll things in", but when it's new it's best to migrate.

When 10.4.4 (or whatever) comes out, the OS release will be the same again, of course.

So -- definitely Migrate and see if you notice anything working better. But don't expect a huge improvement: apps have to be written to take advantage of multiple processors, and not all are... and I/O bound apps won't benefit at all.

Piggy 01-05-2006 02:47 PM

Thanks, Dave. I took your advice and here's where I'm at now - OS X is complaining about two updates that can't be installed: "The digital signature is incorrect. The package may have been tampered with or corrupted since being signed by Apple."

Here are the steps I've performed:

1. Previously erased the original startup disk (Quad Hitachi) through Disk Utility.
2. SmartCloned the startup disk (iMac Seagate) to a LaCie Firewire drive.
3. Installed OS X 10.4.2 (note .2) to the Quad Hitatchi drive in bay 1 from the Power Mac G5 install discs that came with the Quad.
4. Ran the migration assistant at the end of completion to migrate data from the iMac Seagate disk in bay 2 to the Quad Hitachi drive in bay 1.
5. Ran Software Update to update to 10.4.3. A few updates including 10.4.3 would not install.
6. Ran Software Update for everything that would install, then tried 10.4.3 update again. No joy. Tried again using MacOSXUpdateCombo10.4.3.dmg I had previously downloaded manually. This seemed to work fine.
7. Ran Software Update again - only two updates remain:
AirPort Update 2005-01, version 1.0, 1.4 MB
Security Update 2005-009, version 1.0, 5.9 MB
When I try installing these updates I receive the security update error reported at the beginning of this email.

No software updates were pending with the operating system installed on the iMac Seagate drive. Any ideas?

Update: I opted to try 2005-01, restart; 2005-009; restart. These installed properly and no updates are pending!

Any recommendations as to whether I should use the smaller, Seagate or larger, Hitatchi drive as my system and main drive? I'm thinking I should use the smaller Seagate drive as the main and system drive. If so should I use SD2 to erase or SmartUpdate the Seagate drive now that the Hitachi drive is the "most correct" drive?

Is there any effect on performance if a drive is the first or second unit of the SATA controller?

dnanian 01-05-2006 03:34 PM

This doesn't make much sense to me, actually. I don't see why SU wouldn't update the system. It *should*, Piggy... what you did is a fully supported path, as long as the 10.4.2 was from the discs that shipped with the Quad.

You can certainly use SD! to copy drive-to-drive, no problem... I don't really have a specific opinion on which drive to use, though. I don't think it's going to matter much.

The two channels of the SATA controller should behave identically...

Piggy 01-05-2006 04:02 PM

Thanks again, Dave. Maybe SU had a problem because the updates were -01 and -009 -- it seems as if it tried to install them in reverse order as manually doing -01 followed by -009 worked fine. And I offer no explanation for the 10.4.3 main update problem...

The discs I used were definately Power Mac 10.4.2 installation discs.

I am using SD erase to make the Seagate my main system drive again.

In any event things seem to be working as expected now and I should be back up on the Seagate drive soon. I'll run DiskWarrior when done, then run SD to update my clone and wait a few days before wiping the Hitachi drive.

Have a great rest of the week and weekend.

dnanian 01-05-2006 04:14 PM

Yeah, I think that's generally wise. And, let's see what happens when the inevitable 10.4.4 comes out, too. I really can't explain why 10.4.3 didn't just apply & work. Weird.

All times are GMT -4. The time now is 02:34 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.