Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Can't boot from firewire disk (

negativeduck 10-19-2004 11:15 AM

Can't boot from firewire disk
I'm sure this one has been around 300 times in the past and while I'm 99.999% convinced this is in no way a problem with the SuperDuper Package or software figured someone has probably seen this issue before and maybe could send me in the right direction.

I have a PowerBook G4 800 (titanium 15" with onboard firewire) and a Buslink 60 (60gig firewire disk.) Well I can set it under system prefs to boot from the firewire and when i reboot it still boots the internal disk. Holding down the option button the laptop never shows the firewire disk as an option to boot from. Some other info hopes of staving off questions.

So if anyone has any thoughts as to why I can't boot from firewire I'd love to hear it. Course maybe this stuff is just to old to support it?

Machine Model: PowerBook G4
CPU Type: PowerPC G4 (2.1)
Number Of CPUs: 1
CPU Speed: 800 MHz
L2 Cache (per CPU): 256 KB
L3 Cache (per CPU): 1 MB
Memory: 768 MB
Bus Speed: 133 MHz
Boot ROM Version: 4.3.7f3

FireWire Bus:

Speed: 400 Mb/sec Speed


Capacity: 57.27 GB
Manufacturer: LSI Logic
Removable Media: No
Detachable Drive: Yes
BSD Name: disk1
OS9 Drivers: No
Speed: 400 Mb/sec Speed
Unit Spec Id: 24734
Firmware Revision: Y2S4
Unit Software Version: 10483

dnanian 10-19-2004 11:21 AM

The thing to check, Mr. Duck, is whether or not this drive is bootable at all, regardless of whether or not there's a clone on it.

To do this, take your OS X disks and install a clean version of OS X on the drive, as minimally as you'd like just to get the OS on there. Try booting from that... does it work?

If not, the drive isn't boot-compatible with the Mac, and would likely explain the problem... let us know!

negativeduck 10-19-2004 11:28 AM

I had a feeling that was going to be my last option to test this theory. But for some reason was being lazy about attempting to try it that way. Will let you know what's up, and kudo's for the VERY fast response :) Color me impressed.

dnanian 10-19-2004 11:32 AM

A pleasure -- I'll look forward to hearing what's up!

arrakian 10-30-2004 01:07 PM

I have the same computer as NegativeDuck, using OSX 10.3.5, but my firewire drive is from OtherWorld Computing, and I installed two 250 gig Hitachi drives.

If the external firewire drive won't boot up with OSX, how can I get it to do this?

dnanian 10-30-2004 05:16 PM

Hi, "arrakian" -- thanks for contributing here!

If the external firewire drive won't boot with OSX, you need to contact OWC to see if they've got a firmware update for the drive that supports FireWire boot. If not, I'd return the case and get one that does!

Cleve R. 11-23-2004 09:29 PM

I'm having a similar problem with a d2 Lacie 250 GIG firewire drive running Panther. However I CAN reboot off the firewire no problem - but if I shut the computer off and restart, it defaults to the internal drive even if I've set the start up disk to default off the firewire.

Then I had an epiphany - I first hit the power button on the firewire drive and let it spin up - then I hit the power button on the computer...and booted up on the the firewire.

Its not ideal. I'd prefer to just hit the power button on my Mac as sometimes I forget to hit the hard drive button first. But it seems that the firewire drive does not awaken fast enough from the Mac's start up to make the firewire available in time for bootup.

tier0605 04-30-2005 11:42 AM

Same problem with USB external hard drive
I cloned my hard drive last night for the first time on an external usb 2.0 hard drive from IOMEGA and this morning I have tried rebooting the mac with the option key held down while pwoering up and it only finds the "Machintosh" HD. The external hard drive doesnt even show up. I have read a lot of users talk about the same problm with their firewire drive, but no one has mentioned anything about a USB externl hard drive. Does this make a difference at all? Is it possible that I cannot reboot using a usb hard drive?
I switched to the mac just a week ago, so forgive my stupid questions please.

dnanian 04-30-2005 12:00 PM

Unfortunately, the Macintosh can't boot from USB based hard drives -- only compatible FireWire ones... that would likely explain the problem.

I'd strongly suggest exchanging the drive for a FireWire one, if you can -- you'll be much happier if you can boot from it.

Note that just because you can't boot from it, that doesn't mean it's not a good backup. It's still good, and will be bootable once restored to a compatible device.

(And, truly, there are no stupid questions, so fire away!)

tier0605 04-30-2005 12:14 PM

I feared that was the case!

thanks for the prompt input! I feared that was the case - that usb hd's were not bootable because every forum on mac i found talked about booting up from firewire drives but never did they say firewire/usb hd. I am going to try and get this exchanged - I am sure I will be able to do that. It has only been a week. I will have to format the drive on my pc because I think thats the way it comes, so the next user can hook it to his pc.

Thanks again!

dnanian 04-30-2005 12:33 PM

No problem.

Dinesy 04-30-2005 12:47 PM

so it's possible that this is my problem too... My latest problem was the 10.3.9 hdiutil problem recently added to FAQs, but my second to latest problem was a full (supposedly working backup) that, when I tried to boot from it, not only wouldn't boot, but corrupted the entire hard drive. I had to reformat it again and lost the hour or so that I spent doing the backup.

Anyway, I've got a Western Digital 300GB drive inside of a StorTecc FireWire enclosure. I suspect that if my drive isn't bootable it's the fault of the enclosure (chipset maybe? - this one is prolific, not oxford). hmmm, oh well...

dnanian 04-30-2005 12:51 PM

Wow, I've never heard of booting from a drive corrupting it. That's quite strange, but it's certainly possible that the chipset is severely incompatible in a weird way. (I haven't heard of StorTecc myself -- we tend to recommend OWC, LaCie and WiebeTech enclosures since they have the best Mac support -- but people have had luck with the Maxtor OneTouch units, too.)

In any case, if the backup completed successfully -- and was a "Backup - all files" backup -- it should boot fine on a compatible device.

ttrtilley 06-22-2005 01:51 AM

The Prolific controller is the likely culprit. It's worse than that for me. I can't seem to boot from ANY firewire drive as long as this obviously untested piece to Taiwanese junk (DYNAMIC SYSTEM ELECTRONICS CORP /Zynet Polar Hd-D5-U2FW/Prolific PL3507 Combo Device/WDC WD25 00JB-55FUA0) is attached to the bus. Just wasted a whole day on this. Nothing in their FAQ about booting. I wonder if they have ever heard about booting from a firewire drive. Also, the case got abnormally hot when it remained in this failed state till morning. It is usually just luke warm (like your forehead when you've got the flu) but it became almost too hot to hold.

dnanian 06-22-2005 09:05 AM

Wow, that's pretty terrible!

We try to stick with the companies that have historically supported the Mac well -- Wiebetech, OWC and LaCie -- as I mentioned in this thread. They use Oxford chipsets, and seem to be extensively tested -- with any problem getting fixed in short order.

ttrtilley 06-23-2005 02:40 AM

I live in Taiwan, so it's easier to just go down the street and get something. It costs too much to ship things here. I do have a Wiebetech Super DriveDock that I like, except it only has one port so must go on the end of the chain. I cursed that just yesterday since nothing downstream of the Zynet is available, and the DriveDock has to be downstream. Totally disappears, not just for booting!!!!! Speaking of LaCie, their firmware upgrader wanted to upgrade the DriveDock, so I let it go ahead. Now it is a LaCie DriveDock.
I'm not sure if the Zynet/Prolific is easily upgradable. The chip says PL-3507 03497A. I wonder if I could just replace the whole controller. It is probably the least expensive component. The case itself is thick beautiful extruded aluminum. Power supply is external.

dnanian 06-23-2005 09:01 AM

Wow, only one port? Maybe you should get a FireWire hub... that might help resolve the issues. (I don't think I would have let that LaCie updater flash the DriveDock, though! ;) Yikes!)

If the board for the Prolific is a relatively standard size/type, you could probably swap out the whole controller and keep the case... just get something with an Oxford chipset and decent firmware.

angusmillar 05-08-2006 08:34 PM

I just bought a Seagate external firewire drive and was really annoyed when I discovered couldn't boot from it after cloning my drive to it (I'm using 12" powerbook)
Same as you drive appears as an option in Startup disk system preference but if selected still boots off internal, also doesn't appear as option if I boot with option key. I found this while surfing though, I'm going to try but means recloning about 300GB, not going to happen soon but maybe you may feel like giving a go. Apologies to originator of this info, I just can't remember where I got it.

In the past I have had the symptoms you describe when I have formatted an external drive with disk utility and cloned to it, and not been able to boot. The cause was that for a while (not sure about now) when Disk Utility formatted an external drive it left the "ignore ownership" box in the "Get Info" window ticked. In this situation the clone will happen OK (and it will appear as a bootable option) but not boot. It is no good unticking after the clone. It has to be unticked before the clone.

It may be worth your checking what the "ignore ownership" box says on your Seagate.

dnanian 05-08-2006 08:40 PM

That seems rather weird. SuperDuper! automatically unchecks that box, and verifies that it's unchecked, before it copies...

Thierry DL 05-13-2006 10:43 AM

I read 2 articles about Super Duper! in the French Mac press and was very excited about it. I bought it and immediately started to make a bootable clone of my internal HD to a FW800 AluIce (250 GB). It took about 2 hours to clone completely and wanted to verify that it'd boot normally.
But after pressing the "Alt" key to choose my FW800 AluIce, my Quad G5 went "mad" : all the fans were howling amazingly fast, the Apple startup and the "wheel" with grey background kept turning and turning but no boot at all, even after 10 minutes !!

I know that my FW800 AluIce is bootable as I used to use it with Intego Personal Backup, and it always worked fine. Particularly when I needed it to have a "safe & clean" bootable drive with DiskWarrior & iDefrag.

What could I do to help you help me ?

dnanian 05-13-2006 10:49 AM

Have you tried booting into Verbose boot (Cmd-Opt-v during startup) to see if any diagnostic is produced, Thierry? That'd be where I'd start.

It'd also be interesting to know if you can get into Single User mode. To try, hold down Cmd-Opt-s during startup.

Thierry DL 05-13-2006 11:35 AM

1st & 2nd tries failed. 3rd and following tries worked !! Really don't know why 'cause I didn't change anything on my system since yesterday... Well, anyway boot works, but now, when shutting down, it always freezes at closing session : dock, menu bar, desktop icons disappear. Only the mouse cursor and the background picture stay... The cursor can be moved with the mouse and the only thing that allow me to shut down is pressing the power button on the G5 for 5 to 10 seconds...
I repaired the authorizations, and no error was found.

I'll give a try with Disk Warrior to see if something bets better with this...

Thanks for the "verbose start" trick 'cause I'm not quite an "expert" on Mac OS X as everything works always fine with my mac :-)

dnanian 05-13-2006 11:41 AM

So, you didn't really change anything other than start verbosely? Do you have anything other than the drive attached to FireWire? Do you know what kind of bridge the "AluIce" uses? (I've never heard of this particular drive...)

Thierry DL 05-13-2006 01:36 PM

This is the product. This French manufacturer is well knowned in France for its good and reliable products.

It uses a ATA-FW controler Oxford 912+
I have chained an Ice FW 400 200 GB (from the same manufacturer) linked, but turned off.
Finally, I have an iSight plugged to the FireWire hub behind a 23" Apple Cinema Display HD

Meanwhile, I launched a Drive Repair with Disk Utility and had 2 errors with "Forbidden name" (???). Anyway, it has been repaired succesfully.
I am now repairing directory with Disk Warrior that tells ma that 32% of the directory items are out of order :eek:

Waiting for procedure to complete and coming back to edit the post and let you know if everything is back to order ;)

dnanian 05-13-2006 01:53 PM

OK. Again, no direct experience, but if it's got an Oxford bridge and is well regarded, sounds good.

Directory items "Out of order" doesn't really matter much at all, so I wouldn't even bother repairing it.

The "Forbidden names" are likely Photoshop license agreements (Vietnamese). Do you have Photoshop installed?

Peterbart 11-16-2006 08:25 PM

I just bought a LaCie Firewire 400 hard drive, and I seem to be unable to boot from it when it is hooked up to my Powerbook G4. I tried your trick of installing OSX on it, but it didn't work. I am wondering if this workaround would be OK.

Clone my G4 onto the LaCie Hard Drive using SuperDuper. Boot up my PowerbookG4 in firewire disk mode with my iBook running the show. Next, clean the hard drive on my G4, and then use SuperDuper to copy everything back from the LaCie hard drive to the G4. What think you Dave?

dnanian 11-16-2006 10:16 PM

That sounds like it'll work, Peter. But are you sure it's partitioned as "Apple Partition Map" (or "GUID" for Intel Macs). That's often the reason for a "no-boot"...

rzieske 04-08-2007 12:29 PM

can't boot from FW
I know this is a little off topic, but I'm not having any success on the Apple forums. The internal drive on my G5 iMac maybe dead or dying. 3 nights ago apps like PathFinder and Finder windows started to hang. I rebooted a couple times, but the system got very sluggish. I quickly dragged changed data to a FW drive. Then the session hung and the machine would not boot. I booted off of my SuperDuper! FW copy from last weekend and grabbed more data until it hung accessing that drive. I started Disk Utility and got the usual failure when trying to rebiuld the B-tree. From that point I could no longer see the internal drive. That's a great app....

I booted from the Tiger DVD but could no longer mount the internal drive. Tried to boot from the FW drive again and now I can no longer boot from FW either. Nice. Never had that happen before. I know that copy is still bootable as I have two FW drives that I rotate SuperDuper! backups to, neither will boot the iMac, but I can boot my Powerbook from them.

So: I cannot boot from internal as it can't find a system. I cannot boot from bootable FW. When I boot from Tiger DVD the installer cannot find the internal drive to install on it. Disk Utility can find the drive but (as usual) can't repair it (surprise). I let Disk Warrior run for about 24 hrs but always get sick of it and cancel. DW also says that S.M.A.R.T. says hardware is ok...

2 questions: Is it likely my internal drive is dead? Does anyone know why I can no longer boot from the FW drives?

thanks for any thoughts

dnanian 04-08-2007 12:31 PM

That's really strange; it certainly sounds like you're having hardware issues... have you tried running the hardware test on the disc that came with your Mac?

yaloxx 11-01-2007 06:01 PM

I have been playing with 2 external firewire hds lately;

Maxtor One Touch 500 gig
Western Digital 300 gig firewire/sata

I prefer to use pgp with these external hds but I would not even bother with it. I have spent hours with superduper, pgp, and osx and they do not play well because of pgp mostly.

The Maxtor 500 gig did boot to the firewire drive directly after a superduper backup but I would stay away from the drive.

The Western Digital 300 gig firewire/sata seems like a nice drive but it will not boot directly to the firewire drive even after a fresh install of osx to the drive.

It does show up under the system preferences, startup disk, but as we all know trying to boot to the firewire drive that way never works.

I always use the option key on boot up but that does not work either as of yet.

I will try some of the other boot commands but it is wierd the drive shows up as an option under the startup disk choices.

I will post an update if I resolve this.

If you want to avoid all this stuff try an old seagate external (fw) hd the one that comes in the big square yellow boxes (300/400 gig).

Those drives have worked flawlessly for me over the years with superduper and osx.

Cheers :-)

dnanian 11-01-2007 06:13 PM

What Mac, yaloxx?

yaloxx 11-02-2007 12:31 AM

iBook G4 ppc (1.42 Ghz),
osx 10.4.10,
SuperDuper 2.1.4 (v82),

Western Digital - My Book Home 320GB External Hard Drive
Model: WDH1CS3200N SKU: 8472501

Nice quick small drive...

Tried a hfs+ journaled partition, may go unjournaled when I get home see if it goes

73766737 01-27-2008 03:54 PM

My new Maxtor 500 firewire/USB drive suffers the same malady. FYI, Information on the Seagate forum relates to this problem

All times are GMT -4. The time now is 07:07 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.