Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Can't boot from firewire disk (

negativeduck 10-19-2004 12:15 PM

Can't boot from firewire disk
I'm sure this one has been around 300 times in the past and while I'm 99.999% convinced this is in no way a problem with the SuperDuper Package or software figured someone has probably seen this issue before and maybe could send me in the right direction.

I have a PowerBook G4 800 (titanium 15" with onboard firewire) and a Buslink 60 (60gig firewire disk.) Well I can set it under system prefs to boot from the firewire and when i reboot it still boots the internal disk. Holding down the option button the laptop never shows the firewire disk as an option to boot from. Some other info hopes of staving off questions.

So if anyone has any thoughts as to why I can't boot from firewire I'd love to hear it. Course maybe this stuff is just to old to support it?

Machine Model: PowerBook G4
CPU Type: PowerPC G4 (2.1)
Number Of CPUs: 1
CPU Speed: 800 MHz
L2 Cache (per CPU): 256 KB
L3 Cache (per CPU): 1 MB
Memory: 768 MB
Bus Speed: 133 MHz
Boot ROM Version: 4.3.7f3

FireWire Bus:

Speed: 400 Mb/sec Speed


Capacity: 57.27 GB
Manufacturer: LSI Logic
Removable Media: No
Detachable Drive: Yes
BSD Name: disk1
OS9 Drivers: No
Speed: 400 Mb/sec Speed
Unit Spec Id: 24734
Firmware Revision: Y2S4
Unit Software Version: 10483

dnanian 10-19-2004 12:21 PM

The thing to check, Mr. Duck, is whether or not this drive is bootable at all, regardless of whether or not there's a clone on it.

To do this, take your OS X disks and install a clean version of OS X on the drive, as minimally as you'd like just to get the OS on there. Try booting from that... does it work?

If not, the drive isn't boot-compatible with the Mac, and would likely explain the problem... let us know!

negativeduck 10-19-2004 12:28 PM

I had a feeling that was going to be my last option to test this theory. But for some reason was being lazy about attempting to try it that way. Will let you know what's up, and kudo's for the VERY fast response :) Color me impressed.

dnanian 10-19-2004 12:32 PM

A pleasure -- I'll look forward to hearing what's up!

arrakian 10-30-2004 02:07 PM

I have the same computer as NegativeDuck, using OSX 10.3.5, but my firewire drive is from OtherWorld Computing, and I installed two 250 gig Hitachi drives.

If the external firewire drive won't boot up with OSX, how can I get it to do this?

dnanian 10-30-2004 06:16 PM

Hi, "arrakian" -- thanks for contributing here!

If the external firewire drive won't boot with OSX, you need to contact OWC to see if they've got a firmware update for the drive that supports FireWire boot. If not, I'd return the case and get one that does!

Cleve R. 11-23-2004 10:29 PM

I'm having a similar problem with a d2 Lacie 250 GIG firewire drive running Panther. However I CAN reboot off the firewire no problem - but if I shut the computer off and restart, it defaults to the internal drive even if I've set the start up disk to default off the firewire.

Then I had an epiphany - I first hit the power button on the firewire drive and let it spin up - then I hit the power button on the computer...and booted up on the the firewire.

Its not ideal. I'd prefer to just hit the power button on my Mac as sometimes I forget to hit the hard drive button first. But it seems that the firewire drive does not awaken fast enough from the Mac's start up to make the firewire available in time for bootup.

tier0605 04-30-2005 12:42 PM

Same problem with USB external hard drive
I cloned my hard drive last night for the first time on an external usb 2.0 hard drive from IOMEGA and this morning I have tried rebooting the mac with the option key held down while pwoering up and it only finds the "Machintosh" HD. The external hard drive doesnt even show up. I have read a lot of users talk about the same problm with their firewire drive, but no one has mentioned anything about a USB externl hard drive. Does this make a difference at all? Is it possible that I cannot reboot using a usb hard drive?
I switched to the mac just a week ago, so forgive my stupid questions please.

dnanian 04-30-2005 01:00 PM

Unfortunately, the Macintosh can't boot from USB based hard drives -- only compatible FireWire ones... that would likely explain the problem.

I'd strongly suggest exchanging the drive for a FireWire one, if you can -- you'll be much happier if you can boot from it.

Note that just because you can't boot from it, that doesn't mean it's not a good backup. It's still good, and will be bootable once restored to a compatible device.

(And, truly, there are no stupid questions, so fire away!)

tier0605 04-30-2005 01:14 PM

I feared that was the case!

thanks for the prompt input! I feared that was the case - that usb hd's were not bootable because every forum on mac i found talked about booting up from firewire drives but never did they say firewire/usb hd. I am going to try and get this exchanged - I am sure I will be able to do that. It has only been a week. I will have to format the drive on my pc because I think thats the way it comes, so the next user can hook it to his pc.

Thanks again!

dnanian 04-30-2005 01:33 PM

No problem.

Dinesy 04-30-2005 01:47 PM

so it's possible that this is my problem too... My latest problem was the 10.3.9 hdiutil problem recently added to FAQs, but my second to latest problem was a full (supposedly working backup) that, when I tried to boot from it, not only wouldn't boot, but corrupted the entire hard drive. I had to reformat it again and lost the hour or so that I spent doing the backup.

Anyway, I've got a Western Digital 300GB drive inside of a StorTecc FireWire enclosure. I suspect that if my drive isn't bootable it's the fault of the enclosure (chipset maybe? - this one is prolific, not oxford). hmmm, oh well...

dnanian 04-30-2005 01:51 PM

Wow, I've never heard of booting from a drive corrupting it. That's quite strange, but it's certainly possible that the chipset is severely incompatible in a weird way. (I haven't heard of StorTecc myself -- we tend to recommend OWC, LaCie and WiebeTech enclosures since they have the best Mac support -- but people have had luck with the Maxtor OneTouch units, too.)

In any case, if the backup completed successfully -- and was a "Backup - all files" backup -- it should boot fine on a compatible device.

ttrtilley 06-22-2005 02:51 AM

The Prolific controller is the likely culprit. It's worse than that for me. I can't seem to boot from ANY firewire drive as long as this obviously untested piece to Taiwanese junk (DYNAMIC SYSTEM ELECTRONICS CORP /Zynet Polar Hd-D5-U2FW/Prolific PL3507 Combo Device/WDC WD25 00JB-55FUA0) is attached to the bus. Just wasted a whole day on this. Nothing in their FAQ about booting. I wonder if they have ever heard about booting from a firewire drive. Also, the case got abnormally hot when it remained in this failed state till morning. It is usually just luke warm (like your forehead when you've got the flu) but it became almost too hot to hold.

dnanian 06-22-2005 10:05 AM

Wow, that's pretty terrible!

We try to stick with the companies that have historically supported the Mac well -- Wiebetech, OWC and LaCie -- as I mentioned in this thread. They use Oxford chipsets, and seem to be extensively tested -- with any problem getting fixed in short order.

All times are GMT -4. The time now is 06:48 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.